Pierre Rudloff
8 years ago
committed by
Fredrik Fornwall
3 changed files with 37 additions and 0 deletions
@ -0,0 +1,17 @@ |
|||
diff --git a/Makefile b/Makefile
|
|||
index cf2c92a..0f2db46 100644
|
|||
--- a/Makefile
|
|||
+++ b/Makefile
|
|||
@@ -1,9 +1,9 @@
|
|||
SRCS = sslscan.c |
|||
-BINPATH = /usr/bin/
|
|||
-MANPATH = /usr/share/man/
|
|||
+BINPATH = ${prefix}/bin/
|
|||
+MANPATH = ${prefix}/share/man/
|
|||
|
|||
all: |
|||
- gcc -g -Wall -lssl -o sslscan $(SRCS) $(LDFLAGS) $(CFLAGS)
|
|||
+ $(CC) -g -Wall -lssl -lcrypto -o sslscan $(SRCS) $(LDFLAGS) $(CFLAGS) $(CPPFLAGS)
|
|||
|
|||
install: |
|||
cp sslscan $(BINPATH) |
@ -0,0 +1,8 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://sourceforge.net/projects/sslscan/ |
|||
TERMUX_PKG_DESCRIPTION="Fast SSL scanner" |
|||
TERMUX_PKG_VERSION=1.8.2 |
|||
TERMUX_PKG_SRCURL=https://sourceforge.net/projects/sslscan/files/sslscan/sslscan-${TERMUX_PKG_VERSION}.tgz/download |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
|||
TERMUX_PKG_FOLDERNAME=sslscan-${TERMUX_PKG_VERSION} |
|||
TERMUX_PKG_DEPENDS="openssl" |
|||
TERMUX_PKG_MAINTAINER="Pierre Rudloff <contact@rudloff.pro>" |
@ -0,0 +1,12 @@ |
|||
diff --git a/sslscan.c b/sslscan.c
|
|||
index 50ee6cc..bb9071b 100644
|
|||
--- a/sslscan.c
|
|||
+++ b/sslscan.c
|
|||
@@ -41,6 +41,7 @@
|
|||
#include <openssl/pkcs12.h> |
|||
#include <openssl/x509.h> |
|||
#include <openssl/x509v3.h> |
|||
+#include <netinet/in.h>
|
|||
|
|||
// Defines... |
|||
#define false 0 |
Loading…
Reference in new issue