Leonid Plyushch
5 years ago
committed by
GitHub
4 changed files with 85 additions and 0 deletions
@ -0,0 +1,24 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://boinc.berkeley.edu/ |
|||
TERMUX_PKG_DESCRIPTION="Open-source software for volunteer computing" |
|||
TERMUX_PKG_LICENSE="GPL-3.0" |
|||
_MAJOR_VERSION=7.14 |
|||
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.3 |
|||
TERMUX_PKG_SRCURL=https://github.com/BOINC/boinc/archive/client_release/${_MAJOR_VERSION}/${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_SHA256=489e0300ecb1b095f86adb3b03f9bf04f2e1944e08fd9e74a5aa9ee298036d1c |
|||
TERMUX_PKG_DEPENDS="libandroid-shmem, libc++, libcurl, openssl, zlib" |
|||
TERMUX_PKG_BUILD_IN_SRC=true |
|||
TERMUX_PKG_NO_STATICSPLIT=true |
|||
|
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" |
|||
--disable-server |
|||
--enable-client |
|||
--disable-manager |
|||
" |
|||
|
|||
TERMUX_PKG_CONFFILES="etc/boinc-client.conf" |
|||
|
|||
termux_step_pre_configure() { |
|||
CPPFLAGS+=" -DANDROID" |
|||
LDFLAGS+=" -llog" |
|||
./_autosetup |
|||
} |
@ -0,0 +1,12 @@ |
|||
diff -uNr boinc-client_release-7.14-7.14.3/lib/synch.h boinc-client_release-7.14-7.14.3.mod/lib/synch.h
|
|||
--- boinc-client_release-7.14-7.14.3/lib/synch.h 2020-03-10 01:47:48.000000000 +0000
|
|||
+++ boinc-client_release-7.14-7.14.3.mod/lib/synch.h 2020-03-20 10:26:50.144236854 +0000
|
|||
@@ -18,7 +18,7 @@
|
|||
#ifndef BOINC_SYNCH_H |
|||
#define BOINC_SYNCH_H |
|||
|
|||
-#include <sys/sem.h>
|
|||
+#include <linux/sem.h>
|
|||
|
|||
extern int create_semaphore(key_t); |
|||
extern int destroy_semaphore(key_t); |
@ -0,0 +1,19 @@ |
|||
diff -uNr boinc-client_release-7.14-7.14.3/client/Makefile.am boinc-client_release-7.14-7.14.3.mod/client/Makefile.am
|
|||
--- boinc-client_release-7.14-7.14.3/client/Makefile.am 2020-03-10 01:47:48.000000000 +0000
|
|||
+++ boinc-client_release-7.14-7.14.3.mod/client/Makefile.am 2020-03-20 10:52:41.680052794 +0000
|
|||
@@ -133,12 +133,12 @@
|
|||
|
|||
boinc$(EXEEXT): boinc_client$(EXEEXT) |
|||
rm -f boinc$(EXEEXT) .libs/boinc$(EXEEXT) |
|||
- $(LN) boinc_client$(EXEEXT) boinc$(EXEEXT)
|
|||
- if test -f .libs/boinc_client$(EXEEXT) ; then $(LN) .libs/boinc_client$(EXEEXT) .libs/boinc$(EXEEXT) ; fi
|
|||
+ $(LN) -sfr boinc_client$(EXEEXT) boinc$(EXEEXT)
|
|||
+ if test -f .libs/boinc_client$(EXEEXT) ; then $(LN) -sfr .libs/boinc_client$(EXEEXT) .libs/boinc$(EXEEXT) ; fi
|
|||
|
|||
install-exec-hook: |
|||
rm -f $(DESTDIR)$(exec_prefix)/bin/boinc$(EXEEXT) |
|||
- $(LN) $(DESTDIR)$(exec_prefix)/bin/boinc_client$(EXEEXT) $(DESTDIR)$(exec_prefix)/bin/boinc$(EXEEXT)
|
|||
+ $(LN) -sfr $(DESTDIR)$(exec_prefix)/bin/boinc_client$(EXEEXT) $(DESTDIR)$(exec_prefix)/bin/boinc$(EXEEXT)
|
|||
|
|||
## these source files need to be specified because no rule uses them. |
|||
|
@ -0,0 +1,30 @@ |
|||
diff -uNr boinc-client_release-7.14-7.14.3/client/scripts/Makefile.am boinc-client_release-7.14-7.14.3.mod/client/scripts/Makefile.am
|
|||
--- boinc-client_release-7.14-7.14.3/client/scripts/Makefile.am 2020-03-10 01:47:48.000000000 +0000
|
|||
+++ boinc-client_release-7.14-7.14.3.mod/client/scripts/Makefile.am 2020-03-20 10:47:24.478829058 +0000
|
|||
@@ -2,21 +2,21 @@
|
|||
|
|||
install-exec-hook: |
|||
chmod +x boinc-client |
|||
- if [ -d /etc/init.d ] ; then \
|
|||
+ if [ -d /notfound/etc/init.d ] ; then \
|
|||
$(INSTALL) -d $(DESTDIR)$(sysconfdir)/init.d ; \ |
|||
$(INSTALL) -b boinc-client $(DESTDIR)$(sysconfdir)/init.d/boinc-client ; \ |
|||
fi |
|||
- if [ -d /usr/lib/systemd/system ] ; then \
|
|||
+ if [ -d /notfound/usr/lib/systemd/system ] ; then \
|
|||
$(INSTALL) -d $(DESTDIR)/usr/lib/systemd/system/ ; \ |
|||
$(INSTALL_DATA) boinc-client.service $(DESTDIR)/usr/lib/systemd/system/boinc-client.service ; \ |
|||
- elif [ -d /lib/systemd/system ] ; then \
|
|||
+ elif [ -d /notfound/lib/systemd/system ] ; then \
|
|||
$(INSTALL) -d $(DESTDIR)/lib/systemd/system/ ; \ |
|||
$(INSTALL_DATA) boinc-client.service $(DESTDIR)/lib/systemd/system/boinc-client.service ; \ |
|||
fi |
|||
- if [ -d /etc/sysconfig ] ; then \
|
|||
+ if [ -d /notfound/etc/sysconfig ] ; then \
|
|||
$(INSTALL) -d $(DESTDIR)$(sysconfdir)/sysconfig ; \ |
|||
$(INSTALL_DATA) $(srcdir)/boinc-client.conf $(DESTDIR)$(sysconfdir)/sysconfig/boinc-client ; \ |
|||
- elif [ -d /etc/default ] ; then \
|
|||
+ elif [ -d /notfound/etc/default ] ; then \
|
|||
$(INSTALL) -d $(DESTDIR)$(sysconfdir)/default ; \ |
|||
$(INSTALL_DATA) $(srcdir)/boinc-client.conf $(DESTDIR)$(sysconfdir)/default/boinc-client ; \ |
|||
else \ |
Loading…
Reference in new issue