Leonid Plyushch
5 years ago
3 changed files with 42 additions and 0 deletions
@ -0,0 +1,14 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://joeyh.name/code/moreutils/ |
|||
TERMUX_PKG_DESCRIPTION="A growing collection of the unix tools that nobody thought to write thirty years ago" |
|||
TERMUX_PKG_LICENSE="GPL-2.0" |
|||
TERMUX_PKG_VERSION=0.63 |
|||
TERMUX_PKG_SRCURL=http://ftp.debian.org/debian/pool/main/m/moreutils/moreutils_$TERMUX_PKG_VERSION.orig.tar.xz |
|||
TERMUX_PKG_SHA256=01f0b331e07e62c70d58c2dabbb68f5c4ddae4ee6f2d8f070fd1e316108af72c |
|||
TERMUX_PKG_DEPENDS="perl" |
|||
TERMUX_PKG_BUILD_IN_SRC=true |
|||
|
|||
# chronic requires set of external perl modules. |
|||
TERMUX_PKG_RM_AFTER_INSTALL=" |
|||
bin/chronic |
|||
share/man/man1/chronic.1 |
|||
" |
@ -0,0 +1,14 @@ |
|||
diff -uNr moreutils-0.63/is_utf8/Makefile moreutils-0.63.mod/is_utf8/Makefile
|
|||
--- moreutils-0.63/is_utf8/Makefile 2019-01-09 17:14:34.000000000 +0200
|
|||
+++ moreutils-0.63.mod/is_utf8/Makefile 2020-01-03 20:49:32.066770922 +0200
|
|||
@@ -37,8 +37,8 @@
|
|||
SONAME = $(LINKERNAME).$(VERSION) |
|||
REALNAME = $(SONAME).$(MINOR).$(RELEASE) |
|||
|
|||
-CC = gcc
|
|||
-CFLAGS = -O3 -Wextra -Wall -ansi -Wstrict-prototypes
|
|||
+CC ?= gcc
|
|||
+CFLAGS += -Wextra -Wall -ansi -Wstrict-prototypes
|
|||
|
|||
$(NAME): $(OBJ) |
|||
$(CC) $(CFLAGS) -o $(NAME) $(OBJ) |
@ -0,0 +1,14 @@ |
|||
diff -uNr moreutils-0.63/Makefile moreutils-0.63.mod/Makefile
|
|||
--- moreutils-0.63/Makefile 2019-01-09 17:14:34.000000000 +0200
|
|||
+++ moreutils-0.63.mod/Makefile 2020-01-03 20:48:12.342120852 +0200
|
|||
@@ -1,8 +1,8 @@
|
|||
-BINS=isutf8 ifdata ifne pee sponge mispipe lckdo parallel errno
|
|||
+BINS=isutf8 ifdata ifne pee sponge mispipe lckdo errno
|
|||
PERLSCRIPTS=vidir vipe ts combine zrun chronic |
|||
MANS=sponge.1 vidir.1 vipe.1 isutf8.1 ts.1 combine.1 ifdata.1 ifne.1 pee.1 zrun.1 chronic.1 mispipe.1 lckdo.1 parallel.1 errno.1 |
|||
CFLAGS?=-O2 -g -Wall |
|||
-INSTALL_BIN?=install -s
|
|||
+INSTALL_BIN?=install
|
|||
PREFIX?=/usr |
|||
|
|||
ifneq (,$(findstring CYGWIN,$(shell uname))) |
Loading…
Reference in new issue