Fredrik Fornwall
7 years ago
3 changed files with 24 additions and 12 deletions
@ -1,12 +1,12 @@ |
|||
diff -u -r ../gnuplot-4.6.5/Makefile.in ./Makefile.in
|
|||
--- ../gnuplot-4.6.5/Makefile.in 2014-02-23 19:21:11.000000000 +0100
|
|||
+++ ./Makefile.in 2014-07-15 19:48:32.886789826 +0200
|
|||
@@ -319,7 +319,7 @@
|
|||
diff -u -r ../gnuplot-5.2.0/Makefile.in ./Makefile.in
|
|||
--- ../gnuplot-5.2.0/Makefile.in 2017-09-03 03:44:09.000000000 +0000
|
|||
+++ ./Makefile.in 2017-10-14 20:54:05.459305245 +0000
|
|||
@@ -344,7 +344,7 @@
|
|||
top_builddir = @top_builddir@ |
|||
top_srcdir = @top_srcdir@ |
|||
AUTOMAKE_OPTIONS = foreign |
|||
-SUBDIRS = config m4 term src docs $(LISPDIR) man demo tutorial share
|
|||
+SUBDIRS = config m4 term src $(LISPDIR) man tutorial share
|
|||
EXTRA_DIST = BUGS CodeStyle Copyright FAQ.pdf GNUmakefile INSTALL INSTALL.gnu \ |
|||
Makefile.maint PATCHLEVEL PGPKEYS PORTING README README.1ST \ |
|||
VERSION configure.vms pm3d win |
|||
-SUBDIRS = config m4 term src docs man demo tutorial share
|
|||
+SUBDIRS = config m4 term src man tutorial share
|
|||
EXTRA_DIST = BUGS Copyright FAQ.pdf GNUmakefile INSTALL INSTALL.gnu \ |
|||
Makefile.maint PATCHLEVEL PGPKEYS README RELEASE_NOTES \ |
|||
VERSION configure.vms win |
|||
|
@ -1,8 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://gnuplot.info/ |
|||
TERMUX_PKG_DESCRIPTION="Command-line driven graphing utility" |
|||
TERMUX_PKG_VERSION=5.0.6 |
|||
TERMUX_PKG_REVISION=2 |
|||
TERMUX_PKG_VERSION=5.2.0 |
|||
TERMUX_PKG_SHA256=7dfe6425a1a6b9349b1fb42dae46b2e52833b13e807a78a613024d6a99541e43 |
|||
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/project/gnuplot/gnuplot/${TERMUX_PKG_VERSION}/gnuplot-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_SHA256=5bbe4713e555c2e103b7d4ffd45fca69551fff09cf5c3f9cb17428aaacc9b460 |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--without-x --with-lua=no --with-bitmap-terminals" |
|||
TERMUX_PKG_DEPENDS="libandroid-support, readline, pango, libgd" |
|||
|
@ -0,0 +1,13 @@ |
|||
For WEXITSTATUS macro. |
|||
|
|||
diff -u -r ../gnuplot-5.2.0/src/command.c ./src/command.c
|
|||
--- ../gnuplot-5.2.0/src/command.c 2017-08-30 18:48:26.000000000 +0000
|
|||
+++ ./src/command.c 2017-10-14 20:56:13.905856980 +0000
|
|||
@@ -138,6 +138,7 @@
|
|||
int vms_ktid; /* key table id, for translating keystrokes */ |
|||
#endif /* VMS */ |
|||
|
|||
+#include <sys/wait.h>
|
|||
|
|||
/* static prototypes */ |
|||
static void command __PROTO((void)); |
Loading…
Reference in new issue