Browse Source

kona: update to 20190226

emacs-27
Leonid Plyushch 6 years ago
parent
commit
0cdf245b78
No known key found for this signature in database GPG Key ID: 45F2964132545795
  1. 12
      packages/kona/Makefile.patch
  2. 8
      packages/kona/build.sh
  3. 14
      packages/kona/src-getline.h.patch
  4. 8
      packages/kona/src-v.h.patch

12
packages/kona/Makefile.patch

@ -1,19 +1,19 @@
diff -u -r ../kona-Win.3.39-69/Makefile ./Makefile
--- ../kona-Win.3.39-69/Makefile 2016-04-17 14:10:22.000000000 -0400
+++ ./Makefile 2016-05-03 14:21:25.497611299 -0400
diff -uNr kona-Win64-20190226/Makefile kona-Win64-20190226.mod/Makefile
--- kona-Win64-20190226/Makefile 2019-02-26 22:13:07.000000000 +0200
+++ kona-Win64-20190226.mod/Makefile 2019-05-21 14:37:07.394973847 +0300
@@ -1,10 +1,8 @@
-PREFIX = /usr/local
-CFLAGS=-g
-PRODFLAGS = -O3 #-pg -g3
+PRODFLAGS =
+PRODFLAGS =
LIB=libkona.a
DEVFLAGS = -O0 -g3 -DDEBUG -Wunused -Wreturn-type -Wimplicit-int #-Wall
DEVFLAGS = -O0 -g3 -DDEBUG -Wall
-OS := $(shell uname -s | tr "[:upper:]" "[:lower:]")
+OS := android
# Win-64
ifeq (mingw32_nt-6.2,$(OS))
ifeq (msys_nt-10.0,$(OS))
@@ -30,16 +28,12 @@
endif

8
packages/kona/build.sh

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://github.com/kevinlawler/kona
TERMUX_PKG_DESCRIPTION="Open-source implementation of the APL-like K programming language"
TERMUX_PKG_LICENSE="ISC"
TERMUX_PKG_VERSION="3.39-69"
TERMUX_PKG_SRCURL="https://github.com/kevinlawler/kona/archive/Win.${TERMUX_PKG_VERSION}.zip"
TERMUX_PKG_SHA256=ba6d6e9a1ed58678011cdccdd94a2e42cc7bff8abfee94e8b2de9cd93f71785b
TERMUX_PKG_BUILD_IN_SRC=yes
TERMUX_PKG_MAINTAINER="Jonathan Badger @jhbadger"
TERMUX_PKG_VERSION=20190226
TERMUX_PKG_SRCURL=https://github.com/kevinlawler/kona/archive/Win64-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=26cfebd47a3ae60753fc8a910132f45cad58381155255fbac2129e4507fef403
TERMUX_PKG_BUILD_IN_SRC=yes

14
packages/kona/src-getline.h.patch

@ -1,13 +1,13 @@
diff -u -r ../kona-Win.3.39-69/src/getline.h ./src/getline.h
--- ../kona-Win.3.39-69/src/getline.h 2016-04-17 14:10:22.000000000 -0400
+++ ./src/getline.h 2016-05-03 14:15:16.755266190 -0400
@@ -7,8 +7,7 @@
diff -uNr kona-Win64-20190226/src/getline.h kona-Win64-20190226.mod/src/getline.h
--- kona-Win64-20190226/src/getline.h 2019-02-26 22:13:07.000000000 +0200
+++ kona-Win64-20190226.mod/src/getline.h 2019-05-21 14:38:35.428447096 +0300
@@ -6,8 +6,7 @@
I appender(S *s,I *n,S t,I k);
I expander(S *s,I n);
#if defined(__OpenBSD__) || defined(__NetBSD__) || \
- (defined(__MACH__) && __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1070) || \
-#if defined(__MACH__) && __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1070 || \
- defined(__ANDROID__)
+ (defined(__MACH__) && __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1070)
+#if defined(__MACH__) && __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1070
I getline(S *s,size_t * __restrict__ n,FILE *f);
I getdelim(S *s,size_t * __restrict__ n,I d,FILE *f);
#endif

8
packages/kona/src-v.h.patch

@ -1,10 +1,10 @@
diff -u -r ../kona-Win.3.39-69/src/v.h ./src/v.h
--- ../kona-Win.3.39-69/src/v.h 2016-04-17 18:10:22.000000000 +0000
+++ ./src/v.h 2017-07-06 22:54:46.265079031 +0000
diff -uNr kona-Win64-20190226/src/v.h kona-Win64-20190226.mod/src/v.h
--- kona-Win64-20190226/src/v.h 2019-02-26 22:13:07.000000000 +0200
+++ kona-Win64-20190226.mod/src/v.h 2019-05-21 14:40:16.130994527 +0300
@@ -6,3 +6,6 @@
extern V offsetSSR,offsetWhat,offsetAt,offsetDot,offsetColon; //k.c
extern K KTREE; //k.c
K wd_(S s,I n,K*dict,K func); //p.c
K wd_(S s,int n,K*dict,K func); //p.c
+
+K lookupEntryOrCreate(K *p, S k);
+K* EAP(K e);

Loading…
Cancel
Save