Fredrik Fornwall
8 years ago
2 changed files with 8 additions and 50 deletions
@ -1,9 +1,12 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://github.com/hanslub42/rlwrap |
|||
TERMUX_PKG_DESCRIPTION="Wrapper using readline to enable editing of keyboard input for commands" |
|||
TERMUX_PKG_VERSION=0.42 |
|||
TERMUX_PKG_REVISION=1 |
|||
TERMUX_PKG_VERSION=0.43 |
|||
TERMUX_PKG_SRCURL=https://fossies.org/linux/privat/rlwrap-${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ptyttylib_cv_ptys=STREAMS ac_cv_func_grantpt=yes ac_cv_func_unlockpt=yes" |
|||
# Avoid linking to libutil: |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" ac_cv_lib_util_openpty=no" |
|||
TERMUX_PKG_SHA256=4ed39d0399a82942e2edc9feed6e7736f898c58d531d47ce543a063c17f41f22 |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" |
|||
ac_cv_func_grantpt=yes |
|||
ac_cv_func_unlockpt=yes |
|||
ac_cv_lib_util_openpty=no |
|||
ptyttylib_cv_ptys=STREAMS |
|||
" |
|||
TERMUX_PKG_DEPENDS="readline" |
|||
|
@ -1,45 +0,0 @@ |
|||
diff -u -r ../rlwrap-0.42/configure ./configure
|
|||
--- ../rlwrap-0.42/configure 2014-11-14 05:16:59.000000000 -0500
|
|||
+++ ./configure 2015-05-24 18:45:34.387435144 -0400
|
|||
@@ -6610,41 +6610,9 @@
|
|||
# but they wil fail unless /no is a procfs mountpoint ;-) |
|||
|
|||
echo "Will rlwrap find command's working directory under ${opt_proc_mountpoint}/<commands pid>/cwd? let's see..." |
|||
-as_ac_File=`$as_echo "ac_cv_file_$opt_proc_mountpoint/$$/cwd/configure.ac" | $as_tr_sh`
|
|||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $opt_proc_mountpoint/$$/cwd/configure.ac" >&5
|
|||
-$as_echo_n "checking for $opt_proc_mountpoint/$$/cwd/configure.ac... " >&6; }
|
|||
-if eval \${$as_ac_File+:} false; then :
|
|||
- $as_echo_n "(cached) " >&6
|
|||
-else
|
|||
- test "$cross_compiling" = yes &&
|
|||
- as_fn_error $? "cannot check for file existence when cross compiling" "$LINENO" 5
|
|||
-if test -r "$opt_proc_mountpoint/$$/cwd/configure.ac"; then
|
|||
- eval "$as_ac_File=yes"
|
|||
-else
|
|||
- eval "$as_ac_File=no"
|
|||
-fi
|
|||
-fi
|
|||
-eval ac_res=\$$as_ac_File
|
|||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_res" >&5
|
|||
-$as_echo "$ac_res" >&6; }
|
|||
-if eval test \"x\$"$as_ac_File"\" = x"yes"; then :
|
|||
-
|
|||
-cat >>confdefs.h <<_ACEOF
|
|||
-#define `$as_echo "HAVE_$opt_proc_mountpoint/$$/cwd/configure.ac" | $as_tr_cpp` 1
|
|||
-_ACEOF
|
|||
-
|
|||
-
|
|||
-$as_echo "#define HAVE_PROC_PID_CWD 1 " >>confdefs.h
|
|||
-
|
|||
HAVE_PROC_PID_CWD=yes |
|||
|
|||
|
|||
-else
|
|||
- HAVE_PROC_PID_CWD=no
|
|||
-
|
|||
-fi
|
|||
-
|
|||
-
|
|||
|
|||
|
|||
cat >>confdefs.h <<_ACEOF |
Loading…
Reference in new issue