Fredrik Fornwall
9 years ago
2 changed files with 34 additions and 0 deletions
@ -0,0 +1,15 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://pyropus.ca/software/getmail/ |
|||
TERMUX_PKG_DESCRIPTION="fetchmail replacement relatively easy to configure" |
|||
TERMUX_PKG_VERSION=4.49.0 |
|||
TERMUX_PKG_SRCURL=http://pyropus.ca/software/getmail/old-versions/getmail-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_DEPENDS="python2" |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
|||
TERMUX_PKG_PLATFORM_INDEPENDENT=yes |
|||
|
|||
termux_step_make_install () { |
|||
python setup.py install --prefix=$TERMUX_PREFIX --force |
|||
} |
|||
|
|||
termux_step_post_massage () { |
|||
find . -path '*.pyc' -delete |
|||
} |
@ -0,0 +1,19 @@ |
|||
--- ../getmail/src/getmailcore/utilities.py 2013-09-01 04:11:31.000000000 +1000
|
|||
+++ ./getmailcore/utilities.py 2016-03-26 17:22:08.173621990 +1100
|
|||
@@ -44,6 +44,7 @@
|
|||
import getpass |
|||
import commands |
|||
import sys |
|||
+import shutil
|
|||
|
|||
# hashlib only present in python2.5, ssl in python2.6; used together |
|||
# in SSL functionality below |
|||
@@ -333,7 +334,7 @@
|
|||
|
|||
# Move message file from Maildir/tmp to Maildir/new |
|||
try: |
|||
- os.link(fname_tmp, fname_new)
|
|||
+ shutil.copy2(fname_tmp, fname_new)
|
|||
os.unlink(fname_tmp) |
|||
|
|||
except OSError: |
Loading…
Reference in new issue