Fredrik Fornwall
9 years ago
3 changed files with 86 additions and 0 deletions
@ -0,0 +1,30 @@ |
|||
diff -u -r ../ghostscript-9.18/Makefile.in ./Makefile.in
|
|||
--- ../ghostscript-9.18/Makefile.in 2015-10-05 04:21:11.000000000 -0400
|
|||
+++ ./Makefile.in 2015-12-06 16:58:25.937579450 -0500
|
|||
@@ -130,7 +130,7 @@
|
|||
|
|||
# Choose generic configuration options. |
|||
|
|||
-TARGET_ARCH_FILE=@ARCH_CONF_HEADER@
|
|||
+TARGET_ARCH_FILE=/home/fornwall/dc/packages/ghostscript/arch-arm.h
|
|||
|
|||
# -DDEBUG |
|||
# includes debugging features (-Z switch) in the code. |
|||
@@ -360,7 +360,7 @@
|
|||
# Define the name of the C compiler (target and host (AUX)) |
|||
|
|||
CC=@CC@ |
|||
-CCAUX=@CC@
|
|||
+CCAUX=$(CC_FOR_BUILD)
|
|||
|
|||
# Define the name of the linker for the final link step. |
|||
# Normally this is the same as the C compiler. |
|||
@@ -631,7 +631,7 @@
|
|||
|
|||
CCFLAGS=$(GENOPT) $(CAPOPT) $(CFLAGS) |
|||
CC_=$(CC) $(CCFLAGS) |
|||
-CCAUX_=$(CCAUX) $(CFLAGS)
|
|||
+CCAUX_=$(CCAUX)
|
|||
CC_LEAF=$(CC_) |
|||
# note gcc can't use -fomit-frame-pointer with -pg. |
|||
CC_LEAF_PG=$(CC_) |
@ -0,0 +1,41 @@ |
|||
/* Parameters derived from machine and compiler architecture. */ |
|||
/* This file is generated mechanically by genarch.c. */ |
|||
|
|||
/* ---------------- Scalar alignments ---------------- */ |
|||
|
|||
#define ARCH_ALIGN_SHORT_MOD 2 |
|||
#define ARCH_ALIGN_INT_MOD 4 |
|||
#define ARCH_ALIGN_LONG_MOD 4 |
|||
#define ARCH_ALIGN_PTR_MOD 4 |
|||
#define ARCH_ALIGN_FLOAT_MOD 4 |
|||
#define ARCH_ALIGN_DOUBLE_MOD 8 |
|||
|
|||
/* ---------------- Scalar sizes ---------------- */ |
|||
|
|||
#define ARCH_LOG2_SIZEOF_CHAR 0 |
|||
#define ARCH_LOG2_SIZEOF_SHORT 1 |
|||
#define ARCH_LOG2_SIZEOF_INT 2 |
|||
#define ARCH_LOG2_SIZEOF_LONG 2 |
|||
#define ARCH_LOG2_SIZEOF_LONG_LONG 3 |
|||
#define ARCH_SIZEOF_GX_COLOR_INDEX 8 |
|||
#define ARCH_SIZEOF_PTR 4 |
|||
#define ARCH_SIZEOF_FLOAT 4 |
|||
#define ARCH_SIZEOF_DOUBLE 8 |
|||
#define ARCH_FLOAT_MANTISSA_BITS 24 |
|||
#define ARCH_DOUBLE_MANTISSA_BITS 53 |
|||
|
|||
/* ---------------- Unsigned max values ---------------- */ |
|||
|
|||
#define ARCH_MAX_UCHAR ((unsigned char)0xff + (unsigned char)0) |
|||
#define ARCH_MAX_USHORT ((unsigned short)0xffff + (unsigned short)0) |
|||
#define ARCH_MAX_UINT ((unsigned int)~0 + (unsigned int)0) |
|||
#define ARCH_MAX_ULONG ((unsigned long)~0L + (unsigned long)0) |
|||
|
|||
/* ---------------- Miscellaneous ---------------- */ |
|||
|
|||
#define ARCH_IS_BIG_ENDIAN 1 |
|||
#define ARCH_PTRS_ARE_SIGNED 0 |
|||
#define ARCH_FLOATS_ARE_IEEE 1 |
|||
#define ARCH_ARITH_RSHIFT 2 |
|||
#define ARCH_DIV_NEG_POS_TRUNCATES 1 |
|||
|
@ -0,0 +1,15 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://www.ghostscript.com/ |
|||
TERMUX_PKG_DESCRIPTION="Interpreter for the PostScript language and for PDF" |
|||
TERMUX_PKG_VERSION=9.18 |
|||
TERMUX_PKG_SRCURL=http://downloads.ghostscript.com/public/ghostscript-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_DEPENDS="libtiff" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-system-libtiff" |
|||
|
|||
# See " it possible to cross compile GhostPCL/GhostXPS" at bottom of |
|||
# http://ghostscript.com/FAQ.html |
|||
|
|||
termux_step_pre_configure () { |
|||
local _ARCHFILE=$TERMUX_PKG_BUILDER_DIR/arch-arm.h |
|||
$TERMUX_TOUCH -d "next hour" $_ARCHFILE |
|||
perl -p -i -e "s|TARGET_ARCH_FILE=.*|TARGET_ARCH_FILE=$_ARCHFILE|" $TERMUX_PKG_SRCDIR/Makefile.in |
|||
} |
Loading…
Reference in new issue