Fredrik Fornwall
7 years ago
5 changed files with 22 additions and 52 deletions
@ -1,15 +1,25 @@ |
|||
diff -u -r ../git-1.8.5.3/daemon.c ./daemon.c
|
|||
--- ../git-1.8.5.3/daemon.c 2014-01-14 18:10:09.000000000 +0100
|
|||
+++ ./daemon.c 2014-02-02 20:29:55.000000000 +0100
|
|||
@@ -64,9 +64,11 @@
|
|||
static void logreport(int priority, const char *err, va_list params) |
|||
diff -u -r ../git-2.17.0/daemon.c ./daemon.c
|
|||
--- ../git-2.17.0/daemon.c 2018-04-02 19:44:04.000000000 +0200
|
|||
+++ ./daemon.c 2018-04-03 23:10:19.566140810 +0200
|
|||
@@ -82,9 +82,11 @@
|
|||
{ |
|||
if (log_syslog) { |
|||
switch (log_destination) { |
|||
case LOG_DESTINATION_SYSLOG: { |
|||
+ /*
|
|||
char buf[1024]; |
|||
vsnprintf(buf, sizeof(buf), err, params); |
|||
syslog(priority, "%s", buf); |
|||
+ */
|
|||
} else { |
|||
/* |
|||
* Since stderr is set to buffered mode, the |
|||
break; |
|||
} |
|||
case LOG_DESTINATION_STDERR: |
|||
@@ -1432,7 +1434,9 @@
|
|||
} |
|||
|
|||
if (log_destination == LOG_DESTINATION_SYSLOG) { |
|||
+ /*
|
|||
openlog("git-daemon", LOG_PID, LOG_DAEMON); |
|||
+ */
|
|||
set_die_routine(daemon_die); |
|||
} else |
|||
/* avoid splitting a message in the middle */ |
|||
|
@ -1,16 +0,0 @@ |
|||
The Termux git package installs git perl files to $PREFIX/share/git-perl |
|||
by patching perl/Makefile.PL, so setup that path when building perl |
|||
files in this Makefile. |
|||
|
|||
diff -u -r ../git-2.7.4/Makefile ./Makefile
|
|||
--- ../git-2.7.4/Makefile 2016-03-17 16:47:59.000000000 -0400
|
|||
+++ ./Makefile 2016-03-24 22:46:20.335193973 -0400
|
|||
@@ -1789,7 +1788,7 @@
|
|||
sed -e '1{' \ |
|||
-e ' s|#!.*perl|#!$(PERL_PATH_SQ)|' \ |
|||
-e ' h' \ |
|||
- -e ' s=.*=use lib (split(/$(pathsep)/, $$ENV{GITPERLLIB} || "'"$$INSTLIBDIR"'"));=' \
|
|||
+ -e ' s=.*=use lib (split(/$(pathsep)/, $$ENV{GITPERLLIB} || "'"@TERMUX_PREFIX@/share/git-perl"'"));=' \
|
|||
-e ' H' \ |
|||
-e ' x' \ |
|||
-e '}' \ |
@ -1,24 +0,0 @@ |
|||
Install git perl files to a local git-specific folder and |
|||
be sure to bring the private Error.pm copy with it. |
|||
|
|||
diff -u -r ../git-2.7.4/perl/Makefile.PL ./perl/Makefile.PL
|
|||
--- ../git-2.7.4/perl/Makefile.PL 2016-03-17 16:47:59.000000000 -0400
|
|||
+++ ./perl/Makefile.PL 2016-03-24 22:38:12.222059955 -0400
|
|||
@@ -38,15 +38,13 @@
|
|||
my $pm_path = $File::Find::name; |
|||
$pm_path =~ s{^\./}{}; |
|||
|
|||
- $pm{$pm_path} = '$(INST_LIBDIR)/'.$pm_path;
|
|||
+ $pm{$pm_path} = '@TERMUX_PREFIX@/share/git-perl/'.$pm_path;
|
|||
}, "Git", "Git.pm"; |
|||
|
|||
|
|||
# We come with our own bundled Error.pm. It's not in the set of default |
|||
# Perl modules so install it if it's not available on the system yet. |
|||
-if ( !eval { require Error } || $Error::VERSION < 0.15009) {
|
|||
- $pm{'private-Error.pm'} = '$(INST_LIBDIR)/Error.pm';
|
|||
-}
|
|||
+ $pm{'private-Error.pm'} = '@TERMUX_PREFIX@/share/git-perl/Error.pm';
|
|||
|
|||
# redirect stdout, otherwise the message "Writing perl.mak for Git" |
|||
# disrupts the output for the target 'instlibdir' |
Loading…
Reference in new issue