Browse Source
* liblzo: update from 2.09 to 2.10 * net-tools: add package * openvpn: update from 2.4.0 to 2.4.1 * squid: update from 3.5.24 to 3.5.25android-5
committed by
Fredrik Fornwall
9 changed files with 115 additions and 34 deletions
@ -1,37 +1,35 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://openvpn.net |
|||
TERMUX_PKG_DESCRIPTION='An easy-to-use, robust, and highly configurable VPN (Virtual Private Network)' |
|||
TERMUX_PKG_VERSION=2.4.0 |
|||
TERMUX_PKG_DEPENDS="openssl, liblzo" |
|||
TERMUX_PKG_DESCRIPTION="An easy-to-use, robust, and highly configurable VPN (Virtual Private Network)" |
|||
TERMUX_PKG_VERSION=2.4.1 |
|||
TERMUX_PKG_DEPENDS="openssl, liblzo, net-tools" |
|||
TERMUX_PKG_SRCURL=https://swupdate.openvpn.net/community/releases/openvpn-${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_SHA256=6f23ba49a1dbeb658f49c7ae17d9ea979de6d92c7357de3d55cd4525e1b2f87e |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=' --disable-plugin-auth-pam --disable-systemd --disable-debug' |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=' --enable-iproute2 --enable-small --enable-x509-alt-username' |
|||
TERMUX_PKG_MAINTAINER='Vishal Biswas @vishalbiswas' |
|||
TERMUX_PKG_SHA256=fde9e22c6df7a335d2d58c6a4d5967be76df173c766a5c51ece57fd044c76ee5 |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" --disable-plugin-auth-pam |
|||
--disable-systemd |
|||
--disable-debug |
|||
--enable-iproute2 |
|||
--enable-small |
|||
--enable-x509-alt-username |
|||
ac_cv_func_getpwnam=yes |
|||
ac_cv_func_getpass=yes |
|||
IFCONFIG=$TERMUX_PREFIX/bin/ifconfig |
|||
ROUTE=$TERMUX_PREFIX/bin/route |
|||
IPROUTE=$TERMUX_PREFIX/bin/ip |
|||
NETSTAT=$TERMUX_PREFIX/bin/netstat" |
|||
TERMUX_PKG_MAINTAINER="Vishal Biswas @vishalbiswas" |
|||
|
|||
termux_step_pre_configure () { |
|||
# we modify configure.ac |
|||
# uncomment if you want to apply configure.patch |
|||
# autoreconf -i $TERMUX_PKG_SRCDIR |
|||
|
|||
export ac_cv_func_getpwnam='yes' |
|||
# need to provide getpass, else you "can't get console input" |
|||
export ac_cv_func_getpass='yes' |
|||
cp "$TERMUX_PKG_BUILDER_DIR/netbsd_getpass.c" "$TERMUX_PKG_SRCDIR/src/openvpn/" |
|||
|
|||
# paths to external programs used by openvpn |
|||
export IFCONFIG="$TERMUX_PREFIX/bin/applets/ifconfig" |
|||
export ROUTE="$TERMUX_PREFIX/bin/applets/route" |
|||
export IPROUTE="$TERMUX_PREFIX/bin/ip" |
|||
export NETSTAT="$TERMUX_PREFIX/bin/applets/netstat" |
|||
|
|||
# CFLAGS="$CFLAGS -DTARGET_ANDROID" |
|||
LDFLAGS="$LDFLAGS -llog " |
|||
} |
|||
|
|||
termux_step_post_make_install () { |
|||
# helper script |
|||
install -m700 "${TERMUX_PKG_BUILDER_DIR}"/termux-openvpn "${TERMUX_PREFIX}"/bin/ |
|||
install -m700 "$TERMUX_PKG_BUILDER_DIR/termux-openvpn" "$TERMUX_PREFIX/bin/" |
|||
# Install examples |
|||
install -d -m755 "${TERMUX_PREFIX}"/share/openvpn/examples |
|||
cp "${TERMUX_PKG_SRCDIR}"/sample/sample-config-files/* "${TERMUX_PREFIX}"/share/openvpn/examples |
|||
install -d -m755 "$TERMUX_PREFIX/share/openvpn/examples" |
|||
cp "$TERMUX_PKG_SRCDIR"/sample/sample-config-files/* "$TERMUX_PREFIX/share/openvpn/examples" |
|||
} |
|||
|
@ -1,7 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://www.oberhumer.com/opensource/lzo |
|||
TERMUX_PKG_DESCRIPTION='Portable lossless data compression library' |
|||
TERMUX_PKG_VERSION=2.09 |
|||
TERMUX_PKG_DESCRIPTION="Portable lossless data compression library" |
|||
TERMUX_PKG_VERSION=2.10 |
|||
TERMUX_PKG_SRCURL=http://www.oberhumer.com/opensource/lzo/download/lzo-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_MAINTAINER='Vishal Biswas @vishalbiswas' |
|||
TERMUX_PKG_SHA256=f294a7ced313063c057c504257f437c8335c41bfeed23531ee4e6a2b87bcb34c |
|||
TERMUX_PKG_MAINTAINER="Vishal Biswas @vishalbiswas" |
|||
TERMUX_PKG_SHA256=c0f892943208266f9b6543b3ae308fab6284c5c90e627931446fb49b4221a072 |
|||
|
|||
|
@ -0,0 +1,23 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://net-tools.sourceforge.net/ |
|||
TERMUX_PKG_VERSION=1.60.2017.02.21 |
|||
TERMUX_PKG_DESCRIPTION="Configuration tools for Linux networking" |
|||
_commit=479bb4a7e11a4084e2935c0a576388f92469225b |
|||
TERMUX_PKG_SRCURL=https://sourceforge.net/code-snapshots/git/n/ne/net-tools/code.git/net-tools-code-$_commit.zip |
|||
TERMUX_PKG_SHA256=7e9f8e8dcbabed0c8eeb976100496567abae7ac9d92c72cebd1a9d965473e943 |
|||
TERMUX_PKG_BUILD_IN_SRC=true |
|||
TERMUX_PKG_EXTRA_MAKE_ARGS="BINDIR=$TERMUX_PREFIX/bin SBINDIR=$TERMUX_PREFIX HAVE_HOSTNAME_TOOLS=0" |
|||
|
|||
termux_step_configure () { |
|||
CFLAGS="$CFLAGS -D_LINUX_IN6_H -Dindex=strchr -Drindex=strrchr" |
|||
LDFLAGS="$LDFLAGS -llog" |
|||
sed -i "s#/usr#$TERMUX_PREFIX#" $TERMUX_PKG_SRCDIR/man/Makefile |
|||
yes "" | make config || true |
|||
} |
|||
|
|||
termux_step_make () { |
|||
make -j5 $TERMUX_PKG_EXTRA_MAKE_ARGS |
|||
} |
|||
|
|||
termux_step_make_install () { |
|||
make $TERMUX_PKG_EXTRA_MAKE_ARGS update |
|||
} |
@ -0,0 +1,10 @@ |
|||
--- ./ifconfig.c 2017-02-21 23:54:32.000000000 +0530
|
|||
+++ ../ifconfig.c 2017-04-09 14:12:07.253003297 +0530
|
|||
@@ -44,6 +44,7 @@
|
|||
#include <string.h> |
|||
#include <unistd.h> |
|||
#include <netdb.h> |
|||
+#include <arpa/inet.h>
|
|||
|
|||
/* Ugh. But libc5 doesn't provide POSIX types. */ |
|||
#include <asm/types.h> |
@ -0,0 +1,18 @@ |
|||
--- ./lib/inet.c 2017-02-21 23:54:32.000000000 +0530
|
|||
+++ ../inet.c 2017-04-09 14:43:19.639365853 +0530
|
|||
@@ -414,6 +414,7 @@
|
|||
} |
|||
} |
|||
endservent(); |
|||
+#if 0
|
|||
setprotoent(1); |
|||
while ((pe = getprotoent())) { |
|||
/* Allocate a service entry. */ |
|||
@@ -423,6 +424,7 @@
|
|||
add2list(&raw_name, item); |
|||
} |
|||
endprotoent(); |
|||
+#endif
|
|||
return (0); |
|||
} |
|||
|
@ -0,0 +1,11 @@ |
|||
--- ./lib/inet6.c 2017-02-21 23:54:32.000000000 +0530
|
|||
+++ ../inet6.c 2017-04-09 14:01:12.215538103 +0530
|
|||
@@ -46,7 +46,7 @@
|
|||
|
|||
static char *fix_v4_address(char *buf, const struct in6_addr *in6) |
|||
{ |
|||
- if (IN6_IS_ADDR_V4MAPPED(in6->s6_addr)) {
|
|||
+ if (IN6_IS_ADDR_V4MAPPED(in6)) {
|
|||
char *s =strchr(buf, '.'); |
|||
if (s) { |
|||
while (s > buf && *s != ':') |
@ -0,0 +1,10 @@ |
|||
--- ./lib/inet6_sr.c 2017-02-21 23:54:32.000000000 +0530
|
|||
+++ ../inet6_sr.c 2017-04-09 14:07:22.352743997 +0530
|
|||
@@ -35,6 +35,7 @@
|
|||
#include "intl.h" |
|||
#include "net-features.h" |
|||
#include "util.h" |
|||
+#include <linux/ipv6_route.h>
|
|||
|
|||
|
|||
extern struct aftype inet6_aftype; |
@ -0,0 +1,11 @@ |
|||
--- ./nameif.c 2017-02-21 23:54:32.000000000 +0530
|
|||
+++ ../nameif.c 2017-04-09 14:47:40.889765378 +0530
|
|||
@@ -10,7 +10,7 @@
|
|||
#endif |
|||
#include <stdio.h> |
|||
#include <getopt.h> |
|||
-#include <sys/syslog.h>
|
|||
+#include <syslog.h>
|
|||
#include <errno.h> |
|||
#include <stdlib.h> |
|||
#include <ctype.h> |
Loading…
Reference in new issue