Fredrik Fornwall
8 years ago
2 changed files with 22 additions and 27 deletions
@ -0,0 +1,16 @@ |
|||
diff -u -r ../fzf-0.16.1/src/Makefile ./src/Makefile
|
|||
--- ../fzf-0.16.1/src/Makefile 2017-01-16 04:27:40.000000000 +0100
|
|||
+++ ./src/Makefile 2017-01-16 10:30:50.941798907 +0100
|
|||
@@ -53,10 +53,8 @@
|
|||
cd $(SRCDIR) && go get -tags "$(TAGS)" |
|||
|
|||
android-build: $(SRCDIR) |
|||
- cd $(SRCDIR) && GOARCH=arm GOARM=7 CGO_ENABLED=1 go get
|
|||
- cd $(SRCDIR)/fzf && GOARCH=arm GOARM=7 CGO_ENABLED=1 go build -a -ldflags="-w -extldflags=-pie" -o $(BINARYARM7)
|
|||
- cd $(SRCDIR)/fzf && cp $(BINARYARM7) $(RELEASEARM7) && tar -czf $(RELEASEARM7).tgz $(RELEASEARM7) && \
|
|||
- rm -f $(RELEASEARM7)
|
|||
+ cd $(SRCDIR) && CGO_ENABLED=1 go get
|
|||
+ cd $(SRCDIR)/fzf && CGO_ENABLED=1 go build -a -ldflags="-w -extldflags=-pie" -o $(PREFIX)/bin/fzf
|
|||
|
|||
test: deps |
|||
SHELL=/bin/sh GOOS=$(GOOS) go test -v -tags "$(TAGS)" ./... |
Loading…
Reference in new issue