Browse Source
- Update to build on ubuntu 16.04. - Docker: Set FORCE_UNSAFE_CONFIGURE=1. Fixes #275. - Docker: Various fixes. - Neovim: No longer require lua. - Some minor package updates.android-5
Fredrik Fornwall
9 years ago
18 changed files with 205 additions and 134 deletions
@ -1,71 +1,26 @@ |
|||
FROM ubuntu:15.10 |
|||
MAINTAINER Alex Cornejo <acornejo@gmail.com> |
|||
FROM ubuntu:16.04 |
|||
|
|||
# to prevent dialog warnings |
|||
ENV DEBIAN_FRONTEND noninteractive |
|||
# to fix locale to avoid warnings |
|||
# Fix locale to avoid warnings: |
|||
RUN locale-gen en_US.UTF-8 |
|||
RUN dpkg-reconfigure locales |
|||
|
|||
RUN apt-get update && apt-get install -y \ |
|||
sudo \ |
|||
git \ |
|||
asciidoc \ |
|||
automake \ |
|||
bison \ |
|||
flex \ |
|||
cmake \ |
|||
# Used for fetching sources |
|||
curl \ |
|||
# Provides 'msgfmt' which the apt build uses |
|||
gettext \ |
|||
help2man \ |
|||
libacl1-dev \ |
|||
# Needed by luajit host part |
|||
libc6-dev-i386 \ |
|||
# Needed by apt build |
|||
libcurl4-openssl-dev \ |
|||
# Provides 'gkd-pixbuf-query-loaders' which the librsvg build uses |
|||
libgdk-pixbuf2.0-dev \ |
|||
# Provides 'glib-genmarshal' which the glib build uses |
|||
libglib2.0-dev \ |
|||
libncurses5-dev \ |
|||
libssl-dev \ |
|||
libtool \ |
|||
libtool-bin \ |
|||
lua-lpeg \ |
|||
luarocks \ |
|||
lzip \ |
|||
m4 \ |
|||
pkg-config \ |
|||
scons \ |
|||
subversion \ |
|||
texinfo \ |
|||
xmlto \ |
|||
# Provides u'makedepend' which the openssl build uses |
|||
xutils-dev \ |
|||
# Needed for android-sdk |
|||
openjdk-7-jdk |
|||
# Add this folder to the container and set as working directory: |
|||
ADD . /root/termux-packages |
|||
WORKDIR /root/termux-packages |
|||
|
|||
# Allow configure to be run as root: |
|||
ENV FORCE_UNSAFE_CONFIGURE 1 |
|||
|
|||
RUN cd /tmp && \ |
|||
curl -O http://dl.google.com/android/android-sdk_r24.3.4-linux.tgz && \ |
|||
tar xzvf /tmp/android-sdk_r24.3.4-linux.tgz && \ |
|||
RUN apt-get update && \ |
|||
apt-get install -y sudo && \ |
|||
USER=root /root/termux-packages/scripts/ubuntu-setup.sh && \ |
|||
# Setup Android SDK and NDK: |
|||
mkdir -p /root/lib && \ |
|||
cd /root/lib && \ |
|||
curl -o sdk.tgz http://dl.google.com/android/android-sdk_r24.3.4-linux.tgz && \ |
|||
tar xzvf sdk.tgz && \ |
|||
mv android-sdk-linux android-sdk && \ |
|||
curl -o ndk.zip http://dl.google.com/android/repository/android-ndk-r11-linux-x86_64.zip && \ |
|||
unzip ndk.zip && \ |
|||
mkdir /root/lib && \ |
|||
mv /tmp/android-sdk-linux /root/lib/android-sdk && \ |
|||
mv /tmp/android-ndk-r11 /root/lib/android-ndk && \ |
|||
rm -fr /tmp/* |
|||
|
|||
RUN mkdir -p /data/data/com.termux/files/usr && mkdir -p /root/termux-packages && \ |
|||
# Install neovim dependencies |
|||
luarocks install lpeg && \ |
|||
luarocks install mpack && \ |
|||
luarocks install luabitop |
|||
|
|||
ADD scripts /root/termux-packages/scripts |
|||
ADD *.sh /root/termux-packages/ |
|||
ADD *.spec /root/termux-packages/ |
|||
ADD packages /root/termux-packages/packages |
|||
ADD ndk_patches /root/termux-packages/ndk_patches |
|||
mv android-ndk-r11 android-ndk && \ |
|||
/root/termux-packages/scripts/install-sdk.sh |
|||
|
@ -1,8 +0,0 @@ |
|||
#!/bin/sh |
|||
|
|||
# Read settings from .termuxrc if existing |
|||
test -f $HOME/.termuxrc && . $HOME/.termuxrc |
|||
: ${ANDROID_HOME:="${HOME}/lib/android-sdk"} |
|||
|
|||
$ANDROID_HOME/tools/android update sdk --no-ui --all --no-https -t "build-tools-23.0.2" |
|||
$ANDROID_HOME/tools/android update sdk --no-ui --all --no-https -t "android-23" |
@ -0,0 +1,13 @@ |
|||
diff -u -r ../apt-1.2.12/doc/makefile ./doc/makefile
|
|||
--- ../apt-1.2.12/doc/makefile 2016-05-11 08:57:51.000000000 +0000
|
|||
+++ ./doc/makefile 2016-05-24 20:14:30.535233236 +0000
|
|||
@@ -10,7 +10,7 @@
|
|||
LC = en |
|||
include $(DOCBOOK_H) |
|||
|
|||
-doc: manpages docbook
|
|||
+doc: manpages
|
|||
|
|||
examples/sources.list: ../vendor/current/sources.list |
|||
ln -sf '$(abspath $^)' $@ |
|||
|
@ -1,24 +0,0 @@ |
|||
diff -u -r ../dpkg-1.17.10/configure ./configure
|
|||
--- ../dpkg-1.17.10/configure 2014-06-05 21:06:21.000000000 +0200
|
|||
+++ ./configure 2014-07-11 16:43:38.654247015 +0200
|
|||
@@ -23547,7 +23547,7 @@
|
|||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking dpkg cpu type" >&5 |
|||
$as_echo_n "checking dpkg cpu type... " >&6; } |
|||
|
|||
-cpu_type=$($srcdir/run-script $PERL scripts/dpkg-architecture.pl -t$host -qDEB_HOST_ARCH_CPU 2>/dev/null)
|
|||
+cpu_type=TERMUX_ARCH
|
|||
|
|||
if test "x$cpu_type" = "x"; then |
|||
cpu_type=$host_cpu |
|||
@@ -23587,9 +23587,9 @@
|
|||
|
|||
|
|||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking dpkg architecture name" >&5 |
|||
-$as_echo_n "checking dpkg architecture name... " >&6; }
|
|||
+$as_echo_n "checking dpkg architecture name... $srcdir/run-script $PERL scripts/dpkg-architecture.pl -t$host -qDEB_HOST_ARCH" >&6; }
|
|||
|
|||
-dpkg_arch=$($srcdir/run-script $PERL scripts/dpkg-architecture.pl -t$host -qDEB_HOST_ARCH 2>/dev/null)
|
|||
+dpkg_arch=TERMUX_ARCH
|
|||
|
|||
if test "x$dpkg_arch" = "x"; then |
|||
as_fn_error $? "cannot determine host dpkg architecture" "$LINENO" 5 |
@ -0,0 +1,21 @@ |
|||
diff -u -r ../dpkg-1.18.7/configure ./configure
|
|||
--- ../dpkg-1.18.7/configure 2016-05-08 22:09:16.000000000 -0400
|
|||
+++ ./configure 2016-05-24 16:52:40.683774088 -0400
|
|||
@@ -24862,7 +24862,7 @@
|
|||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking dpkg cpu type" >&5 |
|||
$as_echo_n "checking dpkg cpu type... " >&6; } |
|||
|
|||
-cpu_type=$(PERL=$PERL $srcdir/run-script scripts/dpkg-architecture.pl -t$host -qDEB_HOST_ARCH_CPU 2>/dev/null)
|
|||
+cpu_type=TERMUX_ARCH
|
|||
|
|||
if test "x$cpu_type" = "x"; then |
|||
cpu_type=$host_cpu |
|||
@@ -24904,7 +24904,7 @@
|
|||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking dpkg architecture name" >&5 |
|||
$as_echo_n "checking dpkg architecture name... " >&6; } |
|||
|
|||
-dpkg_arch=$(PERL=$PERL $srcdir/run-script scripts/dpkg-architecture.pl -t$host -qDEB_HOST_ARCH 2>/dev/null)
|
|||
+dpkg_arch=TERMUX_ARCH
|
|||
|
|||
if test "x$dpkg_arch" = "x"; then |
|||
as_fn_error $? "cannot determine host dpkg architecture" "$LINENO" 5 |
@ -0,0 +1,105 @@ |
|||
Patch allowing building with perl 5.22. |
|||
|
|||
Will be included in the next ldns release: |
|||
http://git.nlnetlabs.nl/ldns/commit/?h=develop&id=168ee09a |
|||
|
|||
diff --git a/doc/doxyparse.pl b/doc/doxyparse.pl
|
|||
index 96a1732..a09b2e8 100755
|
|||
--- a/doc/doxyparse.pl
|
|||
+++ b/doc/doxyparse.pl
|
|||
@@ -57,10 +57,15 @@ This manpage was automaticly generated from the ldns source code by
|
|||
use of Doxygen and some perl. |
|||
"; |
|||
|
|||
-getopts("m:",\%options);
|
|||
+getopts("em:",\%options);
|
|||
# if -m manpage file is given process that file |
|||
# parse the file which tells us what manpages go together |
|||
my $functions, $see_also; |
|||
+my $i = -1;
|
|||
+my $report_errors = defined $options{'e'};
|
|||
+my $errors = 0;
|
|||
+my %unique;
|
|||
+
|
|||
if (defined $options{'m'}) { |
|||
# process |
|||
open(MAN, "<$options{'m'}") or die "Cannot open $options{'m'}"; |
|||
@@ -68,18 +73,35 @@ if (defined $options{'m'}) {
|
|||
# func1, func2, .. | see_also1, see_also2, ... |
|||
while(<MAN>) { |
|||
chomp; |
|||
+ $i += 1;
|
|||
if (/^#/) { next; } |
|||
if (/^$/) { next; } |
|||
- ($functions, $see_also) = split /[\t ]*\|[\t ]*/, $_;
|
|||
- #print "{$functions}\n";
|
|||
- #print "{$see_also}\n";
|
|||
+ my @parts = split /[\t ]*\|[\t ]*/, $_;
|
|||
+ $functions = shift @parts;
|
|||
+ $see_also = join ', ', @parts;
|
|||
+ print "{$functions}\n";
|
|||
+ print "{$see_also}\n";
|
|||
my @funcs = split /[\t ]*,[\t ]*/, $functions; |
|||
my @also = split /[\t ]*,[\t ]*/, $see_also; |
|||
$manpages{$funcs[0]} = \@funcs; |
|||
$see_also{$funcs[0]} = \@also; |
|||
+ foreach (@funcs) {
|
|||
+ if ($unique{$_}) {
|
|||
+ push $unique{$_}, ($i,);
|
|||
+ } else {
|
|||
+ $unique{$_} = [$i];
|
|||
+ }
|
|||
+ }
|
|||
#print "[", $funcs[0], "]\n"; |
|||
} |
|||
close(MAN); |
|||
+ while (($func, $lines) = each %unique ) {
|
|||
+ if (scalar @$lines > 1) {
|
|||
+ print STDERR "$func in function_manpages on lines: "
|
|||
+ . join(", ",@$lines) . "\n" if $report_errors;
|
|||
+ $errors += 1;
|
|||
+ }
|
|||
+ }
|
|||
} else { |
|||
print "Need -m file to process the .h files\n"; |
|||
exit 1; |
|||
@@ -95,7 +117,7 @@ mkdir "doc/man";
|
|||
mkdir "doc/man/man$MAN_SECTION"; |
|||
|
|||
$state = 0; |
|||
-my $i;
|
|||
+$i = 0;
|
|||
my @lines = <STDIN>; |
|||
my $max = @lines; |
|||
|
|||
@@ -273,7 +295,7 @@ foreach (keys %manpages) {
|
|||
|
|||
print MAN $MAN_MIDDLE; |
|||
|
|||
- if (defined(@$also)) {
|
|||
+ if (@$also) {
|
|||
print MAN "\n.SH SEE ALSO\n\\fI"; |
|||
print MAN join "\\fR, \\fI", @$also; |
|||
print MAN "\\fR.\nAnd "; |
|||
@@ -290,7 +312,7 @@ foreach (keys %manpages) {
|
|||
# create symlinks |
|||
chdir("$BASE/man$MAN_SECTION"); |
|||
foreach (@$name) { |
|||
- print STDERR $_,"\n";
|
|||
+ print STDOUT $_,"\n";
|
|||
my $new_file = $_ . "." . $MAN_SECTION; |
|||
if ($new_file eq $symlink_file) { |
|||
next; |
|||
@@ -301,3 +323,12 @@ foreach (keys %manpages) {
|
|||
chdir("../../.."); # and back, tricky and fragile... |
|||
close(MAN); |
|||
} |
|||
+foreach (keys %api) {
|
|||
+ next if (/ / || /^$/);
|
|||
+ if (not $unique{$_}) {
|
|||
+ print STDERR "no man page for $_\n" if $report_errors;
|
|||
+ $errors += 1;
|
|||
+ }
|
|||
+}
|
|||
+
|
|||
+exit ($report_errors and $errors != 0);
|
@ -0,0 +1,7 @@ |
|||
#!/bin/sh |
|||
|
|||
# Install desired parts of the Android SDK: |
|||
test -f $HOME/.termuxrc && . $HOME/.termuxrc |
|||
: ${ANDROID_HOME:="${HOME}/lib/android-sdk"} |
|||
echo y | $ANDROID_HOME/tools/android update sdk --no-ui --all --no-https -t "build-tools-23.0.3" |
|||
echo y | $ANDROID_HOME/tools/android update sdk --no-ui --all --no-https -t "android-23" |
Loading…
Reference in new issue