Browse Source

python: Update from 3.5 to 3.6

android-5
Fredrik Fornwall 8 years ago
parent
commit
449d39d04a
  1. 5
      packages/asciinema/build.sh
  2. 6
      packages/profanity/build.sh
  3. 11
      packages/python/build.sh
  4. 30
      packages/python/dlfcn_py_android.patch32
  5. 30
      packages/python/dlfcn_py_android.patch64
  6. 12
      packages/python/posixmodule.c.patch
  7. 16
      packages/python/pwdmodule_no_pw_gecos.patch
  8. 5
      packages/ranger/build.sh
  9. 6
      packages/vim-python/build.sh
  10. 4
      packages/weechat/cmake-FindPython.cmake.patch

5
packages/asciinema/build.sh

@ -1,6 +1,7 @@
TERMUX_PKG_HOMEPAGE=https://asciinema.org/
TERMUX_PKG_DESCRIPTION="Record and share your terminal sessions, the right way"
TERMUX_PKG_VERSION=1.3.0
TERMUX_PKG_REVISION=1
# ncurses-utils for tput which asciinema uses:
TERMUX_PKG_DEPENDS="python, ncurses-utils"
TERMUX_PKG_SRCURL=https://github.com/asciinema/asciinema/archive/v${TERMUX_PKG_VERSION}.tar.gz
@ -13,8 +14,8 @@ termux_step_make () {
}
termux_step_make_install () {
export PYTHONPATH=$TERMUX_PREFIX/lib/python3.5/site-packages/
python3.5 setup.py install --prefix=$TERMUX_PREFIX --force
export PYTHONPATH=$TERMUX_PREFIX/lib/python3.6/site-packages/
python3.6 setup.py install --prefix=$TERMUX_PREFIX --force
}
termux_step_post_massage () {

6
packages/profanity/build.sh

@ -1,7 +1,7 @@
TERMUX_PKG_HOMEPAGE=http://profanity.im
TERMUX_PKG_DESCRIPTION="Profanity is a console based XMPP client written in C using ncurses and libstrophe, inspired by Irssi"
TERMUX_PKG_VERSION=0.5.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_MAINTAINER="Oliver Schmidhauser @Neo-Oli"
TERMUX_PKG_SRCURL=http://profanity.im/profanity-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="ncurses,glib,libmesode,libcurl,readline,libuuid,libotr,gpgme,python"
@ -9,8 +9,8 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" --disable-python-plugins"
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_configure() {
CPPFLAGS+=" -I$TERMUX_PREFIX/include/python3.5m"
LDFLAGS+=" -lpython3.5m"
CPPFLAGS+=" -I$TERMUX_PREFIX/include/python3.6m"
LDFLAGS+=" -lpython3.6m"
}
termux_step_post_configure() {

11
packages/python/build.sh

@ -7,10 +7,10 @@ TERMUX_PKG_DESCRIPTION="Python 3 programming language intended to enable clear p
TERMUX_PKG_DEPENDS="libandroid-support, ncurses, readline, libffi, openssl, libutil, libbz2, libsqlite, gdbm, ncurses-ui-libs, libcrypt, liblzma"
TERMUX_PKG_HOSTBUILD=true
_MAJOR_VERSION=3.5
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.2
TERMUX_PKG_REVISION=7
_MAJOR_VERSION=3.6
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.0
TERMUX_PKG_SRCURL=http://www.python.org/ftp/python/${TERMUX_PKG_VERSION}/Python-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=b0c5f904f685e32d9232f7bdcbece9819a892929063b6e385414ad2dd6a23622
# The flag --with(out)-pymalloc (disable/enable specialized mallocs) is enabled by default and causes m suffix versions of python.
# Set ac_cv_func_wcsftime=no to avoid errors such as "character U+ca0025 is not in range [U+0000; U+10ffff]"
@ -64,11 +64,6 @@ termux_step_post_make_install () {
# It is required by ensurepip so bundled with the main python package.
# Copied back in termux_step_post_massage() after the python-dev package has been built.
mv $TERMUX_PREFIX/include/python${_MAJOR_VERSION}m/pyconfig.h $TERMUX_PKG_TMPDIR/pyconfig.h
# This makefile is used by pip to compile C code, and thinks that ${TERMUX_HOST_PLATFORM}-gcc
# and other prefixed tools should be used, but we want unprefixed ones.
# Also Remove the specs flag since that is default in the gcc Termux package:
perl -p -i -e "s|${TERMUX_HOST_PLATFORM}-||g,s|${_SPECSFLAG}||g" $TERMUX_PREFIX/lib/python${_MAJOR_VERSION}/config-${_MAJOR_VERSION}m/Makefile
}
termux_step_post_massage () {

30
packages/python/dlfcn_py_android.patch32

@ -1,30 +0,0 @@
From https://github.com/kivy/python-for-android/blob/master/recipes/python/patches/fix-dlfcn.patch
See https://github.com/kivy/python-for-android/issues/141
diff -u -r ../Python-3.4.0rc1/Lib/plat-linux/DLFCN.py ./Lib/plat-linux/DLFCN.py
--- ../Python-3.4.0rc1/Lib/plat-linux/DLFCN.py 2014-02-10 23:51:49.000000000 +0100
+++ ./Lib/plat-linux/DLFCN.py 2014-02-13 03:25:19.000000000 +0100
@@ -74,10 +74,18 @@
# Included from gnu/stubs.h
# Included from bits/dlfcn.h
+
+# PATCHED FOR ANDROID (the only supported symbols are, for 32-bit):
+# enum {
+# RTLD_NOW = 0,
+# RTLD_LAZY = 1,
+# RTLD_LOCAL = 0,
+# RTLD_GLOBAL = 2,
+# };
RTLD_LAZY = 0x00001
-RTLD_NOW = 0x00002
-RTLD_BINDING_MASK = 0x3
-RTLD_NOLOAD = 0x00004
-RTLD_GLOBAL = 0x00100
+RTLD_NOW = 0x00000
+RTLD_BINDING_MASK = 0x0
+RTLD_NOLOAD = 0x00004
+RTLD_GLOBAL = 0x00002
RTLD_LOCAL = 0
-RTLD_NODELETE = 0x01000
+RTLD_NODELETE = 0x00000

30
packages/python/dlfcn_py_android.patch64

@ -1,30 +0,0 @@
From https://github.com/kivy/python-for-android/blob/master/recipes/python/patches/fix-dlfcn.patch
See https://github.com/kivy/python-for-android/issues/141
diff -u -r ../Python-3.4.0rc1/Lib/plat-linux/DLFCN.py ./Lib/plat-linux/DLFCN.py
--- ../Python-3.4.0rc1/Lib/plat-linux/DLFCN.py 2014-02-10 23:51:49.000000000 +0100
+++ ./Lib/plat-linux/DLFCN.py 2014-02-13 03:25:19.000000000 +0100
@@ -74,10 +74,18 @@
# Included from gnu/stubs.h
# Included from bits/dlfcn.h
+
+# PATCHED FOR ANDROID (the only supported symbols are, for 64-bit):
+# enum {
+# RTLD_NOW = 2,
+# RTLD_LAZY = 1,
+# RTLD_LOCAL = 0,
+# RTLD_GLOBAL = 0x00100,
+# };
RTLD_LAZY = 0x00001
-RTLD_NOW = 0x00002
-RTLD_BINDING_MASK = 0x3
-RTLD_NOLOAD = 0x00004
-RTLD_GLOBAL = 0x00100
+RTLD_NOW = 0x00002
+RTLD_BINDING_MASK = 0x0
+RTLD_NOLOAD = 0x00004
+RTLD_GLOBAL = 0x00100
RTLD_LOCAL = 0
-RTLD_NODELETE = 0x01000
+RTLD_NODELETE = 0x00000

12
packages/python/posixmodule.c.patch

@ -1,12 +0,0 @@
diff -u -r ../Python-3.4.1/Modules/posixmodule.c ./Modules/posixmodule.c
--- ../Python-3.4.1/Modules/posixmodule.c 2014-05-19 07:19:39.000000000 +0200
+++ ./Modules/posixmodule.c 2014-06-25 21:42:11.191524129 +0200
@@ -6048,7 +6048,7 @@
if (_Py_set_inheritable(master_fd, 0, NULL) < 0)
goto posix_error;
-#if !defined(__CYGWIN__) && !defined(HAVE_DEV_PTC)
+#if !defined(__CYGWIN__) && !defined(HAVE_DEV_PTC) && !defined(__ANDROID__)
ioctl(slave_fd, I_PUSH, "ptem"); /* push ptem */
ioctl(slave_fd, I_PUSH, "ldterm"); /* push ldterm */
#ifndef __hpux

16
packages/python/pwdmodule_no_pw_gecos.patch

@ -1,16 +0,0 @@
diff -u -r ../Python-3.4.0rc1/Modules/pwdmodule.c ./Modules/pwdmodule.c
--- ../Python-3.4.0rc1/Modules/pwdmodule.c 2014-02-10 23:51:50.000000000 +0100
+++ ./Modules/pwdmodule.c 2014-02-13 02:16:12.000000000 +0100
@@ -72,7 +72,12 @@
SETS(setIndex++, p->pw_passwd);
PyStructSequence_SET_ITEM(v, setIndex++, _PyLong_FromUid(p->pw_uid));
PyStructSequence_SET_ITEM(v, setIndex++, _PyLong_FromGid(p->pw_gid));
+#ifdef __ANDROID__
+ SETS(setIndex++, Py_None);
+ Py_INCREF(Py_None);
+#else
SETS(setIndex++, p->pw_gecos);
+#endif
SETS(setIndex++, p->pw_dir);
SETS(setIndex++, p->pw_shell);

5
packages/ranger/build.sh

@ -1,7 +1,6 @@
TERMUX_PKG_HOMEPAGE=http://ranger.nongnu.org/
TERMUX_PKG_DESCRIPTION="File manager with VI key bindings"
TERMUX_PKG_VERSION=1.7.2
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=1.8.1
TERMUX_PKG_SRCURL=http://ranger.nongnu.org/ranger-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="python, file"
TERMUX_PKG_FOLDERNAME=ranger-${TERMUX_PKG_VERSION}
@ -9,7 +8,7 @@ TERMUX_PKG_BUILD_IN_SRC=yes
TERMUX_PKG_PLATFORM_INDEPENDENT=yes
termux_step_make_install () {
python3.5 setup.py install --prefix=$TERMUX_PREFIX --force
python3.6 setup.py install --prefix=$TERMUX_PREFIX --force
}
termux_step_post_massage () {

6
packages/vim-python/build.sh

@ -14,11 +14,11 @@ TERMUX_PKG_RM_AFTER_INSTALL='bin/rview bin/rvim bin/ex share/man/man1/evim.1 sha
# vim-python:
TERMUX_PKG_CONFLICTS="vim"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" --enable-python3interp --with-python3-config-dir=$TERMUX_PREFIX/lib/python3.5/config-3.5m/"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" vi_cv_path_python3_pfx=$TERMUX_PREFIX vi_cv_var_python3_version=3.5"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" --enable-python3interp --with-python3-config-dir=$TERMUX_PREFIX/lib/python3.6/config-3.6m/"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" vi_cv_path_python3_pfx=$TERMUX_PREFIX vi_cv_var_python3_version=3.6"
TERMUX_PKG_DESCRIPTION+=" - with python support"
termux_step_pre_configure() {
CPPFLAGS+=" -I${TERMUX_PREFIX}/include/python3.5m"
CPPFLAGS+=" -I${TERMUX_PREFIX}/include/python3.6m"
}
termux_step_pre_configure () {

4
packages/weechat/cmake-FindPython.cmake.patch

@ -64,9 +64,9 @@ diff -u -r ../weechat-1.6/cmake/FindPython.cmake ./cmake/FindPython.cmake
- endif()
- endif()
+ set(PYTHON_EXECUTABLE "@TERMUX_PREFIX@/bin/python")
+ set(PYTHON_INCLUDE_PATH "@TERMUX_PREFIX@/include/python3.5m")
+ set(PYTHON_INCLUDE_PATH "@TERMUX_PREFIX@/include/python3.6m")
+ set(PYTHON_LIBRARY "@TERMUX_PREFIX@/lib")
+ set(PYTHON_LFLAGS "-Xlinker -export-dynamic -lpython3.5m")
+ set(PYTHON_LFLAGS "-Xlinker -export-dynamic -lpython3.6m")
+ set(PYTHON_FOUND TRUE)
mark_as_advanced(

Loading…
Cancel
Save