Leonid Plyushch
5 years ago
4 changed files with 66 additions and 0 deletions
@ -0,0 +1,30 @@ |
|||
diff -uNr mupdf-1.15.0-source/Makefile mupdf-1.15.0-source.mod/Makefile
|
|||
--- mupdf-1.15.0-source/Makefile 2019-05-06 14:53:09.000000000 +0300
|
|||
+++ mupdf-1.15.0-source.mod/Makefile 2019-07-01 02:12:42.460143309 +0300
|
|||
@@ -269,7 +269,7 @@
|
|||
$(OUT)/example: docs/examples/example.c $(MUPDF_LIB) $(THIRD_LIB) |
|||
$(LINK_CMD) $(CFLAGS) $(THIRD_LIBS) |
|||
$(OUT)/multi-threaded: docs/examples/multi-threaded.c $(MUPDF_LIB) $(THIRD_LIB) |
|||
- $(LINK_CMD) $(CFLAGS) $(THIRD_LIBS) -lpthread
|
|||
+ $(LINK_CMD) $(CFLAGS) $(THIRD_LIBS)
|
|||
|
|||
# --- Update version string header --- |
|||
|
|||
@@ -303,7 +303,7 @@
|
|||
tools: $(TOOL_APPS) |
|||
apps: $(TOOL_APPS) $(VIEW_APPS) |
|||
|
|||
-install: libs apps
|
|||
+install: libs tools
|
|||
install -d $(DESTDIR)$(incdir)/mupdf |
|||
install -d $(DESTDIR)$(incdir)/mupdf/fitz |
|||
install -d $(DESTDIR)$(incdir)/mupdf/pdf |
|||
@@ -315,7 +315,7 @@
|
|||
install -m 644 $(INSTALL_LIBS) $(DESTDIR)$(libdir) |
|||
|
|||
install -d $(DESTDIR)$(bindir) |
|||
- install -m 755 $(TOOL_APPS) $(VIEW_APPS) $(DESTDIR)$(bindir)
|
|||
+ install -m 755 $(TOOL_APPS) $(DESTDIR)$(bindir)
|
|||
|
|||
install -d $(DESTDIR)$(mandir)/man1 |
|||
install -m 644 docs/man/*.1 $(DESTDIR)$(mandir)/man1 |
@ -0,0 +1,12 @@ |
|||
diff -uNr mupdf-1.15.0-source/Makerules mupdf-1.15.0-source.mod/Makerules
|
|||
--- mupdf-1.15.0-source/Makerules 2019-05-06 14:53:09.000000000 +0300
|
|||
+++ mupdf-1.15.0-source.mod/Makerules 2019-07-01 02:08:28.604522907 +0300
|
|||
@@ -134,7 +134,7 @@
|
|||
HAVE_PTHREAD := yes |
|||
ifeq ($(HAVE_PTHREAD),yes) |
|||
PTHREAD_CFLAGS := |
|||
- PTHREAD_LIBS := -lpthread
|
|||
+ PTHREAD_LIBS :=
|
|||
endif |
|||
|
|||
endif |
@ -0,0 +1,19 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://mupdf.com/ |
|||
TERMUX_PKG_DESCRIPTION="Lightweight PDF and XPS viewer (library)" |
|||
TERMUX_PKG_LICENSE="AGPL-V3" |
|||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>" |
|||
TERMUX_PKG_VERSION=1.16.1 |
|||
TERMUX_PKG_REVISION=2 |
|||
TERMUX_PKG_SRCURL=https://mupdf.com/downloads/archive/mupdf-${TERMUX_PKG_VERSION}-source.tar.xz |
|||
TERMUX_PKG_SHA256=6fe78184bd5208f9595e4d7f92bc8df50af30fbe8e2c1298b581c84945f2f5da |
|||
TERMUX_PKG_DEPENDS="freetype, harfbuzz, jbig2dec, libjpeg-turbo, openjpeg, zlib" |
|||
TERMUX_PKG_EXTRA_MAKE_ARGS="prefix=$TERMUX_PREFIX build=release libs" |
|||
TERMUX_PKG_BUILD_IN_SRC=true |
|||
TERMUX_PKG_NO_DEVELSPLIT=true |
|||
TERMUX_PKG_KEEP_STATIC_LIBRARIES=true |
|||
|
|||
termux_step_pre_configure() { |
|||
rm -rf thirdparty/{freeglut,freetype,harfbuzz,jbig2dec,libjpeg,openjpeg,zlib} |
|||
export USE_SYSTEM_LIBS=yes |
|||
LDFLAGS+=" -llog" |
|||
} |
@ -0,0 +1,5 @@ |
|||
TERMUX_SUBPKG_DESCRIPTION="Lightweight PDF and XPS viewer (utilities)" |
|||
TERMUX_SUBPKG_INCLUDE=" |
|||
bin/ |
|||
share/man/man1/ |
|||
" |
Loading…
Reference in new issue