Fredrik Fornwall
6 years ago
committed by
GitHub
81 changed files with 2177 additions and 303 deletions
@ -1,44 +0,0 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://www.openssl.org/ |
|
||||
TERMUX_PKG_DESCRIPTION="Library implementing the SSL and TLS protocols as well as general purpose cryptography functions" |
|
||||
TERMUX_PKG_DEPENDS="ca-certificates" |
|
||||
TERMUX_PKG_VERSION=1.1.1~pre9 |
|
||||
TERMUX_PKG_SHA256=95ebdfbb05e8451fb01a186ccaa4a7da0eff9a48999ede9fe1a7d90db75ccb4c |
|
||||
TERMUX_PKG_SRCURL=https://www.openssl.org/source/openssl-${TERMUX_PKG_VERSION/\~/-}.tar.gz |
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="bin/c_rehash etc/ssl/misc" |
|
||||
TERMUX_PKG_BUILD_IN_SRC=yes |
|
||||
|
|
||||
# Information about compilation and installation of openssl: |
|
||||
# http://wiki.openssl.org/index.php/Compilation_and_Installation |
|
||||
|
|
||||
termux_step_configure () { |
|
||||
CFLAGS+=" -DNO_SYSLOG" |
|
||||
|
|
||||
perl -p -i -e "s@TERMUX_CFLAGS@$CFLAGS@g" Configure |
|
||||
rm -Rf $TERMUX_PREFIX/lib/libcrypto.* $TERMUX_PREFIX/lib/libssl.* |
|
||||
test $TERMUX_ARCH = "arm" && TERMUX_OPENSSL_PLATFORM="android-arm" |
|
||||
test $TERMUX_ARCH = "aarch64" && TERMUX_OPENSSL_PLATFORM="android-arm64" |
|
||||
test $TERMUX_ARCH = "i686" && TERMUX_OPENSSL_PLATFORM="android-x86" |
|
||||
test $TERMUX_ARCH = "x86_64" && TERMUX_OPENSSL_PLATFORM="android-x86_64" |
|
||||
# If enabling zlib-dynamic we need "zlib-dynamic" instead of "no-comp no-dso": |
|
||||
./Configure $TERMUX_OPENSSL_PLATFORM \ |
|
||||
--prefix=$TERMUX_PREFIX \ |
|
||||
--openssldir=$TERMUX_PREFIX/etc/tls \ |
|
||||
shared \ |
|
||||
no-ssl \ |
|
||||
no-comp \ |
|
||||
no-dso \ |
|
||||
no-hw \ |
|
||||
no-engine \ |
|
||||
no-srp \ |
|
||||
no-tests |
|
||||
} |
|
||||
|
|
||||
termux_step_make () { |
|
||||
make depend |
|
||||
make -j $TERMUX_MAKE_PROCESSES all |
|
||||
} |
|
||||
|
|
||||
termux_step_make_install () { |
|
||||
# "install_sw" instead of "install" to not install man pages: |
|
||||
make -j 1 install_sw MANDIR=$TERMUX_PREFIX/share/man MANSUFFIX=.ssl |
|
||||
} |
|
@ -1,12 +0,0 @@ |
|||||
diff -uNr openssl-1.0.2o/e_os.h openssl-1.0.2o.mod/e_os.h
|
|
||||
--- openssl-1.0.2o/e_os.h 2018-03-27 16:54:46.000000000 +0300
|
|
||||
+++ openssl-1.0.2o.mod/e_os.h 2018-06-19 15:24:21.644044663 +0300
|
|
||||
@@ -90,7 +90,7 @@
|
|
||||
* sockets will be tried in the order listed in case accessing the device |
|
||||
* files listed in DEVRANDOM did not return enough entropy. |
|
||||
*/ |
|
||||
-# define DEVRANDOM_EGD "/var/run/egd-pool","/dev/egd-pool","/etc/egd-pool","/etc/entropy"
|
|
||||
+# define DEVRANDOM_EGD "@TERMUX_PREFIX@/var/run/egd-pool","/dev/egd-pool","@TERMUX_PREFIX@/etc/egd-pool","@TERMUX_PREFIX@/etc/entropy"
|
|
||||
# endif |
|
||||
|
|
||||
# if defined(OPENSSL_SYS_VXWORKS) |
|
@ -1,3 +0,0 @@ |
|||||
TERMUX_SUBPKG_INCLUDE="bin" |
|
||||
TERMUX_SUBPKG_DESCRIPTION="The openssl command line cryptographic tool" |
|
||||
TERMUX_SUBPKG_DEPENDS="openssl" |
|
@ -1,25 +0,0 @@ |
|||||
--- ../cache/alpine-2.20/pith/Makefile.am 2015-01-12 05:12:25.585178823 +0000
|
|
||||
+++ ./pith/Makefile.am 2016-12-11 05:35:52.697766827 +0000
|
|
||||
@@ -29,19 +29,13 @@
|
|
||||
state.c status.c store.c stream.c string.c strlst.c takeaddr.c tempfile.c text.c \ |
|
||||
thread.c adjtime.c url.c util.c helptext.c smkeys.c smime.c |
|
||||
|
|
||||
-help_c_gen$(EXEEXT): $(help_c_gen_OBJECTS) $(help_c_gen_DEPENDENCIES)
|
|
||||
- @rm -f help_c_gen$(EXEEXT)
|
|
||||
- $(LINK) $(help_c_gen_OBJECTS) $(help_c_gen_LDADD)
|
|
||||
-help_h_gen$(EXEEXT): $(help_h_gen_OBJECTS) $(help_h_gen_DEPENDENCIES)
|
|
||||
- @rm -f help_h_gen$(EXEEXT)
|
|
||||
- $(LINK) $(help_h_gen_OBJECTS) $(help_h_gen_LDADD)
|
|
||||
|
|
||||
-helptext.c: help_c_gen pine.hlp
|
|
||||
+helptext.c: pine.hlp
|
|
||||
./help_c_gen < pine.hlp > $@ |
|
||||
|
|
||||
-helptext.h: help_h_gen pine.hlp
|
|
||||
+helptext.h: pine.hlp
|
|
||||
./help_h_gen < pine.hlp > $@ |
|
||||
|
|
||||
AM_CPPFLAGS = -I@top_builddir@/include -I@top_srcdir@/include |
|
||||
|
|
||||
-CLEANFILES = helptext.c helptext.h help_h_gen help_c_gen
|
|
||||
+CLEANFILES = helptext.c helptext.h
|
|
@ -1,6 +1,7 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://github.com/esnet/iperf |
TERMUX_PKG_HOMEPAGE=https://github.com/esnet/iperf |
||||
TERMUX_PKG_DESCRIPTION="TCP, UDP, and SCTP network bandwidth measurement tool" |
TERMUX_PKG_DESCRIPTION="TCP, UDP, and SCTP network bandwidth measurement tool" |
||||
TERMUX_PKG_VERSION=3.6 |
TERMUX_PKG_VERSION=3.6 |
||||
|
TERMUX_PKG_REVISION=1 |
||||
TERMUX_PKG_SHA256=de5d51e46dc460cc590fb4d44f95e7cad54b74fea1eba7d6ebd6f8887d75946e |
TERMUX_PKG_SHA256=de5d51e46dc460cc590fb4d44f95e7cad54b74fea1eba7d6ebd6f8887d75946e |
||||
TERMUX_PKG_SRCURL=https://fossies.org/linux/privat/iperf-$TERMUX_PKG_VERSION.tar.gz |
TERMUX_PKG_SRCURL=https://fossies.org/linux/privat/iperf-$TERMUX_PKG_VERSION.tar.gz |
||||
TERMUX_PKG_DEPENDS="openssl" |
TERMUX_PKG_DEPENDS="openssl" |
||||
|
@ -1,6 +1,7 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://www.libssh2.org |
TERMUX_PKG_HOMEPAGE=https://www.libssh2.org |
||||
TERMUX_PKG_DESCRIPTION="Client-side library implementing the SSH2 protocol" |
TERMUX_PKG_DESCRIPTION="Client-side library implementing the SSH2 protocol" |
||||
TERMUX_PKG_VERSION=1.8.0 |
TERMUX_PKG_VERSION=1.8.0 |
||||
|
TERMUX_PKG_REVISION=1 |
||||
TERMUX_PKG_SHA256=39f34e2f6835f4b992cafe8625073a88e5a28ba78f83e8099610a7b3af4676d4 |
TERMUX_PKG_SHA256=39f34e2f6835f4b992cafe8625073a88e5a28ba78f83e8099610a7b3af4676d4 |
||||
TERMUX_PKG_SRCURL=https://www.libssh2.org/download/libssh2-$TERMUX_PKG_VERSION.tar.gz |
TERMUX_PKG_SRCURL=https://www.libssh2.org/download/libssh2-$TERMUX_PKG_VERSION.tar.gz |
||||
TERMUX_PKG_DEPENDS="openssl" |
TERMUX_PKG_DEPENDS="openssl" |
||||
|
@ -0,0 +1,29 @@ |
|||||
|
diff -u -r ../nmap-7.70/libssh2/src/openssl.h ./libssh2/src/openssl.h
|
||||
|
--- ../nmap-7.70/libssh2/src/openssl.h 2017-11-11 17:43:24.000000000 +0000
|
||||
|
+++ ./libssh2/src/openssl.h 2018-08-24 08:59:09.372633959 +0000
|
||||
|
@@ -227,14 +227,18 @@
|
||||
|
#endif |
||||
|
|
||||
|
#if OPENSSL_VERSION_NUMBER >= 0x10100000L |
||||
|
-#define libssh2_crypto_init() \
|
||||
|
- ENGINE_load_builtin_engines(); \
|
||||
|
- ENGINE_register_all_complete()
|
||||
|
+# ifdef OPENSSL_NO_ENGINE
|
||||
|
+# define libssh2_crypto_init()
|
||||
|
+# else
|
||||
|
+# define libssh2_crypto_init() \
|
||||
|
+ ENGINE_load_builtin_engines(); \
|
||||
|
+ ENGINE_register_all_complete()
|
||||
|
+# endif
|
||||
|
#else |
||||
|
-#define libssh2_crypto_init() \
|
||||
|
- OpenSSL_add_all_algorithms(); \
|
||||
|
- ENGINE_load_builtin_engines(); \
|
||||
|
- ENGINE_register_all_complete()
|
||||
|
+# define libssh2_crypto_init() \
|
||||
|
+ OpenSSL_add_all_algorithms(); \
|
||||
|
+ ENGINE_load_builtin_engines(); \
|
||||
|
+ ENGINE_register_all_complete()
|
||||
|
#endif |
||||
|
|
||||
|
#define libssh2_crypto_exit() |
@ -0,0 +1,13 @@ |
|||||
|
diff -u -r ../node-v10.9.0/deps/v8/gypfiles/v8.gyp ./deps/v8/gypfiles/v8.gyp
|
||||
|
--- ../node-v10.9.0/deps/v8/gypfiles/v8.gyp 2018-08-15 13:53:24.000000000 +0000
|
||||
|
+++ ./deps/v8/gypfiles/v8.gyp 2018-08-23 21:43:30.588264328 +0000
|
||||
|
@@ -2053,8 +2053,7 @@
|
||||
|
# library order and break (see crbug.com/469973). |
||||
|
# These libraries do not exist on Mac hosted builds. |
||||
|
'libraries': [ |
||||
|
- '-ldl',
|
||||
|
- '-lrt'
|
||||
|
+ '-ldl'
|
||||
|
] |
||||
|
}] |
||||
|
] |
@ -1,12 +0,0 @@ |
|||||
diff -u -r ../node-v0.12.7/deps/npm/node_modules/osenv/node_modules/os-tmpdir/index.js ./deps/npm/node_modules/osenv/node_modules/os-tmpdir/index.js
|
|
||||
--- ../node-v0.12.7/deps/npm/node_modules/osenv/node_modules/os-tmpdir/index.js 2015-07-09 18:41:19.000000000 -0400
|
|
||||
+++ ./deps/npm/node_modules/osenv/node_modules/os-tmpdir/index.js 2015-07-24 20:56:42.278310940 -0400
|
|
||||
@@ -14,7 +14,7 @@
|
|
||||
path = process.env.TMPDIR || |
|
||||
process.env.TMP || |
|
||||
process.env.TEMP || |
|
||||
- '/tmp';
|
|
||||
+ '@TERMUX_PREFIX@/tmp';
|
|
||||
} |
|
||||
|
|
||||
if (trailingSlashRe.test(path)) { |
|
@ -0,0 +1,21 @@ |
|||||
|
diff -u -r ../node-v10.9.0/src/node_internals.h ./src/node_internals.h
|
||||
|
--- ../node-v10.9.0/src/node_internals.h 2018-08-15 13:53:35.000000000 +0000
|
||||
|
+++ ./src/node_internals.h 2018-08-24 00:07:40.104037627 +0000
|
||||
|
@@ -951,7 +951,7 @@
|
||||
|
void Umask(const v8::FunctionCallbackInfo<v8::Value>& args); |
||||
|
void Uptime(const v8::FunctionCallbackInfo<v8::Value>& args); |
||||
|
|
||||
|
-#if defined(__POSIX__) && !defined(__ANDROID__) && !defined(__CloudABI__)
|
||||
|
+#if defined(__POSIX__) && !defined(__CloudABI__)
|
||||
|
void SetGid(const v8::FunctionCallbackInfo<v8::Value>& args); |
||||
|
void SetEGid(const v8::FunctionCallbackInfo<v8::Value>& args); |
||||
|
void SetUid(const v8::FunctionCallbackInfo<v8::Value>& args); |
||||
|
@@ -963,7 +963,7 @@
|
||||
|
void GetEUid(const v8::FunctionCallbackInfo<v8::Value>& args); |
||||
|
void GetEGid(const v8::FunctionCallbackInfo<v8::Value>& args); |
||||
|
void GetGroups(const v8::FunctionCallbackInfo<v8::Value>& args); |
||||
|
-#endif // __POSIX__ && !defined(__ANDROID__) && !defined(__CloudABI__)
|
||||
|
+#endif // __POSIX__ && !defined(__CloudABI__)
|
||||
|
|
||||
|
} // namespace node |
||||
|
|
@ -0,0 +1,29 @@ |
|||||
|
diff -u -r ../node-v10.9.0/src/node_process.cc ./src/node_process.cc
|
||||
|
--- ../node-v10.9.0/src/node_process.cc 2018-08-15 13:53:35.000000000 +0000
|
||||
|
+++ ./src/node_process.cc 2018-08-23 23:40:53.046488108 +0000
|
||||
|
@@ -20,7 +20,7 @@
|
||||
|
#include <unistd.h> // setuid, getuid |
||||
|
#endif |
||||
|
|
||||
|
-#if defined(__POSIX__) && !defined(__ANDROID__) && !defined(__CloudABI__)
|
||||
|
+#if defined(__POSIX__) && !defined(__CloudABI__)
|
||||
|
#include <pwd.h> // getpwnam() |
||||
|
#include <grp.h> // getgrnam() |
||||
|
#endif |
||||
|
@@ -247,7 +247,7 @@
|
||||
|
} |
||||
|
|
||||
|
|
||||
|
-#if defined(__POSIX__) && !defined(__ANDROID__) && !defined(__CloudABI__)
|
||||
|
+#if defined(__POSIX__) && !defined(__CloudABI__)
|
||||
|
|
||||
|
static const uid_t uid_not_found = static_cast<uid_t>(-1); |
||||
|
static const gid_t gid_not_found = static_cast<gid_t>(-1); |
||||
|
@@ -546,6 +546,6 @@
|
||||
|
return env->ThrowErrnoException(errno, "initgroups"); |
||||
|
} |
||||
|
|
||||
|
-#endif // __POSIX__ && !defined(__ANDROID__) && !defined(__CloudABI__)
|
||||
|
+#endif // __POSIX__ && !defined(__CloudABI__)
|
||||
|
|
||||
|
} // namespace node |
File diff suppressed because it is too large
@ -1,48 +0,0 @@ |
|||||
The first chunks are to set custom CFLAGS. |
|
||||
|
|
||||
The last chunk is a fix for the no-hw option - see no-hw-option.patch |
|
||||
|
|
||||
diff -u -r ../openssl-1.0.2h/Configure ./Configure
|
|
||||
--- ../openssl-1.0.2h/Configure 2016-05-03 09:44:42.000000000 -0400
|
|
||||
+++ ./Configure 2016-06-21 17:46:40.583766442 -0400
|
|
||||
@@ -403,7 +403,7 @@
|
|
||||
# ./Configure linux-armv4 -march=armv6 -D__ARM_MAX_ARCH__=8 |
|
||||
# |
|
||||
"linux-armv4", "gcc: -O3 -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${armv4_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)", |
|
||||
-"linux-aarch64","gcc: -O3 -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${aarch64_asm}:linux64:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
+"linux-aarch64","gcc: TERMUX_CFLAGS -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${aarch64_asm}:linux64:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
# Configure script adds minimally required -march for assembly support, |
|
||||
# if no -march was specified at command line. mips32 and mips64 below |
|
||||
# refer to contemporary MIPS Architecture specifications, MIPS32 and |
|
||||
@@ -421,7 +421,7 @@
|
|
||||
"linux-ppc64le","gcc:-m64 -DL_ENDIAN -O3 -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL:$ppc64_asm:linux64le:dlfcn:linux-shared:-fPIC:-m64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR):::", |
|
||||
"linux-ia64", "gcc:-DL_ENDIAN -DTERMIO -O3 -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_UNROLL DES_INT:${ia64_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)", |
|
||||
"linux-ia64-icc","icc:-DL_ENDIAN -O2 -Wall::-D_REENTRANT::-ldl -no_cpprt:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_RISC1 DES_INT:${ia64_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)", |
|
||||
-"linux-x86_64", "gcc:-m64 -DL_ENDIAN -O3 -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:elf:dlfcn:linux-shared:-fPIC:-m64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR):::64",
|
|
||||
+"linux-x86_64", "gcc:-m64 -DL_ENDIAN TERMUX_CFLAGS -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:elf:dlfcn:linux-shared:-fPIC:-m64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR):::64",
|
|
||||
"linux-x86_64-clang", "clang: -m64 -DL_ENDIAN -O3 -Wall -Wextra $clang_disabled_warnings -Qunused-arguments::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:elf:dlfcn:linux-shared:-fPIC:-m64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR):::64", |
|
||||
"debug-linux-x86_64-clang", "clang: -DBN_DEBUG -DREF_CHECK -DCONF_DEBUG -DCRYPTO_MDEBUG -m64 -DL_ENDIAN -g -Wall -Wextra $clang_disabled_warnings -Qunused-arguments::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:elf:dlfcn:linux-shared:-fPIC:-m64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR):::64", |
|
||||
"linux-x86_64-icc", "icc:-DL_ENDIAN -O2::-D_REENTRANT::-ldl -no_cpprt:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:elf:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR):::64", |
|
||||
@@ -469,10 +469,10 @@
|
|
||||
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}", |
|
||||
|
|
||||
# Android: linux-* but without pointers to headers and libs. |
|
||||
-"android","gcc:-mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
-"android-x86","gcc:-mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:".eval{my $asm=${x86_elf_asm};$asm=~s/:elf/:android/;$asm}.":dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
-"android-armv7","gcc:-march=armv7-a -mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${armv4_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
-"android-mips","gcc:-mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${mips32_asm}:o32:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
+"android","gcc: TERMUX_CFLAGS -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
+"android-x86","gcc: TERMUX_CFLAGS -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:".eval{my $asm=${x86_elf_asm};$asm=~s/:elf/:android/;$asm}.":dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
+"android-armv7","gcc: TERMUX_CFLAGS -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${armv4_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
+"android-mips","gcc: TERMUX_CFLAGS -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${mips32_asm}:o32:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
|
|
||||
|
|
||||
#### *BSD [do see comment about ${BSDthreads} above!] |
|
||||
"BSD-generic32","gcc:-O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)", |
|
||||
@@ -1157,6 +1157,7 @@
|
|
||||
print " OPENSSL_NO_$ALGO"; |
|
||||
|
|
||||
if (/^err$/) { $flags .= "-DOPENSSL_NO_ERR "; } |
|
||||
+ elsif (/^hw$/) { $flags .= "-DOPENSSL_NO_HW "; }
|
|
||||
elsif (/^asm$/) { $no_asm = 1; } |
|
||||
} |
|
||||
else |
|
@ -1,27 +0,0 @@ |
|||||
"openssl 1.0.0b fails to install when compiled with the no-hw option" |
|
||||
http://rt.openssl.org/Ticket/Display.html?id=2384&user=guest&pass=guest |
|
||||
|
|
||||
On part is extracted to Configure.patch |
|
||||
|
|
||||
diff -u -r ../openssl-1.0.1f/engines/Makefile ./engines/Makefile
|
|
||||
--- ../openssl-1.0.1f/engines/Makefile 2014-01-06 15:36:06.000000000 +0100
|
|
||||
+++ ./engines/Makefile 2014-03-02 22:04:09.000000000 +0100
|
|
||||
@@ -113,6 +113,7 @@
|
|
||||
pfx=lib; \ |
|
||||
if [ "$(PLATFORM)" != "Cygwin" ]; then \ |
|
||||
case "$(CFLAGS)" in \ |
|
||||
+ *OPENSSL_NO_HW*) echo ... skipping install OPENSSL_NO_HW defined; continue;; \
|
|
||||
*DSO_BEOS*) sfx=".so";; \ |
|
||||
*DSO_DLFCN*) sfx=`expr "$(SHLIB_EXT)" : '.*\(\.[a-z][a-z]*\)' \| ".so"`;; \ |
|
||||
*DSO_DL*) sfx=".sl";; \ |
|
||||
diff -u -r ../openssl-1.0.1f/engines/ccgost/Makefile ./engines/ccgost/Makefile
|
|
||||
--- ../openssl-1.0.1f/engines/ccgost/Makefile 2014-01-06 15:36:06.000000000 +0100
|
|
||||
+++ ./engines/ccgost/Makefile 2014-03-02 22:04:09.000000000 +0100
|
|
||||
@@ -47,6 +47,7 @@
|
|
||||
pfx=lib; \ |
|
||||
if [ "$(PLATFORM)" != "Cygwin" ]; then \ |
|
||||
case "$(CFLAGS)" in \ |
|
||||
+ *OPENSSL_NO_HW*) echo ... skipping install OPENSSL_NO_HW defined; exit;; \
|
|
||||
*DSO_BEOS*) sfx=".so";; \ |
|
||||
*DSO_DLFCN*) sfx=`expr "$(SHLIB_EXT)" : '.*\(\.[a-z][a-z]*\)' \| ".so"`;; \ |
|
||||
*DSO_DL*) sfx=".sl";; \ |
|
@ -1,8 +1,11 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://rtmpdump.mplayerhq.hu/ |
TERMUX_PKG_HOMEPAGE=https://rtmpdump.mplayerhq.hu/ |
||||
TERMUX_PKG_DESCRIPTION="Small dumper for media content streamed over the RTMP protocol" |
TERMUX_PKG_DESCRIPTION="Small dumper for media content streamed over the RTMP protocol" |
||||
|
# NOTE: Special handling of unofficial support for openssl 1.1 from |
||||
|
# https://gitlab.com/JudgeZarbi/RTMPDump-OpenSSL-1.1 |
||||
TERMUX_PKG_VERSION=2.4 |
TERMUX_PKG_VERSION=2.4 |
||||
TERMUX_PKG_SRCURL=http://dev.gentoo.org/~hwoarang/distfiles/rtmpdump-${TERMUX_PKG_VERSION}.tar.gz |
TERMUX_PKG_REVISION=1 |
||||
TERMUX_PKG_SHA256=51f54d37907f19bfa00219d57ec6e12d09458bb31360e8cf004883df745f094c |
TERMUX_PKG_SRCURL=https://gitlab.com/JudgeZarbi/RTMPDump-OpenSSL-1.1/-/archive/019592918b0f961104eaf71b56c1db0fa26ed497/RTMPDump-OpenSSL-1.1-019592918b0f961104eaf71b56c1db0fa26ed497.tar.bz2 |
||||
|
TERMUX_PKG_SHA256=42978d5b1cfe9fe4e01305f81c183935056a6c1ad46b9cd2e582f9147196fa87 |
||||
TERMUX_PKG_BUILD_IN_SRC=yes |
TERMUX_PKG_BUILD_IN_SRC=yes |
||||
TERMUX_PKG_DEPENDS="openssl" |
TERMUX_PKG_DEPENDS="openssl" |
||||
TERMUX_PKG_MAINTAINER="Pierre Rudloff @Rudloff" |
TERMUX_PKG_MAINTAINER="Pierre Rudloff @Rudloff" |
||||
|
@ -1,6 +1,7 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://www.tarsnap.com/scrypt.html |
TERMUX_PKG_HOMEPAGE=https://www.tarsnap.com/scrypt.html |
||||
TERMUX_PKG_DESCRIPTION="scrypt KDF library and file encryption tool" |
TERMUX_PKG_DESCRIPTION="scrypt KDF library and file encryption tool" |
||||
TERMUX_PKG_VERSION=1.2.1 |
TERMUX_PKG_VERSION=1.2.1 |
||||
|
TERMUX_PKG_REVISION=1 |
||||
TERMUX_PKG_SRCURL=https://www.tarsnap.com/scrypt/scrypt-1.2.1.tgz |
TERMUX_PKG_SRCURL=https://www.tarsnap.com/scrypt/scrypt-1.2.1.tgz |
||||
TERMUX_PKG_SHA256=4621f5e7da2f802e20850436219370092e9fcda93bd598f6d4236cce33f4c577 |
TERMUX_PKG_SHA256=4621f5e7da2f802e20850436219370092e9fcda93bd598f6d4236cce33f4c577 |
||||
TERMUX_PKG_DEPENDS="openssl" |
TERMUX_PKG_DEPENDS="openssl" |
||||
|
@ -1,10 +0,0 @@ |
|||||
# Android 5 requires position-independent executables, so we use the |
|
||||
# %{!S:X} Substitutes X, if the -S switch is not given to GCC" |
|
||||
# construct (see https://gcc.gnu.org/onlinedocs/gcc/Spec-Files.html for full reference) |
|
||||
# to add -fPIE and -pie flags as appropriate. |
|
||||
|
|
||||
*cc1_options: |
|
||||
+ %{!fpie: %{!fPIE: %{!fpic: %{!fPIC: %{!fno-pic:-fPIE}}}}} |
|
||||
|
|
||||
*link: |
|
||||
+ %{!nopie: %{!static: %{!shared: %{!nostdlib: %{!nostartfiles: %{!fno-PIE: %{!fno-pie: -pie}}}}}}} |
|
Loading…
Reference in new issue