Browse Source

zile: add disabled package

My hope was to use zile given that Emacs is segfaulting. The good news
is that zile builds.  The bad news is that zile also segfaults.
According to gdb, the crash is somewhere in GC_realloc.
android-5
Iain Nicol 9 years ago
parent
commit
6120715ae0
  1. 13
      disabled-packages/zile/build.sh
  2. 19
      disabled-packages/zile/help2man.patch

13
disabled-packages/zile/build.sh

@ -0,0 +1,13 @@
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/zile/
TERMUX_PKG_DESCRIPTION="Lightweight clone of the Emacs text editor"
TERMUX_PKG_VERSION=2.4.11
TERMUX_PKG_SRCURL=https://ftp.gnu.org/gnu/zile/zile-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libgc, ncurses"
# Host build for man pages generated by help2man, see patch:
TERMUX_PKG_HOSTBUILD=yes
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_configure () {
# Required because patch modifies a Makefile.am.
autoreconf
}

19
disabled-packages/zile/help2man.patch

@ -0,0 +1,19 @@
Use man pages generated by help2man in the host build.
diff -u -r ../zile-2.4.11/doc/Makefile.am ./doc/Makefile.am
--- ../zile-2.4.11/doc/Makefile.am 2014-02-24 21:42:16.000000000 +0000
+++ ./doc/Makefile.am 2015-11-14 19:40:13.163834200 +0000
@@ -27,11 +27,8 @@
EXTRA_DIST += doc/man-extras doc/zile.1.in
man_MANS = doc/zile.1
-doc/zile.1: $(srcdir)/doc/zile.1.in doc/Makefile.am config.status
- @test -d doc || mkdir doc
- rm -f $@ $@.tmp
- $(edit) $(abs_srcdir)/doc/zile.1.in >$@.tmp
- mv $@.tmp $@
+doc/zile.1:
+ cp $(top_srcdir)/../host-build/$@ $@
$(srcdir)/doc/zile.1.in: doc/man-extras build-aux/zile-help2man-wrapper configure.ac $(builddir)/src/zile$(EXEEXT)
@test -d doc || mkdir doc
Loading…
Cancel
Save