Henrik Grimler
6 years ago
306 changed files with 753 additions and 653 deletions
@ -1,17 +0,0 @@ |
|||
diff -uNr apt-1.4.8/apt-pkg/acquire-method.cc apt-1.4.8.mod/apt-pkg/acquire-method.cc
|
|||
--- apt-1.4.8/apt-pkg/acquire-method.cc 2017-09-13 19:47:33.000000000 +0300
|
|||
+++ apt-1.4.8.mod/apt-pkg/acquire-method.cc 2019-01-22 23:03:29.751025868 +0200
|
|||
@@ -458,6 +458,13 @@
|
|||
* the worker will enqueue again later on to the right queue */ |
|||
void pkgAcqMethod::Redirect(const string &NewURI) |
|||
{ |
|||
+ if (NewURI.find_first_not_of(" !\"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_`abcdefghijklmnopqrstuvwxyz{|}~") != std::string::npos)
|
|||
+ {
|
|||
+ _error->Error("SECURITY: URL redirect target contains control characters, rejecting.");
|
|||
+ Fail();
|
|||
+ return;
|
|||
+ }
|
|||
+
|
|||
std::cout << "103 Redirect\nURI: " << Queue->Uri << "\n" |
|||
<< "New-URI: " << NewURI << "\n" |
|||
<< "\n" << std::flush; |
@ -1,11 +1,13 @@ |
|||
diff -u -r ../babl-BABL_0_1_34/Makefile.am ./Makefile.am
|
|||
--- ../babl-BABL_0_1_34/Makefile.am 2017-10-06 15:15:57.000000000 +0200
|
|||
+++ ./Makefile.am 2017-10-14 20:26:51.643517261 +0200
|
|||
@@ -3,7 +3,6 @@
|
|||
diff -u -r ../babl-BABL_0_1_62/Makefile.am ./Makefile.am
|
|||
--- ../babl-BABL_0_1_62/Makefile.am 2019-02-01 16:22:50.000000000 +0000
|
|||
+++ ./Makefile.am 2019-02-03 21:11:44.103560598 +0000
|
|||
@@ -3,8 +3,7 @@
|
|||
SUBDIRS = \ |
|||
babl \ |
|||
extensions \ |
|||
- tests \
|
|||
tools |
|||
- tools \
|
|||
- tests
|
|||
+ tools
|
|||
|
|||
if ENABLE_DOCS |
|||
SUBDIRS+= docs |
|||
|
@ -1,7 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://packages.debian.org/debianutils |
|||
TERMUX_PKG_DESCRIPTION="Small utilities which are used primarily by the installation scripts of Debian packages" |
|||
TERMUX_PKG_LICENSE="GPL-2.0" |
|||
TERMUX_PKG_VERSION=4.8.6 |
|||
TERMUX_PKG_SHA256=db09047144dadf6a35d0f28977fbef83b0dd60ca32e6c8512cce2444a6423f73 |
|||
TERMUX_PKG_VERSION=4.8.6.1 |
|||
TERMUX_PKG_SHA256=099f1e8a7278b26145a2ba2dda84c4118403bfab38c8d7070a6235a7ffcb55ed |
|||
TERMUX_PKG_SRCURL=http://ftp.debian.org/debian/pool/main/d/debianutils/debianutils_${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_RM_AFTER_INSTALL="bin/installkernel share/man/man8/installkernel.8" |
|||
|
Some files were not shown because too many files changed in this diff
Loading…
Reference in new issue