committed by
Fredrik Fornwall
3 changed files with 44 additions and 0 deletions
@ -0,0 +1,10 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/gettext/ |
|||
TERMUX_PKG_DESCRIPTION="GNU Internationalization utilities" |
|||
TERMUX_PKG_VERSION=0.19.8 |
|||
TERMUX_PKG_SRCURL=https://ftp.gnu.org/pub/gnu/gettext/gettext-${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_SHA256=9c1781328238caa1685d7bc7a2e1dcf1c6c134e86b42ed554066734b621bd12f |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
|||
TERMUX_PKG_DEPENDS="pcre, liblzma, libxml2, libcroco, ncurses, libunistring" |
|||
termux_step_pre_configure () { |
|||
autoreconf |
|||
} |
@ -0,0 +1,23 @@ |
|||
--- ../cache/gettext-0.19.8/gettext-tools/gnulib-lib/Makefile.am 2016-01-20 02:38:26.000000000 +0000
|
|||
+++ ./gettext-tools/gnulib-lib/Makefile.am 2017-02-24 21:24:59.916938343 +0000
|
|||
@@ -58,7 +58,6 @@
|
|||
# Rules generated and collected by gnulib-tool. |
|||
include Makefile.gnulib |
|||
|
|||
-# Which classes to export from the shared library.
|
|||
MOOPPFLAGS += --dllexport=styled_ostream |
|||
|
|||
# OS/2 does not support a DLL name longer than 8 characters. |
|||
@@ -67,10 +66,11 @@
|
|||
endif |
|||
|
|||
# Linking with C++ libraries is needed _only_ on mingw and Cygwin. |
|||
+# .. termux edit because i can't be bothered fixing it properly.
|
|||
if !WOE32DLL |
|||
libgettextlib_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \ |
|||
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link \ |
|||
- $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(libgettextlib_la_LDFLAGS) $(LDFLAGS) \
|
|||
+ $(CCLD) $(AM_CFLAGS) $(CFLAGS) -lcroco-0.6 -lglib-2.0 -landroid-support -lpcre -lxml2 -lz -llzma -lm -lncurses -lunistring -liconv $(LDFLAGS) \
|
|||
-o $@ |
|||
else |
|||
libgettextlib_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CXX \ |
@ -0,0 +1,11 @@ |
|||
--- ../cache/gettext-0.19.8/gettext-tools/src/msginit.c 2016-05-30 09:12:33.000000000 +0000
|
|||
+++ ./gettext-tools/src/msginit.c 2017-02-23 06:45:14.705803371 +0000
|
|||
@@ -1073,7 +1073,7 @@
|
|||
struct passwd *pwd; |
|||
|
|||
pwd = get_user_pwd (); |
|||
-#if HAVE_PWD_H
|
|||
+#ifndef __ANDROID__
|
|||
if (pwd != NULL) |
|||
{ |
|||
const char *fullname; |
Loading…
Reference in new issue