4 changed files with 22 additions and 11 deletions
@ -0,0 +1,12 @@ |
|||
diff -u -r ../cmake-3.15.2/Source/CMakeLists.txt ./Source/CMakeLists.txt
|
|||
--- ../cmake-3.15.2/Source/CMakeLists.txt 2019-08-07 16:58:29.000000000 +0000
|
|||
+++ ./Source/CMakeLists.txt 2019-08-21 10:42:07.237355685 +0000
|
|||
@@ -759,7 +759,7 @@
|
|||
|
|||
# GHS support |
|||
# Works only for windows and linux |
|||
-if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Linux")
|
|||
+if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Linux" OR CMAKE_SYSTEM_NAME STREQUAL "Android")
|
|||
set(SRCS ${SRCS} |
|||
cmGlobalGhsMultiGenerator.cxx |
|||
cmGlobalGhsMultiGenerator.h |
@ -1,12 +1,12 @@ |
|||
diff -u -r ../cmake-3.10.1/Source/cmExecProgramCommand.cxx ./Source/cmExecProgramCommand.cxx
|
|||
--- ../cmake-3.10.1/Source/cmExecProgramCommand.cxx 2017-12-13 14:25:23.000000000 +0100
|
|||
+++ ./Source/cmExecProgramCommand.cxx 2017-12-15 12:18:37.696103242 +0100
|
|||
diff -u -r ../cmake-3.15.2/Source/cmExecProgramCommand.cxx ./Source/cmExecProgramCommand.cxx
|
|||
--- ../cmake-3.15.2/Source/cmExecProgramCommand.cxx 2019-08-07 16:58:29.000000000 +0000
|
|||
+++ ./Source/cmExecProgramCommand.cxx 2019-08-18 20:05:17.156753010 +0000
|
|||
@@ -205,7 +205,7 @@
|
|||
} |
|||
fflush(stdout); |
|||
fflush(stderr); |
|||
- const char* cmd[] = { "/bin/sh", "-c", command, nullptr };
|
|||
+ const char* cmd[] = { "@TERMUX_PREFIX@/bin/sh", "-c", command, nullptr };
|
|||
- const char* cmd[] = { "/bin/sh", "-c", command.c_str(), nullptr };
|
|||
+ const char* cmd[] = { "@TERMUX_PREFIX/bin/sh", "-c", command.c_str(), nullptr };
|
|||
cmsysProcess_SetCommand(cp, cmd); |
|||
#endif |
|||
|
|||
|
@ -1,10 +1,9 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://cmake.org/ |
|||
TERMUX_PKG_DESCRIPTION="Family of tools designed to build, test and package software" |
|||
TERMUX_PKG_LICENSE="BSD 3-Clause" |
|||
TERMUX_PKG_VERSION=3.14.5 |
|||
TERMUX_PKG_REVISION=2 |
|||
TERMUX_PKG_VERSION=3.15.2 |
|||
TERMUX_PKG_SRCURL=https://www.cmake.org/files/v${TERMUX_PKG_VERSION:0:4}/cmake-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_SHA256=505ae49ebe3c63c595fa5f814975d8b72848447ee13b6613b0f8b96ebda18c06 |
|||
TERMUX_PKG_SHA256=539088cb29a68e6d6a8fba5c00951e5e5b1a92c68fa38a83e1ed2f355933f768 |
|||
TERMUX_PKG_DEPENDS="libarchive, libc++, libcurl, libexpat, jsoncpp, libuv, rhash, make, clang, zlib" |
|||
TERMUX_PKG_FORCE_CMAKE=true |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="-DKWSYS_LFS_WORKS=ON -DBUILD_CursesDialog=ON" |
|||
|
Loading…
Reference in new issue