its-pointless
7 years ago
committed by
Fredrik Fornwall
17 changed files with 23 additions and 201 deletions
@ -1,201 +0,0 @@ |
|||
--- dummy.c.orig 2016-12-10 03:38:32.503722427 +0000
|
|||
+++ ./imap/src/osdep/unix/dummy.c 2016-12-10 03:38:49.147899050 +0000
|
|||
@@ -27,7 +27,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- ../fdstring.c 2016-12-10 08:02:12.555352750 +0000
|
|||
+++ ./imap/src/osdep/unix/fdstring.c 2016-12-10 08:24:29.096929788 +0000
|
|||
@@ -25,7 +25,7 @@
|
|||
* Date: 15 April 1997 |
|||
* Last Edited: 4 April 2007 |
|||
*/ |
|||
-
|
|||
+#define L_SET SEEK_SET
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include "misc.h" |
|||
--- ../cache/alpine-2.20/imap/src/imapd/imapd.c 2015-01-12 05:12:25.519178508 +0000
|
|||
+++ ./imap/src/imapd/imapd.c 2016-12-10 23:37:39.038425114 +0000
|
|||
@@ -28,7 +28,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include <setjmp.h> |
|||
#include <time.h> |
|||
--- ../cache/alpine-2.20/imap/src/ipopd/ipop2d.c 2015-01-12 05:12:25.502178427 +0000
|
|||
+++ ./imap/src/ipopd/ipop2d.c 2016-12-10 23:30:12.213739029 +0000
|
|||
@@ -30,7 +30,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include <time.h> |
|||
#include "c-client.h" |
|||
--- ../cache/alpine-2.20/imap/src/ipopd/ipop3d.c 2015-01-12 05:12:25.502178427 +0000
|
|||
+++ ./imap/src/ipopd/ipop3d.c 2016-12-10 23:31:07.350317290 +0000
|
|||
@@ -29,7 +29,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include <time.h> |
|||
#include "c-client.h" |
|||
--- ../cache/alpine-2.20/imap/src/mailutil/mailutil.c 2015-01-12 05:12:25.518178504 +0000
|
|||
+++ ./imap/src/mailutil/mailutil.c 2016-12-10 23:41:39.036944641 +0000
|
|||
@@ -26,7 +26,6 @@
|
|||
|
|||
#include <stdio.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "c-client.h" |
|||
#ifdef SYSCONFIG /* defined in env_unix.h */ |
|||
#include <pwd.h> |
|||
--- mbx.c.orig 2016-12-10 03:59:23.316906511 +0000
|
|||
+++ ./imap/src/osdep/unix/mbx.c 2016-12-10 03:59:37.913060423 +0000
|
|||
@@ -37,7 +37,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- mh.c 2016-12-10 04:12:37.861288117 +0000
|
|||
+++ ./imap/src/osdep/unix/mh.c 2016-12-10 04:12:46.749381991 +0000
|
|||
@@ -27,7 +27,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- mix.c 2016-12-10 04:15:28.235087404 +0000
|
|||
+++ ./imap/src/osdep/unix/mix.c 2016-12-10 04:15:39.583207240 +0000
|
|||
@@ -26,7 +26,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- mmdf.c.orig 2016-12-10 04:02:48.267067498 +0000
|
|||
+++ ./imap/src/osdep/unix/mmdf.c 2016-12-10 04:02:58.423174574 +0000
|
|||
@@ -28,7 +28,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
--- mtx.c 2016-12-10 04:07:22.129954642 +0000
|
|||
+++ ./imap/src/osdep/unix/mtx.c 2016-12-10 04:07:29.710034547 +0000
|
|||
@@ -37,7 +37,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- mx.c 2016-12-10 04:14:08.566246077 +0000
|
|||
+++ ./imap/src/osdep/unix/mx.c 2016-12-10 04:14:14.882312779 +0000
|
|||
@@ -30,7 +30,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- netmsg.c.orig 2016-12-10 03:41:25.481557722 +0000
|
|||
+++ ./imap/src/c-client/netmsg.c 2016-12-10 03:41:43.933753459 +0000
|
|||
@@ -29,7 +29,6 @@
|
|||
|
|||
#include <stdio.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "c-client.h" |
|||
#include "netmsg.h" |
|||
#include "flstring.h" |
|||
--- news.c 2016-12-10 04:09:10.395096657 +0000
|
|||
+++ ./imap/src/osdep/unix/news.c 2016-12-10 04:09:20.143199638 +0000
|
|||
@@ -30,7 +30,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <sys/stat.h> |
|||
--- phile.c 2016-12-10 04:11:04.612303192 +0000
|
|||
+++ ./imap/src/osdep/unix/phile.c 2016-12-10 04:11:13.568397795 +0000
|
|||
@@ -30,7 +30,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
--- tenex.c.orig 2016-12-10 04:04:06.319890406 +0000
|
|||
+++ ./imap/src/osdep/unix/tenex.c 2016-12-10 04:04:19.476029107 +0000
|
|||
@@ -42,7 +42,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <sys/stat.h> |
|||
--- ../unix.c 2016-12-10 08:51:46.873743032 +0000
|
|||
+++ ./imap/src/osdep/unix/unix.c 2016-12-10 08:52:08.905971091 +0000
|
|||
@@ -40,7 +40,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
--- ../cache/alpine-2.21/imap/src/dmail/dmail.c 2017-02-06 00:06:22.499218141 +0000
|
|||
+++ ./imap/src/dmail/dmail.c 2017-04-25 11:09:01.144317637 +0000
|
|||
@@ -28,7 +28,6 @@
|
|||
#include <pwd.h> |
|||
#include <errno.h> |
|||
#include <ctype.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <sysexits.h> |
|||
#include <sys/file.h> |
|||
#include <sys/stat.h> |
|||
--- ../cache/alpine-2.21/imap/src/tmail/tmail.c 2017-02-06 00:06:22.515218494 +0000
|
|||
+++ ./imap/src/tmail/tmail.c 2017-04-25 11:08:37.468048959 +0000
|
|||
@@ -27,7 +27,6 @@
|
|||
#include <pwd.h> |
|||
#include <errno.h> |
|||
#include <ctype.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <sysexits.h> |
|||
#include <sys/file.h> |
|||
#include <sys/stat.h> |
|||
--- ../cache/alpine-2.20/pico/osdep/filesys.c 2015-01-12 05:12:25.272177331 +0000
|
|||
+++ ./pico/osdep/filesys.c 2016-12-11 00:14:46.945596542 +0000
|
|||
@@ -777,7 +777,6 @@
|
|||
char *cb; |
|||
struct stat tsb, fsb; |
|||
EML eml; |
|||
- extern int errno;
|
|||
|
|||
if(our_stat(a, &fsb) < 0){ /* get source file info */ |
|||
eml.s = errstr(errno); |
@ -0,0 +1,11 @@ |
|||
--- ../fdstring.c 2016-12-10 08:02:12.555352750 +0000
|
|||
+++ ./imap/src/osdep/unix/fdstring.c 2016-12-10 08:24:29.096929788 +0000
|
|||
@@ -25,7 +25,7 @@
|
|||
* Date: 15 April 1997 |
|||
* Last Edited: 4 April 2007 |
|||
*/ |
|||
-
|
|||
+#define L_SET SEEK_SET
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include "misc.h" |
@ -0,0 +1,11 @@ |
|||
--- ../cache/alpine-2.21/imap/src/mlock/Makefile 2017-02-06 00:06:22.515218494 +0000
|
|||
+++ ./imap/src/mlock/Makefile 2017-07-08 09:25:17.637293516 +0000
|
|||
@@ -36,7 +36,7 @@
|
|||
all: mlock |
|||
|
|||
mlock: mlock.o |
|||
- $(CC) $(CFLAGS) -o mlock mlock.o
|
|||
+ $(CC) $(CFLAGS) -o mlock mlock.o -llog
|
|||
|
|||
install: mlock |
|||
chgrp mail mlock |
Loading…
Reference in new issue