Browse Source

apt: Remove cdrom code for slight size shrink

android-5
Fredrik Fornwall 9 years ago
parent
commit
a1b579d9e8
  1. 34
      packages/apt/Makefile.patch
  2. 4
      packages/apt/build.sh
  3. 18
      packages/apt/cmdline-makefile.patch
  4. 15
      packages/apt/methods-makefile.patch

34
packages/apt/Makefile.patch

@ -0,0 +1,34 @@
diff -u -r ../apt-1.1.3/Makefile ./Makefile
--- ../apt-1.1.3/Makefile 2015-11-30 03:08:24.000000000 -0500
+++ ./Makefile 2015-12-04 05:05:01.447148671 -0500
@@ -9,8 +9,8 @@
.PHONY: default
default: startup all
-.PHONY: fast headers library clean veryclean all binary program doc test update-po
-all headers library clean veryclean binary program doc manpages docbook test update-po startup dirs:
+.PHONY: fast headers library clean veryclean all binary program doc update-po
+all headers library clean veryclean binary program doc manpages docbook update-po startup dirs:
$(MAKE) -C vendor $@
$(MAKE) -C apt-pkg $@
$(MAKE) -C apt-inst $@
@@ -21,8 +21,6 @@
$(MAKE) -C dselect $@
$(MAKE) -C doc $@
$(MAKE) -C po $@
- # FIXME: -C test has issue swith parallel builds, investigate!
- -$(MAKE) -C test $@
fast:
$(MAKE) -C vendor all
@@ -32,9 +30,8 @@
$(MAKE) -C methods all
$(MAKE) -C cmdline all
$(MAKE) -C ftparchive all
- $(MAKE) -C test all
-all headers library clean veryclean binary program doc manpages docbook test update-po: startup dirs
+all headers library clean veryclean binary program doc manpages docbook update-po: startup dirs
dirs: startup

4
packages/apt/build.sh

@ -2,7 +2,7 @@ TERMUX_PKG_HOMEPAGE=https://packages.debian.org/apt
TERMUX_PKG_DESCRIPTION="Front-end for the dpkg package manager" TERMUX_PKG_DESCRIPTION="Front-end for the dpkg package manager"
TERMUX_PKG_DEPENDS="liblzma, libgnustl, dpkg, gnupg" TERMUX_PKG_DEPENDS="liblzma, libgnustl, dpkg, gnupg"
TERMUX_PKG_VERSION=1.1.3 TERMUX_PKG_VERSION=1.1.3
TERMUX_PKG_BUILD_REVISION=2 TERMUX_PKG_BUILD_REVISION=3
TERMUX_PKG_SRCURL=http://ftp.debian.org/debian/pool/main/a/apt/apt_${TERMUX_PKG_VERSION}.tar.xz TERMUX_PKG_SRCURL=http://ftp.debian.org/debian/pool/main/a/apt/apt_${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--host=${TERMUX_ARCH}-linux --disable-rpath acl_cv_rpath=$TERMUX_PREFIX/lib gt_cv_func_CFPreferencesCopyAppValue=no gt_cv_func_CFLocaleCopyCurrent=no ac_cv_c_bigendian=no --no-create" TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--host=${TERMUX_ARCH}-linux --disable-rpath acl_cv_rpath=$TERMUX_PREFIX/lib gt_cv_func_CFPreferencesCopyAppValue=no gt_cv_func_CFLocaleCopyCurrent=no ac_cv_c_bigendian=no --no-create"
# When ready to drop bz2 support: # When ready to drop bz2 support:
@ -20,6 +20,8 @@ CXXFLAGS+=" -DSTDIN_FILENO=0 -DSTDOUT_FILENO=1 -DSTDERR_FILENO=2 -DAI_IDN=0"
termux_step_pre_configure () { termux_step_pre_configure () {
cp $TERMUX_COMMON_CACHEDIR/config.{guess,sub} $TERMUX_PKG_SRCDIR/buildlib cp $TERMUX_COMMON_CACHEDIR/config.{guess,sub} $TERMUX_PKG_SRCDIR/buildlib
perl -p -i -e "s/TERMUX_ARCH/$TERMUX_ARCH/" $TERMUX_PKG_SRCDIR/configure perl -p -i -e "s/TERMUX_ARCH/$TERMUX_ARCH/" $TERMUX_PKG_SRCDIR/configure
rm $TERMUX_PKG_SRCDIR/apt-pkg/{cdrom.cc,indexcopy.cc}
} }
termux_step_post_configure () { termux_step_post_configure () {

18
packages/apt/cmdline-makefile.patch

@ -1,7 +1,21 @@
diff -u -r ../apt-1.1.3/cmdline/makefile ./cmdline/makefile diff -u -r ../apt-1.1.3/cmdline/makefile ./cmdline/makefile
--- ../apt-1.1.3/cmdline/makefile 2015-11-30 03:08:24.000000000 -0500 --- ../apt-1.1.3/cmdline/makefile 2015-11-30 03:08:24.000000000 -0500
+++ ./cmdline/makefile 2015-12-03 16:50:46.792294882 -0500 +++ ./cmdline/makefile 2015-12-03 20:09:21.860089855 -0500
@@ -49,7 +49,7 @@ @@ -33,13 +33,6 @@
SOURCE = apt-config.cc
include $(PROGRAM_H)
-# The apt-cdrom program
-PROGRAM=apt-cdrom
-SLIBS = -lapt-pkg -lapt-private $(INTLLIBS)
-LIB_MAKES = apt-pkg/makefile apt-private/makefile
-SOURCE = apt-cdrom.cc
-include $(PROGRAM_H)
-
# The apt-mark program
PROGRAM=apt-mark
SLIBS = -lapt-pkg -lapt-private $(INTLLIBS)
@@ -49,7 +42,7 @@
# The apt-helper # The apt-helper
PROGRAM=apt-helper PROGRAM=apt-helper

15
packages/apt/methods-makefile.patch

@ -1,8 +1,17 @@
diff -u -r ../apt-1.1.3/methods/makefile ./methods/makefile diff -u -r ../apt-1.1.3/methods/makefile ./methods/makefile
--- ../apt-1.1.3/methods/makefile 2015-11-30 03:08:24.000000000 -0500 --- ../apt-1.1.3/methods/makefile 2015-11-30 03:08:24.000000000 -0500
+++ ./methods/makefile 2015-12-03 16:45:46.819879625 -0500 +++ ./methods/makefile 2015-12-03 20:07:25.853599149 -0500
@@ -46,21 +46,21 @@ @@ -37,30 +37,23 @@
SOURCE = gpgv.cc
include $(PROGRAM_H)
-# The cdrom method
-PROGRAM=cdrom
-SLIBS = -lapt-pkg $(INTLLIBS)
-LIB_MAKES = apt-pkg/makefile
-SOURCE = cdrom.cc
-include $(PROGRAM_H)
-
# The http method # The http method
PROGRAM=http PROGRAM=http
-SLIBS = -lapt-pkg $(SOCKETLIBS) $(INTLLIBS) -lresolv -SLIBS = -lapt-pkg $(SOCKETLIBS) $(INTLLIBS) -lresolv
@ -26,7 +35,7 @@ diff -u -r ../apt-1.1.3/methods/makefile ./methods/makefile
LIB_MAKES = apt-pkg/makefile LIB_MAKES = apt-pkg/makefile
SOURCE = ftp.cc rfc2553emu.cc connect.cc SOURCE = ftp.cc rfc2553emu.cc connect.cc
include $(PROGRAM_H) include $(PROGRAM_H)
@@ -81,7 +81,7 @@ @@ -81,7 +74,7 @@
# The mirror method # The mirror method
PROGRAM=mirror PROGRAM=mirror

Loading…
Cancel
Save