52 changed files with 454 additions and 52 deletions
@ -0,0 +1,20 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://duplicity.nongnu.org/ |
|||
TERMUX_PKG_DESCRIPTION="Encrypted bandwidth-efficient backup using the rsync algorithm" |
|||
TERMUX_PKG_VERSION=0.7.06 |
|||
TERMUX_PKG_SRCURL=https://code.launchpad.net/duplicity/0.7-series/${TERMUX_PKG_VERSION}/+download/duplicity-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_DEPENDS="librsync, python2, python2-lockfile" |
|||
TERMUX_PKG_BUILD_IN_SRC="yes" |
|||
|
|||
termux_step_make_install () { |
|||
pip install http://pypi.python.org/packages/source/d/distutilscross/distutilscross-0.1.tar.gz |
|||
|
|||
export PYTHONXCPREFIX=$TERMUX_PREFIX |
|||
export LDSHARED="${CC} -shared -lpython2.7" |
|||
|
|||
python setup.py build -x |
|||
python setup.py install --prefix=$TERMUX_PREFIX --force |
|||
} |
|||
|
|||
termux_step_post_massage () { |
|||
find . -path '*.pyc' -delete |
|||
} |
@ -0,0 +1,13 @@ |
|||
diff -u -r ../duplicity-0.7.06/setup.py ./setup.py
|
|||
--- ../duplicity-0.7.06/setup.py 2015-12-07 07:03:39.000000000 -0500
|
|||
+++ ./setup.py 2016-01-20 18:58:46.049638771 -0500
|
|||
@@ -34,7 +34,8 @@
|
|||
print("Sorry, duplicity requires version 2.6 or 2.7 of python.") |
|||
sys.exit(1) |
|||
|
|||
-incdir_list = libdir_list = None
|
|||
+incdir_list = ['@TERMUX_PREFIX@/include', '@TERMUX_PREFIX@/include/python2.7']
|
|||
+libdir_list = ['@TERMUX_PREFIX@/lib']
|
|||
|
|||
if os.name == 'posix': |
|||
LIBRSYNC_DIR = os.environ.get('LIBRSYNC_DIR', '') |
@ -0,0 +1,15 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://pypi.python.org/pypi/lockfile |
|||
TERMUX_PKG_DESCRIPTION="Platform-independent file locking module for python 2" |
|||
TERMUX_PKG_VERSION=0.12.2 |
|||
TERMUX_PKG_SRCURL=https://pypi.python.org/packages/source/l/lockfile/lockfile-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_DEPENDS="python2" |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
|||
TERMUX_PKG_PLATFORM_INDEPENDENT=yes |
|||
|
|||
termux_step_make_install () { |
|||
python setup.py install --prefix=$TERMUX_PREFIX --force |
|||
} |
|||
|
|||
termux_step_post_massage () { |
|||
find . -path '*.pyc' -delete |
|||
} |
@ -0,0 +1,18 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://github.com/paramiko/paramiko |
|||
TERMUX_PKG_DESCRIPTION="Native Python 2 SSHv2 protocol library" |
|||
TERMUX_PKG_VERSION=1.16.0 |
|||
TERMUX_PKG_SRCURL=https://github.com/paramiko/paramiko/archive/v${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_FOLDERNAME=paramiko-$TERMUX_PKG_VERSION |
|||
TERMUX_PKG_DEPENDS="python2" |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
|||
TERMUX_PKG_PLATFORM_INDEPENDENT=yes |
|||
|
|||
termux_step_make_install () { |
|||
export PYTHONUSERBASE=$TERMUX_PREFIX |
|||
#python setup.py install --force --prefix=$TERMUX_PREFIX |
|||
python setup.py install --force --user |
|||
} |
|||
|
|||
termux_step_post_massage () { |
|||
find . -path '*.pyc' -delete |
|||
} |
@ -0,0 +1,24 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://github.com/tahoe-lafs/pycryptopp |
|||
TERMUX_PKG_DESCRIPTION="Python 2 interfaces to a few good crypto algorithms" |
|||
TERMUX_PKG_VERSION=0.6.0 |
|||
TERMUX_PKG_SRCURL=https://github.com/tahoe-lafs/pycryptopp/archive/pycryptopp-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_FOLDERNAME=pycryptopp-pycryptopp-$TERMUX_PKG_VERSION |
|||
TERMUX_PKG_DEPENDS="python2" |
|||
TERMUX_PKG_BUILD_IN_SRC="yes" |
|||
|
|||
termux_step_make_install () { |
|||
pip install http://pypi.python.org/packages/source/d/distutilscross/distutilscross-0.1.tar.gz |
|||
|
|||
export PYTHONXCPREFIX=$TERMUX_PREFIX |
|||
export LDSHARED="${CC} -shared -lpython2.7" |
|||
|
|||
echo "__version__ = '$TERMUX_PKG_VERSION'" > src/pycryptopp/_version.py |
|||
|
|||
python setup.py build -x |
|||
export PYTHONUSERBASE=$TERMUX_PREFIX/lib/python2.7/site-packages/ |
|||
python setup.py install --prefix=$TERMUX_PREFIX --force --user |
|||
} |
|||
|
|||
termux_step_post_massage () { |
|||
find . -path '*.pyc' -delete |
|||
} |
@ -0,0 +1,23 @@ |
|||
diff -u -r ../pycryptopp-pycryptopp-0.6.0/setup.py ./setup.py
|
|||
--- ../pycryptopp-pycryptopp-0.6.0/setup.py 2012-03-13 04:16:09.000000000 -0400
|
|||
+++ ./setup.py 2016-01-20 19:54:13.085989935 -0500
|
|||
@@ -57,8 +57,8 @@
|
|||
undef_macros=[] |
|||
libraries=[] |
|||
ext_modules=[] |
|||
-include_dirs=[]
|
|||
-library_dirs=[]
|
|||
+include_dirs = ['/data/data/com.termux/files/usr/include', '/data/data/com.termux/files/usr/include/python2.7']
|
|||
+library_dirs = ['/data/data/com.termux/files/usr/lib']
|
|||
extra_srcs=[] # This is for Crypto++ .cpp files if they are needed. |
|||
|
|||
# |
|||
@@ -208,7 +208,7 @@
|
|||
for s in os.listdir(os.path.join("src-ed25519","supercop-ref")) |
|||
if s.endswith(".c") and s!="test.c"]) |
|||
m = Extension("pycryptopp.publickey.ed25519._ed25519", |
|||
- include_dirs=[os.path.join("src-ed25519","supercop-ref")],
|
|||
+ include_dirs=[os.path.join("src-ed25519","supercop-ref")] + include_dirs,
|
|||
sources=sources) |
|||
ext_modules.append(m) |
|||
|
@ -0,0 +1,13 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://racket-lang.org |
|||
TERMUX_PKG_DESCRIPTION="Full-spectrum programming language going beyond Lisp and Scheme" |
|||
TERMUX_PKG_VERSION=6.3 |
|||
TERMUX_PKG_SRCURL=https://mirror.racket-lang.org/releases/6.3/installers/racket-minimal-${TERMUX_PKG_VERSION}-src-builtpkgs.tgz |
|||
TERMUX_PKG_DEPENDS="libffi, libandroid-support" |
|||
# TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-ssl=openssl --disable-iri" |
|||
# TERMUX_PKG_HOSTBUILD=true |
|||
TERMUX_PKG_FOLDERNAME=racket-${TERMUX_PKG_VERSION} |
|||
TERMUX_MAKE_PROCESSES=1 |
|||
|
|||
termux_step_post_extract_package () { |
|||
export TERMUX_PKG_SRCDIR=$TERMUX_PKG_SRCDIR/src |
|||
} |
@ -0,0 +1,27 @@ |
|||
diff -u -r ../apt-1.2/completions/bash/apt ./completions/bash/apt
|
|||
--- ../apt-1.2/completions/bash/apt 2016-01-15 13:53:52.000000000 -0500
|
|||
+++ ./completions/bash/apt 2016-01-25 06:15:46.747246153 -0500
|
|||
@@ -2,7 +2,7 @@
|
|||
|
|||
_apt() |
|||
{ |
|||
- local sourcesdir="/etc/apt/sources.list.d"
|
|||
+ local sourcesdir="@TERMUX_PREFIX@/etc/apt/sources.list.d"
|
|||
local cur prev words cword |
|||
_init_completion || return |
|||
|
|||
@@ -66,14 +66,9 @@
|
|||
if [[ -n $command ]]; then |
|||
case $command in |
|||
remove|purge|autoremove) |
|||
- if [[ -f /etc/debian_version ]]; then
|
|||
# Debian system |
|||
COMPREPLY=( $( \ |
|||
_xfunc dpkg _comp_dpkg_installed_packages $cur ) ) |
|||
- else
|
|||
- # assume RPM based
|
|||
- _xfunc rpm _rpm_installed_packages
|
|||
- fi
|
|||
return 0 |
|||
;; |
|||
show|list) |
@ -1,5 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://bash-completion.alioth.debian.org/ |
|||
TERMUX_PKG_DESCRIPTION="Programmable completion for the bash shell" |
|||
TERMUX_PKG_VERSION=2.1 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_SRCURL=https://bash-completion.alioth.debian.org/files/bash-completion-${TERMUX_PKG_VERSION}.tar.bz2 |
|||
TERMUX_PKG_DEPENDS="bash" |
|||
TERMUX_PKG_PLATFORM_INDEPENDENT=yes |
|||
|
@ -0,0 +1,23 @@ |
|||
From: Barry Warsaw <barry@python.org> |
|||
Subject: Fix bash: words: bad array subscript |
|||
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/bash-completion/+bug/1289597 |
|||
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=741479 |
|||
Origin: vendor, https://bugs.launchpad.net/ubuntu/+source/bash-completion/+bug/1289597 |
|||
Forwarded: yes, <20140312212729.17788.38099.reportbug@samba4.Chuck.local> |
|||
|
|||
---
|
|||
bash_completion | 2 +- |
|||
1 file changed, 1 insertion(+), 1 deletion(-) |
|||
|
|||
--- bash-completion.orig/bash_completion
|
|||
+++ bash-completion/bash_completion
|
|||
@@ -718,7 +718,7 @@ _init_completion()
|
|||
fi |
|||
done |
|||
|
|||
- [[ $cword -eq 0 ]] && return 1
|
|||
+ [[ $cword -le 0 ]] && return 1
|
|||
prev=${words[cword-1]} |
|||
|
|||
[[ ${split-} ]] && _split_longopt && split=true |
|||
|
@ -1,11 +1,14 @@ |
|||
TERMUX_PKG_VERSION=2.25 |
|||
TERMUX_PKG_VERSION=2.26 |
|||
TERMUX_PKG_HOMEPAGE=http://www.gnu.org/software/binutils/ |
|||
TERMUX_PKG_DESCRIPTION="Collection of binary tools, the main ones being ld, the GNU linker, and as, the GNU assembler" |
|||
TERMUX_PKG_SRCURL=http://ftp.gnu.org/gnu/binutils/binutils-${TERMUX_PKG_VERSION}.tar.gz |
|||
# TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-gold" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-werror" |
|||
TERMUX_PKG_EXTRA_MAKE_ARGS="tooldir=$TERMUX_PREFIX" |
|||
TERMUX_PKG_RM_AFTER_INSTALL="share/man/man1/windmc.1 share/man/man1/windres.1 bin/ld.bfd" |
|||
|
|||
# Avoid linking against libfl.so from flex if available: |
|||
export LEXLIB= |
|||
|
|||
termux_step_post_make_install () { |
|||
cp $TERMUX_PKG_BUILDER_DIR/ldd $TERMUX_PREFIX/bin/ldd |
|||
} |
|||
|
@ -0,0 +1,17 @@ |
|||
diff -u -r ../binutils-2.26/ld/emultempl/elf32.em ./ld/emultempl/elf32.em
|
|||
--- ../binutils-2.26/ld/emultempl/elf32.em 2015-11-13 03:27:42.000000000 -0500
|
|||
+++ ./ld/emultempl/elf32.em 2016-01-28 10:20:11.534910516 -0500
|
|||
@@ -115,8 +115,13 @@
|
|||
static void |
|||
gld${EMULATION_NAME}_after_parse (void) |
|||
{ |
|||
+#ifndef __ANDROID__
|
|||
+ /** The Android linker does not support DF_1_PIE but prints a warning:
|
|||
+ 'unsupported flags DT_FLAGS_1=0x8000000'
|
|||
+ due to validation in linker.cpp (see "case DT_FLAGS_1" there. */ */
|
|||
if (bfd_link_pie (&link_info)) |
|||
link_info.flags_1 |= (bfd_vma) DF_1_PIE; |
|||
+#endif
|
|||
|
|||
after_parse_default (); |
|||
} |
@ -0,0 +1,12 @@ |
|||
diff -r -u ../binutils-2.24/ld/configure.tgt ./ld/configure.tgt |
|||
--- ../binutils-2.24/ld/configure.tgt 2013-11-26 12:37:33.000000000 +0100 |
|||
+++ ./ld/configure.tgt 2014-02-12 18:06:26.000000000 +0100 |
|||
@@ -769,7 +769,7 @@ |
|||
|
|||
esac |
|||
|
|||
-NATIVE_LIB_DIRS='/usr/local/lib /lib /usr/lib' |
|||
+NATIVE_LIB_DIRS='/system/lib64' |
|||
case "${target}" in |
|||
|
|||
*-*-dragonfly*) |
@ -1,6 +1,6 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://packages.debian.org/debianutils |
|||
TERMUX_PKG_DESCRIPTION="Small utilities which are used primarily by the installation scripts of Debian packages" |
|||
TERMUX_PKG_VERSION=4.5.1 |
|||
TERMUX_PKG_VERSION=4.7 |
|||
TERMUX_PKG_SRCURL=http://ftp.debian.org/debian/pool/main/d/debianutils/debianutils_${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_RM_AFTER_INSTALL="bin/installkernel share/man/man8/installkernel.8" |
|||
TERMUX_PKG_FOLDERNAME=debianutils |
|||
TERMUX_PKG_FOLDERNAME=debianutils-$TERMUX_PKG_VERSION |
|||
|
@ -1,7 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://elinks.or.cz |
|||
TERMUX_PKG_DESCRIPTION="Full-Featured Text WWW Browser" |
|||
TERMUX_PKG_VERSION=0.12pre6 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_BUILD_REVISION=2 |
|||
TERMUX_PKG_SRCURL=http://elinks.or.cz/download/elinks-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_DEPENDS="libexpat, libidn, openssl" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-256-colors --with-openssl --mandir=$TERMUX_PREFIX/share/man" |
|||
TERMUX_PKG_DEPENDS="libexpat, libidn, openssl, libbz2" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-256-colors --with-openssl --mandir=$TERMUX_PREFIX/share/man --without-gc" |
|||
|
@ -1,4 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://flex.sourceforge.net/ |
|||
TERMUX_PKG_DESCRIPTION="Fast lexical analyser generator" |
|||
TERMUX_PKG_VERSION=2.6.0 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_SRCURL=http://downloads.sourceforge.net/project/flex/flex-${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_DEPENDS="m4" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+="ac_cv_path_M4=$TERMUX_PREFIX/bin/m4" |
|||
|
@ -1,5 +1,5 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://www.gnu.org/software/grep/ |
|||
TERMUX_PKG_DESCRIPTION="Command which searches one or more input files for lines containing a match to a specified pattern" |
|||
TERMUX_PKG_DEPENDS="pcre" |
|||
TERMUX_PKG_VERSION=2.22 |
|||
TERMUX_PKG_VERSION=2.23 |
|||
TERMUX_PKG_SRCURL=http://ftp.gnu.org/gnu/grep/grep-${TERMUX_PKG_VERSION}.tar.xz |
|||
|
@ -0,0 +1,12 @@ |
|||
diff -u -r ../libev-4.22/Makefile.in ./Makefile.in
|
|||
--- ../libev-4.22/Makefile.in 2015-12-20 16:12:45.000000000 -0500
|
|||
+++ ./Makefile.in 2016-02-02 10:30:17.445084694 -0500
|
|||
@@ -343,7 +343,7 @@
|
|||
ev.3 ev.pod Symbols.ev Symbols.event |
|||
|
|||
man_MANS = ev.3 |
|||
-include_HEADERS = ev.h ev++.h event.h
|
|||
+include_HEADERS = ev.h ev++.h
|
|||
lib_LTLIBRARIES = libev.la |
|||
libev_la_SOURCES = ev.c event.c |
|||
libev_la_LDFLAGS = -version-info $(VERSION_INFO) |
@ -0,0 +1,6 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://software.schmorp.de/pkg/libev.html |
|||
TERMUX_PKG_DESCRIPTION="Full-featured and high-performance event loop library" |
|||
TERMUX_PKG_VERSION=4.22 |
|||
TERMUX_PKG_SRCURL=http://dist.schmorp.de/libev/libev-${TERMUX_PKG_VERSION}.tar.gz |
|||
|
|||
CFLAGS+=" -Dfd_mask=int" |
@ -1,4 +1,11 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/libtool/ |
|||
TERMUX_PKG_DESCRIPTION="Generic library support script hiding the complexity of using shared libraries behind a consistent, portable interface" |
|||
TERMUX_PKG_DEPENDS="bash,grep,sed" |
|||
TERMUX_PKG_VERSION=2.4.6 |
|||
TERMUX_PKG_BUILD_REVISION=2 |
|||
TERMUX_PKG_SRCURL=http://ftpmirror.gnu.org/libtool/libtool-${TERMUX_PKG_VERSION}.tar.gz |
|||
|
|||
termux_step_post_make_install () { |
|||
perl -p -i -e "s|\"/bin/|\"$TERMUX_PREFIX/bin/|" $TERMUX_PREFIX/bin/{libtool,libtoolize} |
|||
perl -p -i -e "s|${_SPECSFLAG}||g" $TERMUX_PREFIX/bin/{libtool,libtoolize} |
|||
} |
|||
|
@ -0,0 +1,11 @@ |
|||
diff -u -r ../macchanger-1.7.0/autogen.sh ./autogen.sh
|
|||
--- ../macchanger-1.7.0/autogen.sh 2014-01-01 12:10:25.000000000 -0500
|
|||
+++ ./autogen.sh 2016-01-28 15:39:53.656299665 -0500
|
|||
@@ -84,7 +84,6 @@
|
|||
exit; |
|||
fi |
|||
|
|||
-./configure "$@"
|
|||
|
|||
echo |
|||
echo "Now type 'make' to compile $PROJECT." |
@ -0,0 +1,12 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://github.com/alobbs/macchanger |
|||
TERMUX_PKG_DESCRIPTION="Utility that makes the maniputation of MAC addresses of network interfaces easier" |
|||
TERMUX_PKG_VERSION=1.7.0 |
|||
TERMUX_PKG_SRCURL=https://github.com/alobbs/macchanger/archive/${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_FOLDERNAME=macchanger-${TERMUX_PKG_VERSION} |
|||
# TERMUX_PKG_DEPENDS="pcre, openssl, libuuid" |
|||
# TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-ssl=openssl --disable-iri" |
|||
|
|||
termux_step_pre_configure() { |
|||
cd $TERMUX_PKG_SRCDIR |
|||
./autogen.sh |
|||
} |
@ -1,12 +1,12 @@ |
|||
diff -u -r ../neovim-master/runtime/CMakeLists.txt ./runtime/CMakeLists.txt
|
|||
--- ../neovim-master/runtime/CMakeLists.txt 2015-08-03 15:36:33.000000000 -0400
|
|||
+++ ./runtime/CMakeLists.txt 2015-08-03 17:38:07.657949138 -0400
|
|||
@@ -35,7 +35,7 @@
|
|||
--- ../neovim-master/runtime/CMakeLists.txt 2016-02-05 10:02:38.000000000 -0500
|
|||
+++ ./runtime/CMakeLists.txt 2016-02-05 17:56:54.645492669 -0500
|
|||
@@ -32,7 +32,7 @@
|
|||
) |
|||
|
|||
add_custom_command(OUTPUT ${GENERATED_HELP_TAGS} |
|||
COMMAND ${CMAKE_COMMAND} -E copy_directory |
|||
${PROJECT_SOURCE_DIR}/runtime/doc ${GENERATED_RUNTIME_DIR}/doc |
|||
- COMMAND "${PROJECT_BINARY_DIR}/bin/nvim"
|
|||
+ COMMAND "${PROJECT_BINARY_DIR}/../host-build/bin/nvim"
|
|||
-u NONE |
|||
-i NONE |
|||
-esX |
|||
-es |
|||
|
@ -1,5 +1,5 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://www.gnu.org/software/parallel/ |
|||
TERMUX_PKG_DESCRIPTION="GNU Parallel is a shell tool for executing jobs in parallel using one or more machines" |
|||
TERMUX_PKG_VERSION=20151222 |
|||
TERMUX_PKG_VERSION=20160122 |
|||
TERMUX_PKG_SRCURL=http://ftp.gnu.org/gnu/parallel/parallel-${TERMUX_PKG_VERSION}.tar.bz2 |
|||
TERMUX_PKG_DEPENDS="perl" |
|||
|
@ -0,0 +1,21 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://tinyscheme.sourceforge.net/home.html |
|||
TERMUX_PKG_DESCRIPTION="Very small scheme implementation" |
|||
TERMUX_PKG_VERSION=1.41 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_SRCURL=http://downloads.sourceforge.net/project/tinyscheme/tinyscheme/tinyscheme-1.41/tinyscheme-1.41.tar.gz |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
|||
|
|||
AR+=" crs" |
|||
LD=$CC |
|||
|
|||
# TODO: Add the tsx extension with file/networking (http://heras-gilsanz.com/manuel/tsx.html) |
|||
# and the regexp extension (http://downloads.sourceforge.net/project/tinyscheme/tinyscheme-regex/1.3/re-1.3.tar.gz) |
|||
#termux_step_pre_make () { |
|||
#TSX_TARFILE=$TERMUX_PKG_CACHEDIR/tsx-1.1.tar.gz |
|||
#test ! -f $TSX_TARFILE && curl -o $TSX_TARFILE "http://heras-gilsanz.com/manuel/tsx-1.1.tgz" |
|||
#} |
|||
|
|||
termux_step_post_make_install () { |
|||
mkdir -p $TERMUX_PREFIX/share/tinyscheme/ |
|||
cp $TERMUX_PKG_SRCDIR/init.scm $TERMUX_PREFIX/share/tinyscheme/ |
|||
} |
@ -0,0 +1,39 @@ |
|||
diff -u -r ../tinyscheme-1.41/makefile ./makefile
|
|||
--- ../tinyscheme-1.41/makefile 2013-04-14 16:08:33.000000000 -0400
|
|||
+++ ./makefile 2016-02-03 07:50:01.896212523 -0500
|
|||
@@ -18,7 +18,6 @@
|
|||
#AR= echo |
|||
|
|||
# Unix, generally |
|||
-CC = gcc -fpic -pedantic
|
|||
DEBUG=-g -Wall -Wno-char-subscripts -O |
|||
Osuf=o |
|||
SOsuf=so |
|||
@@ -27,11 +26,8 @@
|
|||
LIBPREFIX=lib |
|||
OUT = -o $@ |
|||
RM= -rm -f |
|||
-AR= ar crs
|
|||
|
|||
# Linux |
|||
-LD = gcc
|
|||
-LDFLAGS = -shared
|
|||
DEBUG=-g -Wno-char-subscripts -O |
|||
SYS_LIBS= -ldl -lm |
|||
PLATFORM_FEATURES= -DSUN_DL=1 |
|||
@@ -77,7 +73,7 @@
|
|||
$(LD) $(LDFLAGS) $(OUT) $(OBJS) $(SYS_LIBS) |
|||
|
|||
scheme$(EXE_EXT): $(OBJS) |
|||
- $(CC) -o $@ $(DEBUG) $(OBJS) $(SYS_LIBS)
|
|||
+ $(CC) $(CFLAGS) -o $@ $(DEBUG) $(OBJS) $(SYS_LIBS)
|
|||
|
|||
$(STATICLIBTARGET): $(OBJS) |
|||
$(AR) $@ $(OBJS) |
|||
@@ -96,3 +92,6 @@
|
|||
tags: TAGS |
|||
TAGS: $(TAGS_SRCS) |
|||
etags $(TAGS_SRCS) |
|||
+
|
|||
+install: scheme
|
|||
+ cp scheme @TERMUX_PREFIX@/bin/tinyscheme
|
@ -0,0 +1,12 @@ |
|||
diff -u -r ../tinyscheme-1.41/scheme.c ./scheme.c
|
|||
--- ../tinyscheme-1.41/scheme.c 2013-04-14 16:08:33.000000000 -0400
|
|||
+++ ./scheme.c 2016-02-03 08:22:19.137873950 -0500
|
|||
@@ -101,7 +101,7 @@
|
|||
#endif |
|||
|
|||
#ifndef InitFile |
|||
-# define InitFile "init.scm"
|
|||
+# define InitFile "@TERMUX_PREFIX@/share/tinyscheme/init.scm"
|
|||
#endif |
|||
|
|||
#ifndef FIRST_CELLSEGS |
@ -0,0 +1,15 @@ |
|||
bzero() is a define in the NDK header files (but should probably |
|||
not be used at all, bzero as deprecated and then removed in POSIX). |
|||
|
|||
diff -u -r ../vim-7.4.1174/src/osdef1.h.in ./src/osdef1.h.in
|
|||
--- ../vim-7.4.1174/src/osdef1.h.in 2016-01-24 16:17:03.000000000 -0500
|
|||
+++ ./src/osdef1.h.in 2016-01-24 17:01:12.816949231 -0500
|
|||
@@ -70,8 +70,6 @@
|
|||
# endif |
|||
# endif |
|||
#endif |
|||
-/* used inside of FD_ZERO macro: */
|
|||
-extern void bzero(void *, size_t);
|
|||
#ifdef HAVE_SETSID |
|||
extern pid_t setsid(void); |
|||
#endif |
@ -0,0 +1,15 @@ |
|||
bzero() is a define in the NDK header files (but should probably |
|||
not be used at all, bzero as deprecated and then removed in POSIX). |
|||
|
|||
diff -u -r ../vim-7.4.1174/src/osdef1.h.in ./src/osdef1.h.in
|
|||
--- ../vim-7.4.1174/src/osdef1.h.in 2016-01-24 16:17:03.000000000 -0500
|
|||
+++ ./src/osdef1.h.in 2016-01-24 17:01:12.816949231 -0500
|
|||
@@ -70,8 +70,6 @@
|
|||
# endif |
|||
# endif |
|||
#endif |
|||
-/* used inside of FD_ZERO macro: */
|
|||
-extern void bzero(void *, size_t);
|
|||
#ifdef HAVE_SETSID |
|||
extern pid_t setsid(void); |
|||
#endif |
@ -0,0 +1,24 @@ |
|||
diff -u -r ../wol-0.7.1/lib/getline.h ./lib/getline.h
|
|||
--- ../wol-0.7.1/lib/getline.h 2002-03-11 12:55:36.000000000 -0500
|
|||
+++ ./lib/getline.h 2016-02-05 16:14:45.530639085 -0500
|
|||
@@ -19,20 +19,4 @@
|
|||
|
|||
# include <stdio.h> |
|||
|
|||
-# ifndef PARAMS
|
|||
-# if defined PROTOTYPES || (defined __STDC__ && __STDC__)
|
|||
-# define PARAMS(Args) Args
|
|||
-# else
|
|||
-# define PARAMS(Args) ()
|
|||
-# endif
|
|||
-# endif
|
|||
-
|
|||
-# if __GLIBC__ < 2
|
|||
-int
|
|||
-getline PARAMS ((char **_lineptr, size_t *_n, FILE *_stream));
|
|||
-
|
|||
-int
|
|||
-getdelim PARAMS ((char **_lineptr, size_t *_n, int _delimiter, FILE *_stream));
|
|||
-# endif
|
|||
-
|
|||
#endif /* not GETLINE_H_ */ |
Loading…
Reference in new issue