Browse Source

openjpeg: disable static libs

with upstream commit 66297f07a43d2770a97c8456d20202f3d051d980
android-5
Tom Yan 6 years ago
parent
commit
a7639ce7f9
  1. 1
      packages/openjpeg/build.sh
  2. 26
      packages/openjpeg/library-installation-target.patch

1
packages/openjpeg/build.sh

@ -5,6 +5,7 @@ TERMUX_PKG_VERSION=2.3.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=3dc787c1bb6023ba846c2a0d9b1f6e179f1cd255172bde9eb75b01f1e6c7d71a
TERMUX_PKG_SRCURL=https://github.com/uclouvain/openjpeg/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="-DBUILD_STATIC_LIBS=OFF"
termux_step_pre_configure() {
# Force symlinks to be overwritten:

26
packages/openjpeg/library-installation-target.patch

@ -0,0 +1,26 @@
From 66297f07a43d2770a97c8456d20202f3d051d980 Mon Sep 17 00:00:00 2001
From: Even Rouault <even.rouault@spatialys.com>
Date: Mon, 9 Oct 2017 11:40:43 +0200
Subject: [PATCH] Unix build: fix regression of 2.3.0 where a shared-only or
static-only build lacks the installation target for the library (#1019, fixes
regression introduced by 3dfc6ca2bcf06fd1adb6b6b4cecc6c092f08ba0b)
---
src/lib/openjp2/CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/lib/openjp2/CMakeLists.txt b/src/lib/openjp2/CMakeLists.txt
index 0b452038..f8990ccf 100644
--- a/src/lib/openjp2/CMakeLists.txt
+++ b/src/lib/openjp2/CMakeLists.txt
@@ -99,6 +99,7 @@ else()
set(INSTALL_LIBS ${OPENJPEG_LIBRARY_NAME} openjp2_static)
else()
add_library(${OPENJPEG_LIBRARY_NAME} ${OPENJPEG_SRCS})
+ set(INSTALL_LIBS ${OPENJPEG_LIBRARY_NAME})
endif()
endif()
--
2.21.0
Loading…
Cancel
Save