5 changed files with 62 additions and 64 deletions
@ -0,0 +1,8 @@ |
|||
diff -u -r ../glib-2.60.2/gio/meson.build ./gio/meson.build
|
|||
--- ../glib-2.60.2/gio/meson.build 2019-05-03 13:43:28.000000000 +0000
|
|||
+++ ./gio/meson.build 2019-05-11 20:18:56.264103995 +0000
|
|||
@@ -994,4 +994,3 @@
|
|||
endif |
|||
|
|||
subdir('fam') |
|||
-subdir('tests')
|
@ -0,0 +1,39 @@ |
|||
diff -u -r ../glib-2.60.2/glib/gutils.c ./glib/gutils.c
|
|||
--- ../glib-2.60.2/glib/gutils.c 2019-05-03 13:43:28.000000000 +0000
|
|||
+++ ./glib/gutils.c 2019-05-11 19:59:12.830415366 +0000
|
|||
@@ -378,7 +378,7 @@
|
|||
* what to search if PATH is unset. POSIX may, dunno. |
|||
*/ |
|||
|
|||
- path = "/bin:/usr/bin:.";
|
|||
+ path = "@TERMUX_PREFIX@/bin:@TERMUX_PREFIX@/bin/applets:.";
|
|||
} |
|||
#else |
|||
n = GetModuleFileNameW (NULL, wfilename, MAXPATHLEN); |
|||
@@ -958,7 +958,7 @@
|
|||
if (tmp == NULL || *tmp == '\0') |
|||
{ |
|||
g_free (tmp); |
|||
- tmp = g_strdup ("/tmp");
|
|||
+ tmp = g_strdup ("@TERMUX_PREFIX@/tmp");
|
|||
} |
|||
#endif /* !G_OS_WIN32 */ |
|||
|
|||
@@ -2080,7 +2080,7 @@
|
|||
*/ |
|||
#ifndef G_OS_WIN32 |
|||
if (!data_dirs || !data_dirs[0]) |
|||
- data_dirs = "/usr/local/share/:/usr/share/";
|
|||
+ data_dirs = "@TERMUX_PREFIX@/share/";
|
|||
|
|||
data_dir_vector = g_strsplit (data_dirs, G_SEARCHPATH_SEPARATOR_S, 0); |
|||
#else |
|||
@@ -2174,7 +2174,7 @@
|
|||
} |
|||
#else |
|||
if (!conf_dirs || !conf_dirs[0]) |
|||
- conf_dirs = "/etc/xdg";
|
|||
+ conf_dirs = "@TERMUX_PREFIX@/etc/xdg";
|
|||
|
|||
conf_dir_vector = g_strsplit (conf_dirs, G_SEARCHPATH_SEPARATOR_S, 0); |
|||
#endif |
@ -0,0 +1,11 @@ |
|||
diff -u -r ../glib-2.60.2/meson.build ./meson.build
|
|||
--- ../glib-2.60.2/meson.build 2019-05-03 13:43:28.000000000 +0000
|
|||
+++ ./meson.build 2019-05-11 20:10:26.054269305 +0000
|
|||
@@ -360,7 +360,6 @@
|
|||
# https://wiki.gnome.org/Projects/GLib/CompilerRequirements#Function_pointer_conversions. |
|||
'-Wno-pedantic', |
|||
'-Werror=declaration-after-statement', |
|||
- '-Werror=format=2',
|
|||
'-Werror=implicit-function-declaration', |
|||
'-Werror=init-self', |
|||
'-Werror=missing-include-dirs', |
Loading…
Reference in new issue