Oliver Schmidhauser
8 years ago
committed by
Fredrik Fornwall
2 changed files with 23 additions and 0 deletions
@ -0,0 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://nyancat.dakko.us |
|||
TERMUX_PKG_DESCRIPTION="Nyancat in your terminal, rendered through ANSI escape sequences." |
|||
TERMUX_PKG_VERSION=1.5.1 |
|||
TERMUX_PKG_MAINTAINER="Oliver Schmidhauser @Neo-Oli" |
|||
TERMUX_PKG_SRCURL=https://github.com/klange/nyancat/archive/${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_FOLDERNAME=nyancat-$TERMUX_PKG_VERSION |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
@ -0,0 +1,16 @@ |
|||
diff --git a/Makefile b/Makefile
|
|||
index 8d68431..6653583 100644
|
|||
--- a/Makefile
|
|||
+++ b/Makefile
|
|||
@@ -33,7 +33,9 @@ distcheck: $(distdir).tar.gz
|
|||
@echo "*** Package $(distdir).tar.gz is ready for distribution." |
|||
|
|||
install: all |
|||
- install src/nyancat /usr/bin/${package}
|
|||
- gzip -9 -c < nyancat.1 > /usr/share/man/man1/nyancat.1.gz
|
|||
+ install -d "$(DESTDIR)$(PREFIX)/bin"
|
|||
+ install -d "$(DESTDIR)$(PREFIX)/share/man/man1"
|
|||
+ install src/nyancat "$(DESTDIR)$(PREFIX)/bin/nyancat"
|
|||
+ install -m644 nyancat.1 "$(DESTDIR)$(PREFIX)/share/man/man1/nyancat.1"
|
|||
|
|||
.PHONY: FORCE all clean check dist distcheck install |
Loading…
Reference in new issue