Fredrik Fornwall
9 years ago
53 changed files with 192 additions and 241 deletions
@ -1,7 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://developer.gnome.org/gdk-pixbuf/ |
|||
TERMUX_PKG_DESCRIPTION="Library for image loading and manipulation" |
|||
TERMUX_PKG_VERSION=2.32.3 |
|||
TERMUX_PKG_SRCURL=ftp://ftp.gnome.org/pub/gnome/sources/gdk-pixbuf/2.32/gdk-pixbuf-${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_VERSION=2.34.0 |
|||
TERMUX_PKG_SRCURL=ftp://ftp.gnome.org/pub/gnome/sources/gdk-pixbuf/2.34/gdk-pixbuf-${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_DEPENDS="glib, libpng, libtiff, libjpeg-turbo" |
|||
# Avoid runtime test which does not work when cross compiling: |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-gio-sniffing" |
|||
|
@ -1,6 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://www.gnuplot.info/ |
|||
TERMUX_PKG_DESCRIPTION="Command-line driven graphing utility" |
|||
TERMUX_PKG_VERSION=4.6.7 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_SRCURL=http://downloads.sourceforge.net/project/gnuplot/gnuplot/${TERMUX_PKG_VERSION}/gnuplot-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--without-x --with-lua=no" |
|||
TERMUX_PKG_DEPENDS="libandroid-support, readline, pango" |
|||
|
@ -1,20 +0,0 @@ |
|||
--- ../kona-Win.3.36-64/src/0.c 2015-07-30 11:18:02.000000000 -0400
|
|||
+++ ./src/0.c 2015-12-06 03:24:04.000000000 -0500
|
|||
@@ -84,7 +84,7 @@
|
|||
GC; } |
|||
else if( (3==ABS(t) && (!strcmp(m,"/dev/fd/0") || !strcmp(m,"/dev/stdin"))) //read stdin |
|||
|| 4==t && (!strcmp(*kS(a),"/dev/fd/0") || !strcmp(*kS(a),"/dev/stdin")) ){ |
|||
- b=getdelim_(&v,(size_t * __restrict__)&s,EOF,stdin);
|
|||
+ b=new_getdelim_(&v,(size_t * __restrict__)&s,EOF,stdin);
|
|||
P(freopen_stdin() == NULL, FE) |
|||
if(b==-1){z=newK(0,0); GC;} } |
|||
else { //read mapped file |
|||
@@ -868,7 +868,7 @@
|
|||
FILE *f; K z,l; S s=0; I n=0; |
|||
f=popen(cmd,"r"); P(!f,_n()) |
|||
z=newK(0,0); //oom |
|||
- while (getline_(&s, (size_t * __restrict__)&n, f) >= 0) {
|
|||
+ while (new_getline_(&s, (size_t * __restrict__)&n, f) >= 0) {
|
|||
l=newK(-3,n-1); strncpy(kC(l),s,n-1); kap(&z,&l); } |
|||
free(s); pclose(f); |
|||
R z; } |
@ -1,11 +0,0 @@ |
|||
--- ../kona-Win.3.36-64/src/c.c 2015-07-30 11:18:02.000000000 -0400
|
|||
+++ ./src/c.c 2015-12-06 03:19:35.000000000 -0500
|
|||
@@ -463,7 +463,7 @@
|
|||
w=t; while(isspace(*w++))l++; |
|||
if(l==n||!n){if(y)cd(y); y=0; continue;} |
|||
O("%s ",t); |
|||
- if(-1==getline_(&u,&m,stdin))GC;
|
|||
+ if(-1==new_getline_(&u,&m,stdin))GC;
|
|||
d=stepopt(u,m); |
|||
if(d==1){if(y)cd(y); y=0; continue;}else if(d==2)GC; |
|||
show(k=ex(wd(t,n))); |
@ -1,40 +0,0 @@ |
|||
--- ../kona-Win.3.36-64/src/getline.c 2015-07-30 11:18:02.000000000 -0400
|
|||
+++ ./src/getline.c 2015-12-06 03:21:45.000000000 -0500
|
|||
@@ -29,12 +29,12 @@
|
|||
R 0; |
|||
} |
|||
|
|||
-I getline_(S *s,size_t * __restrict__ n,FILE *f){R getdelim_(s,n,'\n',f);}
|
|||
+I new_getline_(S *s,size_t * __restrict__ n,FILE *f){R new_getdelim_(s,n,'\n',f);}
|
|||
|
|||
-I getdelim_(S *s,size_t * __restrict__ n,I d,FILE *f)
|
|||
+I new_getdelim_(S *s,size_t * __restrict__ n,I d,FILE *f)
|
|||
{ |
|||
I m; S z; |
|||
- if(getdelim(s,n,d,f)==-1){*n=0; R -1;}
|
|||
+ if(new_getdelim(s,n,d,f)==-1){*n=0; R -1;}
|
|||
m=strlenn(*s,*n); |
|||
z=strdupn(*s,m); |
|||
free(*s); |
|||
@@ -44,8 +44,8 @@
|
|||
|
|||
#if defined(__OpenBSD__) || defined(__NetBSD__) || \ |
|||
(defined(__MACH__) && __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1070) |
|||
-I getline(S *s,I*n, FILE *f){ R getdelim(s,n,'\n',f);}
|
|||
-I getdelim(S *s,I*n, I d, FILE *f)//target, current capacity, delimiter, file
|
|||
+I getline(S *s,I*n, FILE *f){ R new_getdelim(s,n,'\n',f);}
|
|||
+I new_getdelim(S *s,I*n, I d, FILE *f)//target, current capacity, delimiter, file
|
|||
{ |
|||
unsigned char *q; |
|||
I w=0; |
|||
@@ -92,8 +92,8 @@
|
|||
#endif |
|||
|
|||
#ifdef WIN32 |
|||
-I getline(S *s,I*n, FILE *f){ R getdelim(s,n,'\n',f);}
|
|||
-I getdelim(S *s,I*n, I d, FILE *f) { //target, current capacity, delimiter, file
|
|||
+I getline(S *s,I*n, FILE *f){ R new_getdelim(s,n,'\n',f);}
|
|||
+I new_getdelim(S *s,I*n, I d, FILE *f) { //target, current capacity, delimiter, file
|
|||
char *q; I w=0; |
|||
if (!s) {errno = EINVAL; goto error;} |
|||
if (f->_cnt <= 0) { |
@ -1,23 +0,0 @@ |
|||
--- ../kona-Win.3.36-64/src/getline.h 2015-07-30 11:18:02.000000000 -0400
|
|||
+++ ./src/getline.h 2015-12-06 03:21:00.000000000 -0500
|
|||
@@ -1,16 +1,16 @@
|
|||
K _p(); |
|||
S strdupn(S s,I k); |
|||
I strlenn(S s,I k); |
|||
-I getdelim_(S *s,size_t * __restrict__ n,I d,FILE *f);
|
|||
-I getline_(S *s,size_t * __restrict__ n,FILE *f);
|
|||
+I new_getdelim_(S *s,size_t * __restrict__ n,I d,FILE *f);
|
|||
+I new_getline_(S *s,size_t * __restrict__ n,FILE *f);
|
|||
I appender(S *s,I *n,S t,I k); |
|||
I expander(S *s,I n); |
|||
|
|||
#if defined(__OpenBSD__) || defined(__NetBSD__) || \ |
|||
(defined(__MACH__) && __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1070) || \ |
|||
defined(__ANDROID__) |
|||
-I getline(S *s,size_t * __restrict__ n,FILE *f);
|
|||
-I getdelim(S *s,size_t * __restrict__ n,I d,FILE *f);
|
|||
+I new_getline(S *s,size_t * __restrict__ n,FILE *f);
|
|||
+I new_getdelim(S *s,size_t * __restrict__ n,I d,FILE *f);
|
|||
#endif |
|||
|
|||
#if WIN32 |
@ -1,26 +0,0 @@ |
|||
--- ../kona-Win.3.36-64/src/kc.c 2015-07-30 11:18:02.000000000 -0400
|
|||
+++ ./src/kc.c 2015-12-06 03:18:50.000000000 -0500
|
|||
@@ -34,12 +34,12 @@
|
|||
I wds_(K*a,FILE*f,I l) { |
|||
S s=0,t=0; I b=0,c=0,m=0,n=0,v=0; K z=0; PDA p=0; |
|||
I o=isatty(STDIN)&&f==stdin; |
|||
- if(-1==(c=getline_(&s,(size_t * __restrict__)&n,f)))GC;
|
|||
+ if(-1==(c=new_getline_(&s,(size_t * __restrict__)&n,f)))GC;
|
|||
appender(&t,&m,s,n); |
|||
while(1==(v=complete(t,m,&p,0))) { |
|||
b=parsedepth(p); |
|||
if(o)prompt(b+l); |
|||
- if(-1==(c=getline_(&s,(size_t * __restrict__)&n,f)))GC;
|
|||
+ if(-1==(c=new_getline_(&s,(size_t * __restrict__)&n,f)))GC;
|
|||
appender(&t,&m,s,n); } |
|||
SW(v){CS(2,show(kerr("unmatched"));GC) CS(3,show(kerr("nest")); GC)} |
|||
z=newK(-3,m-1); |
|||
@@ -200,7 +200,7 @@
|
|||
//I o = isatty(STDIN) && f==stdin; //display results to stdout? |
|||
I o = isatty(STDIN); //display results to stdout? |
|||
|
|||
- if(-1==(c=getline(&s,(size_t * __restrict__)&m,f))) GC;
|
|||
+ if(-1==(c=new_getline(&s,(size_t * __restrict__)&m,f))) GC;
|
|||
if(s[0]=='\\' && s[1]=='\n') { |
|||
if(fCheck) { fCheck=0; R 0; } //escape suspended execution with single backslash |
|||
if(*a) GC; } //escape continue with single backslash |
@ -0,0 +1,12 @@ |
|||
diff -u -r ../kona-Win.3.39-69/src/bswap.c ./src/bswap.c
|
|||
--- ../kona-Win.3.39-69/src/bswap.c 2016-04-17 14:10:22.000000000 -0400
|
|||
+++ ./src/bswap.c 2016-05-03 14:17:03.393640037 -0400
|
|||
@@ -11,8 +11,6 @@
|
|||
|
|||
#if defined(__linux__) && defined(__GNUC__) |
|||
#include <byteswap.h> |
|||
-#define bswap32 __bswap_32
|
|||
-#define bswap64 __bswap_64
|
|||
#endif |
|||
|
|||
#ifdef _MSC_VER |
@ -0,0 +1,13 @@ |
|||
diff -u -r ../kona-Win.3.39-69/src/getline.h ./src/getline.h
|
|||
--- ../kona-Win.3.39-69/src/getline.h 2016-04-17 14:10:22.000000000 -0400
|
|||
+++ ./src/getline.h 2016-05-03 14:15:16.755266190 -0400
|
|||
@@ -7,8 +7,7 @@
|
|||
I expander(S *s,I n); |
|||
|
|||
#if defined(__OpenBSD__) || defined(__NetBSD__) || \ |
|||
- (defined(__MACH__) && __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1070) || \
|
|||
- defined(__ANDROID__)
|
|||
+ (defined(__MACH__) && __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1070)
|
|||
I getline(S *s,size_t * __restrict__ n,FILE *f); |
|||
I getdelim(S *s,size_t * __restrict__ n,I d,FILE *f); |
|||
#endif |
@ -1,8 +1,15 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://lftp.yar.ru/ |
|||
TERMUX_PKG_DESCRIPTION="FTP/HTTP client and file transfer program" |
|||
TERMUX_PKG_VERSION=4.6.5 |
|||
TERMUX_PKG_VERSION=4.7.1 |
|||
TERMUX_PKG_SRCURL=http://lftp.yar.ru/ftp/lftp-${TERMUX_PKG_VERSION}.tar.xz |
|||
# (1) Android has dn_expand, but lftp assumes that dn_skipname then exists, which it does not on android. |
|||
# (2) Use --with-openssl to use openssl instead of gnutls. |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_cv_func_dn_expand=no --with-openssl" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_cv_func_dn_expand=no --with-openssl --with-zlib=$TERMUX_STANDALONE_TOOLCHAIN/sysroot/usr --with-expat=$TERMUX_PREFIX" |
|||
TERMUX_PKG_DEPENDS="libexpat, openssl, readline, libutil, libidn" |
|||
|
|||
termux_step_pre_configure () { |
|||
# We have patched an m4 file. |
|||
cd $TERMUX_PKG_SRCDIR |
|||
aclocal |
|||
autoconf |
|||
} |
|||
|
@ -0,0 +1,12 @@ |
|||
diff -u -r ../lftp-4.7.1/m4/ax_check_zlib.m4 ./m4/ax_check_zlib.m4
|
|||
--- ../lftp-4.7.1/m4/ax_check_zlib.m4 2016-02-20 08:57:52.000000000 -0500
|
|||
+++ ./m4/ax_check_zlib.m4 2016-05-03 13:06:09.166707065 -0400
|
|||
@@ -70,7 +70,7 @@
|
|||
# Handle user hints |
|||
# |
|||
[AC_MSG_CHECKING(if zlib is wanted) |
|||
-zlib_places="/usr/local /usr /opt/local /sw"
|
|||
+zlib_places=""
|
|||
AC_ARG_WITH([zlib], |
|||
[ --with-zlib=DIR root directory path of zlib installation @<:@defaults to |
|||
/usr/local or /usr if not found in /usr/local@:>@ |
@ -1,6 +1,5 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://isl.gforge.inria.fr/ |
|||
TERMUX_PKG_DESCRIPTION="Library for manipulating sets and relations of integer points bounded by linear constraints" |
|||
TERMUX_PKG_VERSION=0.15 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_VERSION=0.16.1 |
|||
TERMUX_PKG_SRCURL=http://isl.gforge.inria.fr/isl-${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_DEPENDS="libgmp" |
|||
|
@ -1,6 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://wiki.gnome.org/action/show/Projects/LibRsvg |
|||
TERMUX_PKG_DESCRIPTION="Library to render SVG files using cairo" |
|||
TERMUX_PKG_VERSION=2.40.15 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_SRCURL=http://ftp.gnome.org/pub/GNOME/sources/librsvg/2.40/librsvg-${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_DEPENDS="libcroco,pango,gdk-pixbuf" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-introspection" |
|||
|
@ -1,7 +1,9 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://www.videolan.org/developers/x264.html |
|||
TERMUX_PKG_DESCRIPTION="Library for encoding video streams into the H.264/MPEG-4 AVC format" |
|||
TERMUX_PKG_VERSION="20141218-2245" |
|||
# NOTE: Switched from official ftp://ftp.videolan.org/ on 2014-12-21 since it was down: |
|||
TERMUX_PKG_SRCURL=http://mirror.yandex.ru/mirrors/ftp.videolan.org/x264/snapshots/x264-snapshot-${TERMUX_PKG_VERSION}-stable.tar.bz2 |
|||
# Avoid text relocations: |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-asm" |
|||
TERMUX_PKG_VERSION="20160503-2245" |
|||
TERMUX_PKG_SRCURL=ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-${TERMUX_PKG_VERSION}.tar.bz2 |
|||
if [ $TERMUX_ARCH = "i686" ]; then |
|||
# Avoid text relocations. Only needed on i686, see: |
|||
# https://mailman.videolan.org/pipermail/x264-devel/2016-March/011589.html |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-asm" |
|||
fi |
|||
|
@ -1,5 +1,4 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://www.nongnu.org/lzip/lzip.html |
|||
TERMUX_PKG_DESCRIPTION="Lossless data compressor similar to gzip and bzip2" |
|||
TERMUX_PKG_VERSION=1.18~rc2 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_SRCURL=http://download.savannah.gnu.org/releases/lzip/lzip-1.18-rc2.tar.lz |
|||
TERMUX_PKG_VERSION=1.18~rc3 |
|||
TERMUX_PKG_SRCURL=http://download.savannah.gnu.org/releases/lzip/lzip-1.18-rc3.tar.lz |
|||
|
@ -1,7 +1,6 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://www.pango.org/ |
|||
TERMUX_PKG_DESCRIPTION="Library for laying out and rendering text" |
|||
_MAJOR_VERSION=1.39 |
|||
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.0 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
_MAJOR_VERSION=1.40 |
|||
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.1 |
|||
TERMUX_PKG_SRCURL=http://ftp.gnome.org/pub/GNOME/sources/pango/${_MAJOR_VERSION}/pango-${TERMUX_PKG_VERSION}.tar.xz |
|||
TERMUX_PKG_DEPENDS="fontconfig,glib,harfbuzz,libcairo" |
|||
|
@ -1,6 +1,6 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://www.gnu.org/software/parallel/ |
|||
TERMUX_PKG_DESCRIPTION="GNU Parallel is a shell tool for executing jobs in parallel using one or more machines" |
|||
TERMUX_PKG_VERSION=20160322 |
|||
TERMUX_PKG_VERSION=20160422 |
|||
TERMUX_PKG_SRCURL=http://ftp.gnu.org/gnu/parallel/parallel-${TERMUX_PKG_VERSION}.tar.bz2 |
|||
TERMUX_PKG_DEPENDS="perl" |
|||
TERMUX_PKG_PLATFORM_INDEPENDENT=yes |
|||
|
@ -1,7 +1,6 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://subversion.apache.org/ |
|||
TERMUX_PKG_DESCRIPTION="Centralized version control system characterized by its simplicity" |
|||
TERMUX_PKG_VERSION=1.9.3 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_VERSION=1.9.4 |
|||
TERMUX_PKG_SRCURL=http://apache.mirrors.spacedump.net/subversion/subversion-${TERMUX_PKG_VERSION}.tar.bz2 |
|||
TERMUX_PKG_DEPENDS="apr, apr-util, serf, libexpat, libsqlite" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--without-sasl --without-libmagic" |
|||
|
@ -1,6 +1,13 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://zbar.sourceforge.net |
|||
TERMUX_PKG_DESCRIPTION="Software suite for reading bar codes from various sources" |
|||
TERMUX_PKG_VERSION=0.10 |
|||
TERMUX_PKG_BUILD_REVISION=1 |
|||
TERMUX_PKG_SRCURL=http://downloads.sourceforge.net/project/zbar/zbar/0.10/zbar-${TERMUX_PKG_VERSION}.tar.bz2 |
|||
TERMUX_PKG_DEPENDS="imagemagick" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-pthread --disable-video --without-xshm --without-xv --without-gtk --without-qt --without-python --mandir=$TERMUX_PREFIX/share/man" |
|||
|
|||
termux_step_pre_configure () { |
|||
# Run autoreconf since we have patched configure.ac |
|||
cd $TERMUX_PKG_SRCDIR |
|||
autoconf |
|||
} |
|||
|
@ -0,0 +1,20 @@ |
|||
diff -u -r ../zbar-0.10/configure.ac ./configure.ac
|
|||
--- ../zbar-0.10/configure.ac 2009-10-23 14:16:44.000000000 -0400
|
|||
+++ ./configure.ac 2016-05-03 09:00:57.495043230 -0400
|
|||
@@ -281,15 +281,7 @@
|
|||
])])]) |
|||
MAGICK_VERSION=`$PKG_CONFIG MagickWand --modversion` |
|||
AC_MSG_NOTICE([using ImageMagick version $MAGICK_VERSION]) |
|||
-
|
|||
-dnl double check ImageMagick install (bug #2582232)
|
|||
- CPPFLAGS_save="$CPPFLAGS"
|
|||
- CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
|
|||
- AC_CHECK_HEADER([wand/MagickWand.h], [],
|
|||
- [AC_MSG_FAILURE([ImageMagick package found but wand/MagickWand.h not installed?!
|
|||
-this is a problem with your ImageMagick install,
|
|||
-please resolve the inconsistency and try again...])])
|
|||
- CPPFLAGS="$CPPFLAGS_save"])
|
|||
+ ])
|
|||
|
|||
AM_CONDITIONAL([HAVE_MAGICK], [test "x$with_imagemagick" = "xyes"]) |
|||
|
@ -0,0 +1,12 @@ |
|||
diff -u -r ../zbar-0.10/zbarimg/zbarimg.c ./zbarimg/zbarimg.c
|
|||
--- ../zbar-0.10/zbarimg/zbarimg.c 2009-10-23 14:16:44.000000000 -0400
|
|||
+++ ./zbarimg/zbarimg.c 2016-05-03 08:54:42.053504890 -0400
|
|||
@@ -38,7 +38,7 @@
|
|||
#include <assert.h> |
|||
|
|||
#include <zbar.h> |
|||
-#include <wand/MagickWand.h>
|
|||
+#include <ImageMagick-7/MagickWand/MagickWand.h>
|
|||
|
|||
/* in 6.4.5.4 MagickGetImagePixels changed to MagickExportImagePixels. |
|||
* (still not sure this check is quite right... |
Loading…
Reference in new issue