committed by
Fredrik Fornwall
5 changed files with 72 additions and 0 deletions
@ -0,0 +1,16 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://rybczak.net/ncmpcpp/ |
|||
TERMUX_PKG_DESCRIPTION="NCurses Music Player Client (Plus Plus)" |
|||
TERMUX_PKG_VERSION=0.7.7 |
|||
local _COMMIT=8134e6e23b2787322fa10e65e44d286da82eea91 |
|||
TERMUX_PKG_SRCURL=https://github.com/arybczak/ncmpcpp/archive/${_COMMIT}.zip |
|||
TERMUX_PKG_FOLDERNAME="ncmpcpp-$_COMMIT" |
|||
TERMUX_PKG_SHA256=aced88b623ef79f6ccf619f769e7f4b6680d395aef9a789cee6d019927577c62 |
|||
TERMUX_PKG_DEPENDS="fftw, boost, readline, libcurl, libmpdclient" |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
|||
TERMUX_PKG_KEEP_SHARE_DOC=yes |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-visualizer --enable-outputs --enable-clock" |
|||
|
|||
termux_step_pre_configure() { |
|||
./autogen.sh |
|||
CXXFLAGS+=" -DNCURSES_WIDECHAR -U_XOPEN_SOURCE" |
|||
} |
@ -0,0 +1,17 @@ |
|||
--- ../cache/ncmpcpp-8134e6e23b2787322fa10e65e44d286da82eea91/doc/config 2017-04-23 02:24:57.000000000 +0000
|
|||
+++ ./doc/config 2017-05-13 23:29:50.055629354 +0000
|
|||
@@ -49,7 +49,13 @@
|
|||
## } |
|||
## |
|||
# |
|||
-#visualizer_fifo_path = /tmp/mpd.fifo
|
|||
+visualizer_fifo_path = "/data/data/com.termux/files/usr/tmp/mpd.fifo"
|
|||
+visualizer_output_name = "my_fifo"
|
|||
+visualizer_sync_interval = "30"
|
|||
+visualizer_in_stereo = "yes"
|
|||
+visualizer_type = "spectrum"
|
|||
+visualizer_look = "+|"
|
|||
+
|
|||
# |
|||
## |
|||
## Note: Below parameter is needed for ncmpcpp to determine which output |
@ -0,0 +1,15 @@ |
|||
--- ../cache/ncmpcpp-8134e6e23b2787322fa10e65e44d286da82eea91/configure.ac 2017-04-23 02:24:57.000000000 +0000
|
|||
+++ ./configure.ac 2017-05-06 00:32:15.468042009 +0000
|
|||
@@ -147,9 +147,9 @@
|
|||
fi |
|||
|
|||
# pthread |
|||
-AC_CHECK_LIB(pthread, pthread_create, LIBS="$LIBS -lpthread",
|
|||
- AC_MSG_ERROR([pthread library is required])
|
|||
-)
|
|||
+#AC_CHECK_LIB(pthread, pthread_create, LIBS="$LIBS -lboost_thread",
|
|||
+# AC_MSG_ERROR([pthread library is required])
|
|||
+#)
|
|||
|
|||
# ncursesw |
|||
PKG_CHECK_MODULES([ncursesw], [ncursesw], [ |
@ -0,0 +1,13 @@ |
|||
--- ../cache/ncmpcpp-8134e6e23b2787322fa10e65e44d286da82eea91/src/ncmpcpp.cpp 2017-04-23 02:24:57.000000000 +0000
|
|||
+++ ./src/ncmpcpp.cpp 2017-04-30 03:20:01.848812572 +0000
|
|||
@@ -108,8 +108,8 @@
|
|||
cerr_buffer = std::cerr.rdbuf(); |
|||
std::cerr.rdbuf(errorlog.rdbuf()); |
|||
|
|||
- sigignore(SIGPIPE);
|
|||
- signal(SIGWINCH, sighandler);
|
|||
+ // sigignore(SIGPIPE);
|
|||
+ // signal(SIGWINCH, sighandler);
|
|||
|
|||
Mpd.setNoidleCallback(Status::update); |
|||
|
@ -0,0 +1,11 @@ |
|||
--- ../cache/ncmpcpp-8134e6e23b2787322fa10e65e44d286da82eea91/src/settings.cpp 2017-04-23 02:24:57.000000000 +0000
|
|||
+++ ./src/settings.cpp 2017-05-14 00:38:51.558248240 +0000
|
|||
@@ -211,7 +211,7 @@
|
|||
// keep the same order of variables as in configuration file |
|||
p.add("ncmpcpp_directory", &ncmpcpp_directory, "~/.ncmpcpp/", adjust_directory); |
|||
p.add("lyrics_directory", &lyrics_directory, "~/.lyrics/", adjust_directory); |
|||
- p.add<void>("mpd_host", nullptr, "localhost", [](std::string host) {
|
|||
+ p.add<void>("mpd_host", nullptr, "~/.mpd/socket", [](std::string host) {
|
|||
expand_home(host); |
|||
Mpd.SetHostname(host); |
|||
}); |
Loading…
Reference in new issue