Leonid Plyushch
5 years ago
No known key found for this signature in database
GPG Key ID: 45F2964132545795
2 changed files with
20 additions and
7 deletions
-
packages/rgbds/Makefile.patch
-
packages/rgbds/src-extern-getopt.c.patch
|
@ -1,5 +1,6 @@ |
|
|
--- ../Makefile.orig 2019-11-01 17:25:45.000000000 +0100
|
|
|
diff -uNr rgbds/Makefile rgbds.mod/Makefile
|
|
|
+++ ./Makefile 2020-02-23 21:55:43.646881105 +0100
|
|
|
--- rgbds/Makefile 2020-04-04 12:01:55.000000000 +0300
|
|
|
|
|
|
+++ rgbds.mod/Makefile 2020-04-14 23:07:08.846835851 +0300
|
|
|
@@ -11,11 +11,9 @@
|
|
|
@@ -11,11 +11,9 @@
|
|
|
|
|
|
|
|
|
# User-defined variables |
|
|
# User-defined variables |
|
@ -18,12 +19,12 @@ |
|
|
WARNFLAGS := -Wall |
|
|
WARNFLAGS := -Wall |
|
|
|
|
|
|
|
|
-# Overridable CFLAGS
|
|
|
-# Overridable CFLAGS
|
|
|
-CFLAGS := -g
|
|
|
-CFLAGS := -O3
|
|
|
# Non-overridable CFLAGS |
|
|
# Non-overridable CFLAGS |
|
|
REALCFLAGS := ${CFLAGS} ${WARNFLAGS} -std=c99 -D_POSIX_C_SOURCE=200809L \ |
|
|
REALCFLAGS := ${CFLAGS} ${WARNFLAGS} -std=c11 -D_POSIX_C_SOURCE=200809L \ |
|
|
-Iinclude -DBUILD_VERSION_STRING=\"${VERSION_STRING}\" |
|
|
-D_DEFAULT_SOURCE -Iinclude |
|
|
-# Overridable LDFLAGS
|
|
|
-# Overridable LDFLAGS
|
|
|
-LDFLAGS :=
|
|
|
-LDFLAGS :=
|
|
|
# Non-overridable LDFLAGS |
|
|
# Non-overridable LDFLAGS |
|
|
REALLDFLAGS := ${LDFLAGS} ${WARNFLAGS} |
|
|
REALLDFLAGS := ${LDFLAGS} ${WARNFLAGS} \ |
|
|
|
|
|
-DBUILD_VERSION_STRING=\"${VERSION_STRING}\" |
|
|
|
@ -0,0 +1,12 @@ |
|
|
|
|
|
diff -uNr rgbds/src/extern/getopt.c rgbds.mod/src/extern/getopt.c
|
|
|
|
|
|
--- rgbds/src/extern/getopt.c 2020-04-03 14:52:29.000000000 +0300
|
|
|
|
|
|
+++ rgbds.mod/src/extern/getopt.c 2020-04-14 23:04:52.158998525 +0300
|
|
|
|
|
|
@@ -108,7 +108,7 @@
|
|
|
|
|
|
} |
|
|
|
|
|
cnt++; |
|
|
|
|
|
} |
|
|
|
|
|
- if (cnt==1 && longonly && arg-start == mblen(start, MB_LEN_MAX)) {
|
|
|
|
|
|
+ if (cnt==1 && longonly && arg-start == mbtowc(0, start, MB_LEN_MAX)) {
|
|
|
|
|
|
int l = arg-start; |
|
|
|
|
|
for (i=0; optstring[i]; i++) { |
|
|
|
|
|
int j; |