Browse Source
Without this patch the path compiled into the library is actually "/data/data/com.termux/files/usr/share/libical"/zoneinfo with the extra quotes. This patch makes it /data/data/com.termux/files/usr/share/libical/zoneinfo which will hopefully make the library work without calling set_zone_directory(). See #1913.android-5
Fredrik Fornwall
7 years ago
2 changed files with 13 additions and 1 deletions
@ -1,7 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://libical.github.io/libical/ |
|||
TERMUX_PKG_DESCRIPTION="Libical is an Open Source implementation of the iCalendar protocols and protocol data units" |
|||
TERMUX_PKG_VERSION=3.0.1 |
|||
TERMUX_PKG_REVISION=1 |
|||
TERMUX_PKG_REVISION=2 |
|||
TERMUX_PKG_SRCURL=https://github.com/libical/libical/releases/download/v$TERMUX_PKG_VERSION/libical-$TERMUX_PKG_VERSION.tar.gz |
|||
TERMUX_PKG_DEPENDS="libxml2" |
|||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" -DSHARED_ONLY=true -DICAL_GLIB=false -DUSE_BUILTIN_TZDATA=true" |
|||
|
@ -0,0 +1,12 @@ |
|||
diff -u -r ../libical-3.0.1/src/libical/CMakeLists.txt ./src/libical/CMakeLists.txt
|
|||
--- ../libical-3.0.1/src/libical/CMakeLists.txt 2017-11-19 15:32:53.000000000 +0100
|
|||
+++ ./src/libical/CMakeLists.txt 2017-12-09 22:14:42.254898817 +0100
|
|||
@@ -17,7 +17,7 @@
|
|||
include_directories(${ICU_INCLUDE_DIR}) |
|||
endif() |
|||
|
|||
-set(PACKAGE_DATA_DIR "\\\"${CMAKE_INSTALL_PREFIX}/share/libical\\\"")
|
|||
+set(PACKAGE_DATA_DIR "${CMAKE_INSTALL_PREFIX}/share/libical")
|
|||
add_definitions(-DPACKAGE_DATA_DIR="${PACKAGE_DATA_DIR}") |
|||
|
|||
set(ICALSCRIPTS ${CMAKE_SOURCE_DIR}/scripts/) |
Loading…
Reference in new issue