Fredrik Fornwall
6 years ago
4 changed files with 3 additions and 39 deletions
@ -1,12 +0,0 @@ |
|||
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/Cargo.toml ./Cargo.toml
|
|||
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/Cargo.toml 2018-10-14 15:21:13.000000000 +0000
|
|||
+++ ./Cargo.toml 2018-10-18 03:04:56.228613011 +0000
|
|||
@@ -41,7 +41,7 @@
|
|||
term_grid = "0.1.6" |
|||
term_size = "0.3.0" |
|||
unicode-width = "0.1.4" |
|||
-users = "0.7"
|
|||
+users = "0.8.1"
|
|||
zoneinfo_compiled = "0.4.7" |
|||
|
|||
[build-dependencies] |
@ -1,12 +0,0 @@ |
|||
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/groups.rs ./src/output/render/groups.rs
|
|||
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/groups.rs 2018-10-14 15:21:13.000000000 +0000
|
|||
+++ ./src/output/render/groups.rs 2018-10-18 03:12:48.223359766 +0000
|
|||
@@ -24,7 +24,7 @@
|
|||
} |
|||
} |
|||
|
|||
- TextCell::paint(style, group.name().to_owned())
|
|||
+ TextCell::paint(style, group.name().to_str().unwrap().to_owned())
|
|||
} |
|||
} |
|||
|
@ -1,12 +0,0 @@ |
|||
diff -u -r ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/users.rs ./src/output/render/users.rs
|
|||
--- ../exa-57e4c08411f59e7db91fa7d8127fbd412667ea32/src/output/render/users.rs 2018-10-14 15:21:13.000000000 +0000
|
|||
+++ ./src/output/render/users.rs 2018-10-18 03:13:18.959014671 +0000
|
|||
@@ -9,7 +9,7 @@
|
|||
impl f::User { |
|||
pub fn render<C: Colours, U: Users>(&self, colours: &C, users: &U) -> TextCell { |
|||
let user_name = match users.get_user_by_uid(self.0) { |
|||
- Some(user) => user.name().to_owned(),
|
|||
+ Some(user) => user.name().to_str().unwrap().to_owned(),
|
|||
None => self.0.to_string(), |
|||
}; |
|||
|
Loading…
Reference in new issue