Browse Source

new package: sc

android-5
Leonid Plyushch 6 years ago
committed by Fredrik Fornwall
parent
commit
cd3fcd8aa3
  1. 55
      packages/sc/Makefile.patch
  2. 15
      packages/sc/build.sh
  3. 32
      packages/sc/cmds.c.patch

55
packages/sc/Makefile.patch

@ -0,0 +1,55 @@
--- Makefile 2018-02-23 05:27:24.471990919 +0000
+++ src/Makefile 2018-02-23 05:45:28.024744930 +0000
@@ -20,13 +20,13 @@
# packaging this with an O/S, for example, you'll probably want to change
# this to /usr. Otherwise, /usr/local is probably more appropriate, unless
# you're replacing the vendor-supplied version.
-prefix=/usr
+prefix=/data/data/com.termux/files/usr
# This is where the install step puts it.
EXDIR=${prefix}/bin
# This is where the man page goes.
-MANDIR=${prefix}/man/man1
+MANDIR=${prefix}/share/man/man1
MANEXT=1
MANMODE=644
@@ -331,13 +331,14 @@
#########################################
# Use this for Linux
-CC=gcc
+# CC=gcc
# Only use -Wall for testing, since it produces warnings that are of no
# real effect on the reliability of the program, but may concern some
# people who don't understand them.
#CFLAGS=-DSYSV3 -O2 -Wall -pipe
-CFLAGS=-DSYSV3 -O2 -pipe
-LIB=-lm -lncurses
+# CFLAGS=-DSYSV3 -O2 -pipe
+
+LIB=-L$(prefix)/lib -lm -lncurses
# All of the source files
SRC=Makefile abbrev.c cmds.c color.c crypt.c eres.sed frame.c format.c gram.y \
@@ -500,15 +501,15 @@
$(EXDIR)/$(name): $(name)
cp $(name) $(EXDIR)
- strip $(EXDIR)/$(name)
+ $(STRIP) $(EXDIR)/$(name)
$(EXDIR)/$(name)qref: $(name)qref
cp $(name)qref $(EXDIR)
- strip $(EXDIR)/$(name)qref
+ $(STRIP) $(EXDIR)/$(name)qref
$(EXDIR)/p$(name): p$(name)
cp p$(name) $(EXDIR)
- strip $(EXDIR)/p$(name)
+ $(STRIP) $(EXDIR)/p$(name)
$(LIBDIR)/tutorial: tutorial.sc $(LIBDIR)
-mkdir -p $(LIBDIR)/plugins

15
packages/sc/build.sh

@ -0,0 +1,15 @@
TERMUX_PKG_HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/financial/spreadsheet/!INDEX.html"
TERMUX_PKG_DESCRIPTION="A vi-like spreadsheet calculator"
TERMUX_PKG_LICENSE="Public Domain"
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
TERMUX_PKG_VERSION=7.16
TERMUX_PKG_REVISION=3
TERMUX_PKG_SRCURL=http://www.ibiblio.org/pub/Linux/apps/financial/spreadsheet/sc-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=1997a00b6d82d189b65f6fd2a856a34992abc99e50d9ec463bbf1afb750d1765
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_BUILD_IN_SRC=yes
TERMUX_PKG_EXTRA_MAKE_ARGS="SIMPLE=-DSIMPLE"
termux_step_post_configure () {
CFLAGS+=" -I$TERMUX_PREFIX/include"
}

32
packages/sc/cmds.c.patch

@ -0,0 +1,32 @@
--- cmds.c 2018-02-23 05:38:39.654230131 +0000
+++ src/cmds.c 2018-02-23 05:39:23.222435074 +0000
@@ -2861,12 +2861,12 @@
if ((plugin = findplugin(p+1, 'w')) != NULL) {
if (!plugin_exists(plugin, strlen(plugin), save + 1)) {
error("plugin not found");
- return;
+ return 1;
}
*save = '|';
if ((strlen(save) + strlen(fname) + 20) > PATHLEN) {
error("Path too long");
- return;
+ return 1;
}
sprintf(save + strlen(save), " %s%d:", coltoa(c0), r0);
sprintf(save + strlen(save), "%s%d \"%s\"", coltoa(cn), rn, fname);
@@ -2981,12 +2981,12 @@
if ((plugin = findplugin(p+1, 'r')) != NULL) {
if (!(plugin_exists(plugin, strlen(plugin), save + 1))) {
error("plugin not found");
- return;
+ return 1;
}
*save = '|';
if ((strlen(save) + strlen(fname) + 2) > PATHLEN) {
error("Path too long");
- return;
+ return 1;
}
sprintf(save + strlen(save), " \"%s\"", fname);
eraseflg = 0;
Loading…
Cancel
Save