Browse Source
* alpine should compile * fix arm build * combined patches and adjusted build.sh * add maildir supportandroid-5
its-pointless
8 years ago
committed by
Fredrik Fornwall
18 changed files with 5771 additions and 22 deletions
File diff suppressed because it is too large
@ -0,0 +1,27 @@ |
|||
--- ../cache/alpine-2.20/imap/src/osdep/unix/maildir.c 2016-12-15 23:03:33.602342634 +0000
|
|||
+++ ./imap/src/osdep/unix/maildir.c 2016-12-15 23:15:58.433872870 +0000
|
|||
@@ -9,7 +9,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include <pwd.h> |
|||
#include <sys/stat.h> |
|||
@@ -20,7 +19,6 @@
|
|||
#include "misc.h" |
|||
#include "dummy.h" |
|||
#include "maildir.h" |
|||
-
|
|||
/* Driver dispatch used by MAIL */ |
|||
DRIVER maildirdriver = { |
|||
"md", /* driver name, yes it's md, not maildir */ |
|||
@@ -1491,7 +1489,7 @@
|
|||
} |
|||
} while (done == 0); |
|||
|
|||
- if ((fd = open (path1,O_WRONLY|O_CREAT|O_EXCL,S_IREAD|S_IWRITE)) < 0) {
|
|||
+ if ((fd = open (path1,O_WRONLY|O_CREAT|O_EXCL,S_IRUSR|S_IWUSR)) < 0) {
|
|||
snprintf (tmp, sizeof(tmp), "Can't open append mailbox: %s", strerror (errno)); |
|||
mm_log (tmp, ERROR); |
|||
return NIL; |
@ -0,0 +1,232 @@ |
|||
/* Copyright (C) 1992-2001, 2003-2007, 2009-2016 Free Software Foundation, Inc.
|
|||
|
|||
This file is part of the GNU C Library. |
|||
|
|||
This program is free software; you can redistribute it and/or modify |
|||
it under the terms of the GNU General Public License as published by |
|||
the Free Software Foundation; either version 2, or (at your option) |
|||
any later version. |
|||
|
|||
This program is distributed in the hope that it will be useful, |
|||
but WITHOUT ANY WARRANTY; without even the implied warranty of |
|||
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
|||
GNU General Public License for more details. |
|||
|
|||
You should have received a copy of the GNU General Public License along |
|||
with this program; if not, see <http://www.gnu.org/licenses/>. */
|
|||
|
|||
/*#ifndef _LIBC
|
|||
# include <config.h> |
|||
#endifi*/ |
|||
|
|||
#include "getpass.h" |
|||
|
|||
|
|||
#include <stdio.h> |
|||
|
|||
#if !((defined _WIN32 || defined __WIN32__) && !defined __CYGWIN__) |
|||
|
|||
# include <stdbool.h> |
|||
|
|||
# if HAVE_DECL___FSETLOCKING && HAVE___FSETLOCKING |
|||
# if HAVE_STDIO_EXT_H |
|||
# include <stdio_ext.h> |
|||
# endif |
|||
# else |
|||
# define __fsetlocking(stream, type) /* empty */ |
|||
# endif |
|||
|
|||
# if HAVE_TERMIOS_H |
|||
# include <termios.h> |
|||
# endif |
|||
|
|||
# if USE_UNLOCKED_IO |
|||
# include "unlocked-io.h" |
|||
# else |
|||
# if !HAVE_DECL_FFLUSH_UNLOCKED |
|||
# undef fflush_unlocked |
|||
# define fflush_unlocked(x) fflush (x) |
|||
# endif |
|||
# if !HAVE_DECL_FLOCKFILE |
|||
# undef flockfile |
|||
# define flockfile(x) ((void) 0) |
|||
# endif |
|||
# if !HAVE_DECL_FUNLOCKFILE |
|||
# undef funlockfile |
|||
# define funlockfile(x) ((void) 0) |
|||
# endif |
|||
# if !HAVE_DECL_FPUTS_UNLOCKED |
|||
# undef fputs_unlocked |
|||
# define fputs_unlocked(str,stream) fputs (str, stream) |
|||
# endif |
|||
# if !HAVE_DECL_PUTC_UNLOCKED |
|||
# undef putc_unlocked |
|||
# define putc_unlocked(c,stream) putc (c, stream) |
|||
# endif |
|||
# endif |
|||
|
|||
/* It is desirable to use this bit on systems that have it.
|
|||
The only bit of terminal state we want to twiddle is echoing, which is |
|||
done in software; there is no need to change the state of the terminal |
|||
hardware. */ |
|||
|
|||
# ifndef TCSASOFT |
|||
# define TCSASOFT 0 |
|||
# endif |
|||
|
|||
static void |
|||
call_fclose (void *arg) |
|||
{ |
|||
if (arg != NULL) |
|||
fclose (arg); |
|||
} |
|||
|
|||
char * |
|||
getpass (const char *prompt) |
|||
{ |
|||
FILE *tty; |
|||
FILE *in, *out; |
|||
# if HAVE_TCGETATTR |
|||
struct termios s, t; |
|||
# endif |
|||
bool tty_changed = false; |
|||
static char *buf; |
|||
static size_t bufsize; |
|||
ssize_t nread; |
|||
|
|||
/* Try to write to and read from the terminal if we can.
|
|||
If we can't open the terminal, use stderr and stdin. */ |
|||
|
|||
tty = fopen ("/dev/tty", "w+"); |
|||
if (tty == NULL) |
|||
{ |
|||
in = stdin; |
|||
out = stderr; |
|||
} |
|||
else |
|||
{ |
|||
/* We do the locking ourselves. */ |
|||
__fsetlocking (tty, FSETLOCKING_BYCALLER); |
|||
|
|||
out = in = tty; |
|||
} |
|||
|
|||
flockfile (out); |
|||
|
|||
/* Turn echoing off if it is on now. */ |
|||
# if HAVE_TCGETATTR |
|||
if (tcgetattr (fileno (in), &t) == 0) |
|||
{ |
|||
/* Save the old one. */ |
|||
s = t; |
|||
/* Tricky, tricky. */ |
|||
t.c_lflag &= ~(ECHO | ISIG); |
|||
tty_changed = (tcsetattr (fileno (in), TCSAFLUSH | TCSASOFT, &t) == 0); |
|||
} |
|||
# endif |
|||
|
|||
/* Write the prompt. */ |
|||
fputs_unlocked (prompt, out); |
|||
fflush_unlocked (out); |
|||
|
|||
/* Read the password. */ |
|||
nread = getline (&buf, &bufsize, in); |
|||
|
|||
/* According to the C standard, input may not be followed by output
|
|||
on the same stream without an intervening call to a file |
|||
positioning function. Suppose in == out; then without this fseek |
|||
call, on Solaris, HP-UX, AIX, OSF/1, the previous input gets |
|||
echoed, whereas on IRIX, the following newline is not output as |
|||
it should be. POSIX imposes similar restrictions if fileno (in) |
|||
== fileno (out). The POSIX restrictions are tricky and change |
|||
from POSIX version to POSIX version, so play it safe and invoke |
|||
fseek even if in != out. */ |
|||
fseeko (out, 0, SEEK_CUR); |
|||
|
|||
if (buf != NULL) |
|||
{ |
|||
if (nread < 0) |
|||
buf[0] = '\0'; |
|||
else if (buf[nread - 1] == '\n') |
|||
{ |
|||
/* Remove the newline. */ |
|||
buf[nread - 1] = '\0'; |
|||
if (tty_changed) |
|||
{ |
|||
/* Write the newline that was not echoed. */ |
|||
putc_unlocked ('\n', out); |
|||
} |
|||
} |
|||
} |
|||
|
|||
/* Restore the original setting. */ |
|||
# if HAVE_TCSETATTR |
|||
if (tty_changed) |
|||
tcsetattr (fileno (in), TCSAFLUSH | TCSASOFT, &s); |
|||
# endif |
|||
|
|||
funlockfile (out); |
|||
|
|||
call_fclose (tty); |
|||
|
|||
return buf; |
|||
} |
|||
|
|||
#else /* W32 native */ |
|||
|
|||
/* Windows implementation by Martin Lambers <marlam@marlam.de>,
|
|||
improved by Simon Josefsson. */ |
|||
|
|||
/* For PASS_MAX. */ |
|||
# include <limits.h> |
|||
/* For _getch(). */ |
|||
# include <conio.h> |
|||
/* For strdup(). */ |
|||
# include <string.h> |
|||
|
|||
# ifndef PASS_MAX |
|||
# define PASS_MAX 512 |
|||
# endif |
|||
|
|||
char * |
|||
getpass (const char *prompt) |
|||
{ |
|||
char getpassbuf[PASS_MAX + 1]; |
|||
size_t i = 0; |
|||
int c; |
|||
|
|||
if (prompt) |
|||
{ |
|||
fputs (prompt, stderr); |
|||
fflush (stderr); |
|||
} |
|||
|
|||
for (;;) |
|||
{ |
|||
c = _getch (); |
|||
if (c == '\r') |
|||
{ |
|||
getpassbuf[i] = '\0'; |
|||
break; |
|||
} |
|||
else if (i < PASS_MAX) |
|||
{ |
|||
getpassbuf[i++] = c; |
|||
} |
|||
|
|||
if (i >= PASS_MAX) |
|||
{ |
|||
getpassbuf[i] = '\0'; |
|||
break; |
|||
} |
|||
} |
|||
|
|||
if (prompt) |
|||
{ |
|||
fputs ("\r\n", stderr); |
|||
fflush (stderr); |
|||
} |
|||
|
|||
return strdup (getpassbuf); |
|||
} |
|||
#endif |
@ -0,0 +1,30 @@ |
|||
/* getpass.h -- Read a password of arbitrary length from /dev/tty or stdin.
|
|||
Copyright (C) 2004, 2009-2016 Free Software Foundation, Inc. |
|||
Contributed by Simon Josefsson <jas@extundo.com>, 2004. |
|||
|
|||
This program is free software; you can redistribute it and/or modify |
|||
it under the terms of the GNU General Public License as published by |
|||
the Free Software Foundation; either version 2, or (at your option) |
|||
any later version. |
|||
|
|||
This program is distributed in the hope that it will be useful, |
|||
but WITHOUT ANY WARRANTY; without even the implied warranty of |
|||
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
|||
GNU General Public License for more details. |
|||
|
|||
You should have received a copy of the GNU General Public License |
|||
along with this program; if not, see <http://www.gnu.org/licenses/>. */
|
|||
|
|||
#ifndef GETPASS_H |
|||
# define GETPASS_H |
|||
|
|||
/* Get getpass declaration, if available. */ |
|||
# include <unistd.h> |
|||
|
|||
# if !HAVE_DECL_GETPASS |
|||
/* Read a password of arbitrary length from /dev/tty or stdin. */ |
|||
char *getpass (const char *prompt); |
|||
|
|||
# endif |
|||
|
|||
#endif /* GETPASS_H */ |
@ -1,14 +1,45 @@ |
|||
diff -u -r ../alpine-2.20/imap/src/osdep/unix/Makefile ./imap/src/osdep/unix/Makefile
|
|||
--- ../alpine-2.20/imap/src/osdep/unix/Makefile 2015-01-12 00:12:25.505178442 -0500
|
|||
+++ ./imap/src/osdep/unix/Makefile 2016-04-14 17:06:00.090973009 -0400
|
|||
@@ -132,10 +132,7 @@
|
|||
--- ../cache/alpine-2.20/imap/src/osdep/unix/Makefile 2015-01-12 05:12:25.505178442 +0000
|
|||
+++ ./imap/src/osdep/unix/Makefile 2016-12-11 07:08:54.821695452 +0000
|
|||
@@ -131,13 +131,8 @@
|
|||
|
|||
# Commands possibly overriden by the individual port |
|||
|
|||
# Commands possibly overriden by the individual port |
|||
-
|
|||
-ARRC=ar rc
|
|||
-CC=cc
|
|||
LN=ln -s |
|||
-RANLIB=ranlib
|
|||
-
|
|||
-
|
|||
+AARC="ar rc"
|
|||
# Standard distribution build parameters |
|||
|
|||
DEFAULTAUTHENTICATORS=ext md5 pla log |
|||
@@ -513,8 +508,10 @@
|
|||
SPOOLDIR=/var/spool \ |
|||
ACTIVEFILE=/var/lib/news/active \ |
|||
RSHPATH=/usr/bin/rsh \ |
|||
- BASECFLAGS="$(GCCCFLAGS)"
|
|||
-
|
|||
+ CC=${TERMUX_HOST_PLATFORM}-gcc \
|
|||
+ BASECFLAGS="$(GCCCFLAGS)" \
|
|||
+ RANLIB="${TERMUX_HOST_PLATFORM}-ranlib"
|
|||
+
|
|||
lyn: # LynxOS |
|||
$(BUILD) `$(CAT) SPECIALS` OS=$@ \ |
|||
CRXTYPE=nfs \ |
|||
@@ -869,8 +866,13 @@
|
|||
all: $(ARCHIVE) |
|||
|
|||
# Standard distribution build parameters |
|||
$(ARCHIVE): $(BINARIES) |
|||
- sh -c '$(RM) $(ARCHIVE) || true'
|
|||
+ rm -rf client-a
|
|||
+ { echo -n 'ar rc '; cat ARCHIVE; } >ARCHIVE.new
|
|||
+ rm ARCHIVE
|
|||
+ mv ARCHIVE.new ARCHIVE
|
|||
+ chmod +x ARCHIVE
|
|||
@$(CAT) ./ARCHIVE |
|||
+
|
|||
@$(SH) ./ARCHIVE |
|||
|
|||
.c.o: |
|||
|
@ -1,13 +0,0 @@ |
|||
diff -u -r ../alpine-2.20/imap/src/osdep/unix/os_slx.c ./imap/src/osdep/unix/os_slx.c
|
|||
--- ../alpine-2.20/imap/src/osdep/unix/os_slx.c 2015-01-12 00:12:25.504178437 -0500
|
|||
+++ ./imap/src/osdep/unix/os_slx.c 2016-04-14 17:13:21.985871059 -0400
|
|||
@@ -35,9 +35,7 @@
|
|||
#include <netdb.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <pwd.h> |
|||
-#include <shadow.h>
|
|||
#include "misc.h" |
|||
|
|||
|
@ -0,0 +1,11 @@ |
|||
--- ../cache/alpine-2.20/imap/Makefile 2015-01-12 05:12:25.521178518 +0000
|
|||
+++ ./imap/Makefile 2016-12-11 06:43:56.986805502 +0000
|
|||
@@ -457,7 +457,7 @@
|
|||
# Linux shadow password support doesn't build on traditional systems, but most |
|||
# Linux systems are shadow these days. |
|||
|
|||
-lnx: lnxnul an
|
|||
+lnx: lnxok an
|
|||
$(BUILD) BUILDTYPE=$@ |
|||
|
|||
lnxnul: |
@ -0,0 +1,11 @@ |
|||
--- ../cache/alpine-2.20/imap/src/mlock/Makefile 2015-01-12 05:12:25.519178508 +0000
|
|||
+++ ./imap/src/mlock/Makefile 2016-12-11 02:35:52.824846520 +0000
|
|||
@@ -41,7 +41,7 @@
|
|||
install: mlock |
|||
chgrp mail mlock |
|||
chmod 3711 mlock |
|||
- cp -p mlock /etc/mlock
|
|||
+ cp -p mlock /data/data/com.termux/files/usr/etc/mlock
|
|||
|
|||
clean: |
|||
rm -f *.o mlock || true |
@ -0,0 +1,24 @@ |
|||
--- ../cache/alpine-2.20/imap/src/mtest/mtest.c 2015-01-12 05:12:25.501178422 +0000
|
|||
+++ ./imap/src/mtest/mtest.c 2016-12-11 21:13:22.392577687 +0000
|
|||
@@ -97,21 +97,7 @@
|
|||
} |
|||
#endif |
|||
curusr = cpystr (((s = myusername ()) && *s) ? s : "somebody"); |
|||
-#if UNIXLIKE
|
|||
- {
|
|||
- char *suffix;
|
|||
- struct passwd *pwd = getpwnam (curusr);
|
|||
- if (pwd) {
|
|||
- strcpy (tmp,pwd->pw_gecos);
|
|||
- /* dyke out the office and phone poop */
|
|||
- if (suffix = strchr (tmp,',')) suffix[0] = '\0';
|
|||
- strcpy (personalname,tmp);/* make a permanent copy of it */
|
|||
- }
|
|||
- else personalname[0] = '\0';
|
|||
- }
|
|||
-#else
|
|||
personalname[0] = '\0'; |
|||
-#endif
|
|||
curhst = cpystr (mylocalhost ()); |
|||
puts ("MTest -- C client test program"); |
|||
if (!*personalname) prompt ("Personal name: ",personalname, sizeof(personalname)); |
@ -0,0 +1,24 @@ |
|||
--- ../cache/alpine-2.20/imap/src/osdep/unix/os_lnx.c 2015-01-12 05:12:25.504178437 +0000
|
|||
+++ ./imap/src/osdep/unix/os_lnx.c 2016-12-10 23:25:18.054653878 +0000
|
|||
@@ -35,9 +35,9 @@
|
|||
#include <netdb.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <pwd.h> |
|||
#include "misc.h" |
|||
+#include "../../include/getpass.c"
|
|||
|
|||
|
|||
#include "fs_unix.c" |
|||
@@ -50,3 +50,10 @@
|
|||
#include "tz_sv4.c" |
|||
#include "flocklnx.c" |
|||
#include "utime.c" |
|||
+long gethostid (void)
|
|||
+{
|
|||
+return 0xdeadface;
|
|||
+}
|
|||
+
|
|||
+
|
|||
+
|
@ -0,0 +1,18 @@ |
|||
--- ../cache/alpine-2.20/imap/src/osdep/unix/os_lnx.h 2015-01-12 05:12:25.505178442 +0000
|
|||
+++ ./imap/src/osdep/unix/os_lnx.h 2016-12-10 23:21:20.644163814 +0000
|
|||
@@ -48,13 +48,13 @@
|
|||
#include <syslog.h> |
|||
#include <sys/file.h> |
|||
|
|||
-
|
|||
/* Linux gets this wrong */ |
|||
|
|||
#define setpgrp setpgid |
|||
|
|||
#define direct dirent |
|||
-
|
|||
+#define L_SET SEEK_SET
|
|||
+#define FNDELAY O_NDELAY
|
|||
#define flock safe_flock |
|||
|
|||
#define utime portable_utime |
@ -0,0 +1,10 @@ |
|||
--- ../cache/alpine-2.20/pico/osdep/filesys.c 2015-01-12 05:12:25.272177331 +0000
|
|||
+++ ./pico/osdep/filesys.c 2016-12-11 00:14:46.945596542 +0000
|
|||
@@ -777,7 +777,6 @@
|
|||
char *cb; |
|||
struct stat tsb, fsb; |
|||
EML eml; |
|||
- extern int errno;
|
|||
|
|||
if(our_stat(a, &fsb) < 0){ /* get source file info */ |
|||
eml.s = errstr(errno); |
@ -0,0 +1,12 @@ |
|||
--- ../cache/alpine-2.20/pico/osdep/filesys.h 2015-01-12 05:12:25.274177340 +0000
|
|||
+++ ./pico/osdep/filesys.h 2016-12-11 00:14:00.413116231 +0000
|
|||
@@ -17,7 +17,8 @@
|
|||
|
|||
#ifndef PICO_OSDEP_FILESYS_INCLUDED |
|||
#define PICO_OSDEP_FILESYS_INCLUDED |
|||
-
|
|||
+#define S_IWRITE S_IWUSR
|
|||
+#define S_IREAD S_IRUSR
|
|||
|
|||
#include "../../pith/osdep/canaccess.h" /* for *_ACCESS */ |
|||
|
@ -0,0 +1,25 @@ |
|||
--- ../cache/alpine-2.20/pith/Makefile.am 2015-01-12 05:12:25.585178823 +0000
|
|||
+++ ./pith/Makefile.am 2016-12-11 05:35:52.697766827 +0000
|
|||
@@ -29,19 +29,13 @@
|
|||
state.c status.c store.c stream.c string.c strlst.c takeaddr.c tempfile.c text.c \ |
|||
thread.c adjtime.c url.c util.c helptext.c smkeys.c smime.c |
|||
|
|||
-help_c_gen$(EXEEXT): $(help_c_gen_OBJECTS) $(help_c_gen_DEPENDENCIES)
|
|||
- @rm -f help_c_gen$(EXEEXT)
|
|||
- $(LINK) $(help_c_gen_OBJECTS) $(help_c_gen_LDADD)
|
|||
-help_h_gen$(EXEEXT): $(help_h_gen_OBJECTS) $(help_h_gen_DEPENDENCIES)
|
|||
- @rm -f help_h_gen$(EXEEXT)
|
|||
- $(LINK) $(help_h_gen_OBJECTS) $(help_h_gen_LDADD)
|
|||
|
|||
-helptext.c: help_c_gen pine.hlp
|
|||
+helptext.c: pine.hlp
|
|||
./help_c_gen < pine.hlp > $@ |
|||
|
|||
-helptext.h: help_h_gen pine.hlp
|
|||
+helptext.h: pine.hlp
|
|||
./help_h_gen < pine.hlp > $@ |
|||
|
|||
AM_CPPFLAGS = -I@top_builddir@/include -I@top_srcdir@/include |
|||
|
|||
-CLEANFILES = helptext.c helptext.h help_h_gen help_c_gen
|
|||
+CLEANFILES = helptext.c helptext.h
|
@ -0,0 +1,150 @@ |
|||
--- ../cache/alpine-2.20/pith/Makefile.in 2015-01-18 07:00:44.062653689 +0000
|
|||
+++ ./pith/Makefile.in 2016-12-11 05:32:58.043992422 +0000
|
|||
@@ -1,7 +1,7 @@
|
|||
-# Makefile.in generated by automake 1.13.4 from Makefile.am.
|
|||
+# Makefile.in generated by automake 1.15 from Makefile.am.
|
|||
# @configure_input@ |
|||
|
|||
-# Copyright (C) 1994-2013 Free Software Foundation, Inc.
|
|||
+# Copyright (C) 1994-2014 Free Software Foundation, Inc.
|
|||
|
|||
# This Makefile.in is free software; the Free Software Foundation |
|||
# gives unlimited permission to copy and/or distribute it, |
|||
@@ -27,7 +27,17 @@
|
|||
|
|||
|
|||
VPATH = @srcdir@ |
|||
-am__is_gnu_make = test -n '$(MAKEFILE_LIST)' && test -n '$(MAKELEVEL)'
|
|||
+am__is_gnu_make = { \
|
|||
+ if test -z '$(MAKELEVEL)'; then \
|
|||
+ false; \
|
|||
+ elif test -n '$(MAKE_HOST)'; then \
|
|||
+ true; \
|
|||
+ elif test -n '$(MAKE_VERSION)' && test -n '$(CURDIR)'; then \
|
|||
+ true; \
|
|||
+ else \
|
|||
+ false; \
|
|||
+ fi; \
|
|||
+}
|
|||
am__make_running_with_option = \ |
|||
case $${target_option-} in \ |
|||
?) ;; \ |
|||
@@ -92,8 +102,6 @@
|
|||
host_triplet = @host@ |
|||
noinst_PROGRAMS = help_h_gen$(EXEEXT) help_c_gen$(EXEEXT) |
|||
subdir = pith |
|||
-DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
|
|||
- $(top_srcdir)/mkinstalldirs $(top_srcdir)/depcomp
|
|||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4 |
|||
am__aclocal_m4_deps = $(top_srcdir)/m4/acx_pthread.m4 \ |
|||
$(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/iconv.m4 \ |
|||
@@ -111,6 +119,7 @@
|
|||
$(top_srcdir)/configure.ac |
|||
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \ |
|||
$(ACLOCAL_M4) |
|||
+DIST_COMMON = $(srcdir)/Makefile.am $(am__DIST_COMMON)
|
|||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs |
|||
CONFIG_HEADER = $(top_builddir)/include/config.h |
|||
CONFIG_CLEAN_FILES = |
|||
@@ -147,9 +156,6 @@
|
|||
smkeys.$(OBJEXT) smime.$(OBJEXT) |
|||
libpith_a_OBJECTS = $(am_libpith_a_OBJECTS) |
|||
PROGRAMS = $(noinst_PROGRAMS) |
|||
-help_c_gen_SOURCES = help_c_gen.c
|
|||
-help_c_gen_OBJECTS = help_c_gen.$(OBJEXT)
|
|||
-help_c_gen_LDADD = $(LDADD)
|
|||
AM_V_lt = $(am__v_lt_@AM_V@) |
|||
am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@) |
|||
am__v_lt_0 = --silent |
|||
@@ -191,8 +197,6 @@
|
|||
am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@) |
|||
am__v_CCLD_0 = @echo " CCLD " $@; |
|||
am__v_CCLD_1 = |
|||
-SOURCES = $(libpith_a_SOURCES) help_c_gen.c help_h_gen.c
|
|||
-DIST_SOURCES = $(libpith_a_SOURCES) help_c_gen.c help_h_gen.c
|
|||
RECURSIVE_TARGETS = all-recursive check-recursive cscopelist-recursive \ |
|||
ctags-recursive dvi-recursive html-recursive info-recursive \ |
|||
install-data-recursive install-dvi-recursive \ |
|||
@@ -234,6 +238,8 @@
|
|||
ETAGS = etags |
|||
CTAGS = ctags |
|||
DIST_SUBDIRS = $(SUBDIRS) |
|||
+am__DIST_COMMON = $(srcdir)/Makefile.in $(top_srcdir)/depcomp \
|
|||
+ $(top_srcdir)/mkinstalldirs
|
|||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST) |
|||
am__relativize = \ |
|||
dir0=`pwd`; \ |
|||
@@ -320,6 +326,7 @@
|
|||
LTLIBICONV = @LTLIBICONV@ |
|||
LTLIBINTL = @LTLIBINTL@ |
|||
LTLIBOBJS = @LTLIBOBJS@ |
|||
+LT_SYS_LIBRARY_PATH = @LT_SYS_LIBRARY_PATH@
|
|||
MAINT = @MAINT@ |
|||
MAKE = @MAKE@ |
|||
MAKEINFO = @MAKEINFO@ |
|||
@@ -413,6 +420,7 @@
|
|||
prefix = @prefix@ |
|||
program_transform_name = @program_transform_name@ |
|||
psdir = @psdir@ |
|||
+runstatedir = @runstatedir@
|
|||
sbindir = @sbindir@ |
|||
sharedstatedir = @sharedstatedir@ |
|||
srcdir = @srcdir@ |
|||
@@ -434,7 +442,7 @@
|
|||
thread.c adjtime.c url.c util.c helptext.c smkeys.c smime.c |
|||
|
|||
AM_CPPFLAGS = -I@top_builddir@/include -I@top_srcdir@/include |
|||
-CLEANFILES = helptext.c helptext.h help_h_gen help_c_gen
|
|||
+CLEANFILES = helptext.c helptext.h
|
|||
all: $(BUILT_SOURCES) |
|||
$(MAKE) $(AM_MAKEFLAGS) all-recursive |
|||
|
|||
@@ -452,7 +460,6 @@
|
|||
echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign pith/Makefile'; \ |
|||
$(am__cd) $(top_srcdir) && \ |
|||
$(AUTOMAKE) --foreign pith/Makefile |
|||
-.PRECIOUS: Makefile
|
|||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status |
|||
@case '$?' in \ |
|||
*config.status*) \ |
|||
@@ -488,6 +495,8 @@
|
|||
echo " rm -f" $$list; \ |
|||
rm -f $$list |
|||
|
|||
+
|
|||
+
|
|||
mostlyclean-compile: |
|||
-rm -f *.$(OBJEXT) |
|||
|
|||
@@ -568,14 +577,14 @@
|
|||
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po |
|||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=no @AMDEPBACKSLASH@ |
|||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@ |
|||
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c $<
|
|||
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c -o $@ $<
|
|||
|
|||
.c.obj: |
|||
@am__fastdepCC_TRUE@ $(AM_V_CC)$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'` |
|||
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po |
|||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=no @AMDEPBACKSLASH@ |
|||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@ |
|||
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c `$(CYGPATH_W) '$<'`
|
|||
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c -o $@ `$(CYGPATH_W) '$<'`
|
|||
|
|||
.c.lo: |
|||
@am__fastdepCC_TRUE@ $(AM_V_CC)$(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $< |
|||
@@ -872,13 +881,8 @@
|
|||
mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \ |
|||
tags tags-am uninstall uninstall-am |
|||
|
|||
+.PRECIOUS: Makefile
|
|||
|
|||
-help_c_gen$(EXEEXT): $(help_c_gen_OBJECTS) $(help_c_gen_DEPENDENCIES)
|
|||
- @rm -f help_c_gen$(EXEEXT)
|
|||
- $(LINK) $(help_c_gen_OBJECTS) $(help_c_gen_LDADD)
|
|||
-help_h_gen$(EXEEXT): $(help_h_gen_OBJECTS) $(help_h_gen_DEPENDENCIES)
|
|||
- @rm -f help_h_gen$(EXEEXT)
|
|||
- $(LINK) $(help_h_gen_OBJECTS) $(help_h_gen_LDADD)
|
|||
|
|||
helptext.c: help_c_gen pine.hlp |
|||
./help_c_gen < pine.hlp > $@ |
@ -0,0 +1,28 @@ |
|||
--- ../cache/alpine-2.20/pith/osdep/pw_stuff.c 2015-01-12 05:12:25.588178837 +0000
|
|||
+++ ./pith/osdep/pw_stuff.c 2016-12-11 21:24:31.283700286 +0000
|
|||
@@ -103,12 +103,6 @@
|
|||
len = strlen(fname_to_utf8(unix_pwd->pw_name)); |
|||
ui->login = (char *) malloc((len+1) * sizeof(char)); |
|||
snprintf(ui->login, len+1, "%s", fname_to_utf8(unix_pwd->pw_name)); |
|||
-
|
|||
- if((s = gcos_name(unix_pwd->pw_gecos, unix_pwd->pw_name)) != NULL){
|
|||
- len = strlen(fname_to_utf8(s));
|
|||
- ui->fullname = (char *) malloc((len+1) * sizeof(char));
|
|||
- snprintf(ui->fullname, len+1, "%s", fname_to_utf8(s));
|
|||
- }
|
|||
} |
|||
|
|||
#else /* _WINDOWS */ |
|||
@@ -190,12 +184,6 @@
|
|||
if(pw != NULL){ |
|||
char *gn, *s = NULL; |
|||
size_t l; |
|||
-
|
|||
- if((gn = gcos_name(pw->pw_gecos, name)) != NULL
|
|||
- && (s = (char *) malloc(l = ((strlen(gn) + 1) * sizeof(char)))) != NULL)
|
|||
- snprintf(s, l, "%s", gn);
|
|||
-
|
|||
- return(s);
|
|||
} |
|||
else |
|||
return((char *) NULL); |
@ -0,0 +1,191 @@ |
|||
--- ../cache/alpine-2.20/imap/src/dmail/dmail.c 2015-01-12 05:12:25.501178422 +0000
|
|||
+++ ./imap/src/dmail/dmail.c 2016-12-11 02:21:38.600238679 +0000
|
|||
@@ -27,7 +27,6 @@
|
|||
#include <stdio.h> |
|||
#include <pwd.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <sysexits.h> |
|||
#include <sys/file.h> |
|||
#include <sys/stat.h> |
|||
--- dummy.c.orig 2016-12-10 03:38:32.503722427 +0000
|
|||
+++ ./imap/src/osdep/unix/dummy.c 2016-12-10 03:38:49.147899050 +0000
|
|||
@@ -27,7 +27,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- ../fdstring.c 2016-12-10 08:02:12.555352750 +0000
|
|||
+++ ./imap/src/osdep/unix/fdstring.c 2016-12-10 08:24:29.096929788 +0000
|
|||
@@ -25,7 +25,7 @@
|
|||
* Date: 15 April 1997 |
|||
* Last Edited: 4 April 2007 |
|||
*/ |
|||
-
|
|||
+#define L_SET SEEK_SET
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include "misc.h" |
|||
--- ../cache/alpine-2.20/imap/src/imapd/imapd.c 2015-01-12 05:12:25.519178508 +0000
|
|||
+++ ./imap/src/imapd/imapd.c 2016-12-10 23:37:39.038425114 +0000
|
|||
@@ -28,7 +28,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include <setjmp.h> |
|||
#include <time.h> |
|||
--- ../cache/alpine-2.20/imap/src/ipopd/ipop2d.c 2015-01-12 05:12:25.502178427 +0000
|
|||
+++ ./imap/src/ipopd/ipop2d.c 2016-12-10 23:30:12.213739029 +0000
|
|||
@@ -30,7 +30,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include <time.h> |
|||
#include "c-client.h" |
|||
--- ../cache/alpine-2.20/imap/src/ipopd/ipop3d.c 2015-01-12 05:12:25.502178427 +0000
|
|||
+++ ./imap/src/ipopd/ipop3d.c 2016-12-10 23:31:07.350317290 +0000
|
|||
@@ -29,7 +29,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include <time.h> |
|||
#include "c-client.h" |
|||
--- ../cache/alpine-2.20/imap/src/mailutil/mailutil.c 2015-01-12 05:12:25.518178504 +0000
|
|||
+++ ./imap/src/mailutil/mailutil.c 2016-12-10 23:41:39.036944641 +0000
|
|||
@@ -26,7 +26,6 @@
|
|||
|
|||
#include <stdio.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "c-client.h" |
|||
#ifdef SYSCONFIG /* defined in env_unix.h */ |
|||
#include <pwd.h> |
|||
--- mbx.c.orig 2016-12-10 03:59:23.316906511 +0000
|
|||
+++ ./imap/src/osdep/unix/mbx.c 2016-12-10 03:59:37.913060423 +0000
|
|||
@@ -37,7 +37,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- mh.c 2016-12-10 04:12:37.861288117 +0000
|
|||
+++ ./imap/src/osdep/unix/mh.c 2016-12-10 04:12:46.749381991 +0000
|
|||
@@ -27,7 +27,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- mix.c 2016-12-10 04:15:28.235087404 +0000
|
|||
+++ ./imap/src/osdep/unix/mix.c 2016-12-10 04:15:39.583207240 +0000
|
|||
@@ -26,7 +26,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- mmdf.c.orig 2016-12-10 04:02:48.267067498 +0000
|
|||
+++ ./imap/src/osdep/unix/mmdf.c 2016-12-10 04:02:58.423174574 +0000
|
|||
@@ -28,7 +28,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
--- mtx.c 2016-12-10 04:07:22.129954642 +0000
|
|||
+++ ./imap/src/osdep/unix/mtx.c 2016-12-10 04:07:29.710034547 +0000
|
|||
@@ -37,7 +37,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- mx.c 2016-12-10 04:14:08.566246077 +0000
|
|||
+++ ./imap/src/osdep/unix/mx.c 2016-12-10 04:14:14.882312779 +0000
|
|||
@@ -30,7 +30,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <pwd.h> |
|||
--- netmsg.c.orig 2016-12-10 03:41:25.481557722 +0000
|
|||
+++ ./imap/src/c-client/netmsg.c 2016-12-10 03:41:43.933753459 +0000
|
|||
@@ -29,7 +29,6 @@
|
|||
|
|||
#include <stdio.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "c-client.h" |
|||
#include "netmsg.h" |
|||
#include "flstring.h" |
|||
--- news.c 2016-12-10 04:09:10.395096657 +0000
|
|||
+++ ./imap/src/osdep/unix/news.c 2016-12-10 04:09:20.143199638 +0000
|
|||
@@ -30,7 +30,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <sys/stat.h> |
|||
--- phile.c 2016-12-10 04:11:04.612303192 +0000
|
|||
+++ ./imap/src/osdep/unix/phile.c 2016-12-10 04:11:13.568397795 +0000
|
|||
@@ -30,7 +30,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
--- tenex.c.orig 2016-12-10 04:04:06.319890406 +0000
|
|||
+++ ./imap/src/osdep/unix/tenex.c 2016-12-10 04:04:19.476029107 +0000
|
|||
@@ -42,7 +42,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include "mail.h" |
|||
#include "osdep.h" |
|||
#include <sys/stat.h> |
|||
--- ../cache/alpine-2.20/imap/src/tmail/tmail.c 2015-01-12 05:12:25.519178508 +0000
|
|||
+++ ./imap/src/tmail/tmail.c 2016-12-11 02:27:17.811652040 +0000
|
|||
@@ -26,7 +26,6 @@
|
|||
#include <stdio.h> |
|||
#include <pwd.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <sysexits.h> |
|||
#include <sys/file.h> |
|||
#include <sys/stat.h> |
|||
--- ../unix.c 2016-12-10 08:51:46.873743032 +0000
|
|||
+++ ./imap/src/osdep/unix/unix.c 2016-12-10 08:52:08.905971091 +0000
|
|||
@@ -40,7 +40,6 @@
|
|||
#include <stdio.h> |
|||
#include <ctype.h> |
|||
#include <errno.h> |
|||
-extern int errno; /* just in case */
|
|||
#include <signal.h> |
|||
#include "mail.h" |
|||
#include "osdep.h" |
Loading…
Reference in new issue