its-pointless
7 years ago
committed by
Fredrik Fornwall
4 changed files with 43 additions and 0 deletions
@ -0,0 +1,7 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/gsasl |
|||
TERMUX_PKG_DESCRIPTION="GNU SASL library" |
|||
TERMUX_PKG_VERSION=1.8.0 |
|||
TERMUX_PKG_SRCURL=https://ftp.gnu.org/gnu/gsasl/libgsasl-${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_SHA256=3adfb49f9c92a719dea855fd1840d698cde55d4648d332a69032ba8bea207720 |
|||
TERMUX_PKG_REVISION=1 |
|||
TERMUX_PKG_DEPENDS="libidn" |
@ -0,0 +1,14 @@ |
|||
TERMUX_PKG_HOMEPAGE=http://msmtp.sourceforge.net |
|||
TERMUX_PKG_DESCRIPTION="light SMTP client" |
|||
TERMUX_PKG_VERSION=1.6.6 |
|||
TERMUX_PKG_SRCURL=https://sourceforge.net/projects/msmtp/files/msmtp/1.6.6/msmtp-1.6.6.tar.xz |
|||
TERMUX_PKG_SHA256=da15db1f62bd0201fce5310adb89c86188be91cd745b7cb3b62b81a501e7fb5e |
|||
#TERMUX_PKG_BUILD_IN_SRC=yes |
|||
#TERMUX_PKG_EXTRA_CONFIGURE_ARGS="" |
|||
#TERMUX_PKG_HOSTBUILD=true |
|||
TERMUX_PKG_DEPENDS="libgnutls, libidn" |
|||
termux_step_pre_configure () { |
|||
LDFLAGS=" -llog" |
|||
cp $TERMUX_SCRIPTDIR/packages/alpine/getpass* src/ |
|||
autoreconf -if |
|||
} |
@ -0,0 +1,12 @@ |
|||
--- ../cache/msmtp-1.6.6/src/Makefile.am 2014-11-30 22:26:00.000000000 +0000
|
|||
+++ ./src/Makefile.am 2018-01-24 00:22:11.210726100 +0000
|
|||
@@ -12,7 +12,8 @@
|
|||
tools.c tools.h \ |
|||
xalloc.c xalloc.h \ |
|||
gettext.h \ |
|||
- aliases.c aliases.h
|
|||
+ aliases.c aliases.h \
|
|||
+ getpass.c getpass.h
|
|||
|
|||
if HAVE_TLS |
|||
msmtp_SOURCES += tls.c tls.h |
@ -0,0 +1,10 @@ |
|||
--- ../cache/msmtp-1.6.6/src/msmtp.c 2016-11-14 19:44:01.000000000 +0000
|
|||
+++ ./src/msmtp.c 2018-01-24 00:14:54.940709798 +0000
|
|||
@@ -37,6 +37,7 @@
|
|||
#include <errno.h> |
|||
#include <time.h> |
|||
#include <getopt.h> |
|||
+#include <getpass.h>
|
|||
extern char *optarg; |
|||
extern int optind; |
|||
#include <unistd.h> |
Loading…
Reference in new issue