Rabby Sheikh
5 years ago
committed by
GitHub
2 changed files with 34 additions and 0 deletions
@ -0,0 +1,23 @@ |
|||
--- blackbox-1.20181219/Makefile 2018-12-20 01:20:19.000000000 +0600
|
|||
+++ blackbox-1.20181219-mod/Makefile 2020-02-29 01:04:51.748485748 +0600
|
|||
@@ -14,7 +14,7 @@
|
|||
@echo ' make usrlocal-uninstall Remove blackbox files from /usr/local/bin/' |
|||
@echo ' make test Run tests' |
|||
|
|||
-install:
|
|||
+copy-install:
|
|||
@echo 'To install, copy the files from bin to somewhere in your PATH.' |
|||
@echo 'The README.md document gives more details.' |
|||
@echo 'Or run "make" (with no options) for more info.' |
|||
@@ -66,9 +66,9 @@
|
|||
@echo '***************************************************************' |
|||
$(MAKE) symlinks-install |
|||
|
|||
-copy-install:
|
|||
+install:
|
|||
@echo 'Copying files from ./bin to /usr/local/bin' |
|||
- @cd bin && for f in `find . -type f -iname "*" ! -iname "Makefile"`; do cp `pwd`/$$f /usr/local/bin/$$f; done
|
|||
+ @cd bin && for f in `find . -type f -iname "*" ! -iname "Makefile"`; do cp `pwd`/$$f @TERMUX_PREFIX@/bin/$$f; done
|
|||
@echo 'Done.' |
|||
|
|||
usrlocal-uninstall: |
@ -0,0 +1,11 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://github.com/StackExchange/blackbox |
|||
TERMUX_PKG_DESCRIPTION="Safely store secrets in Git/Mercurial/Subversion" |
|||
TERMUX_PKG_LICENSE="MIT" |
|||
TERMUX_PKG_MAINTAINER="Rabby Sheikh @xploitednoob" |
|||
TERMUX_PKG_VERSION=1.20181219 |
|||
TERMUX_PKG_SRCURL=https://github.com/StackExchange/blackbox/archive/v${TERMUX_PKG_VERSION}.tar.gz |
|||
TERMUX_PKG_SHA256=afd40d1676645ce9aaf4cdbf71352bf1a8f6d426998436cea3ae536881ef5f81 |
|||
TERMUX_PKG_DEPENDS="gnupg" |
|||
TERMUX_PKG_SUGGESTS="git, subversion" |
|||
TERMUX_PKG_PLATFORM_INDEPENDENT=true |
|||
TERMUX_PKG_BUILD_IN_SRC=true |
Loading…
Reference in new issue