Butta
5 years ago
committed by
Leonid Plyushch
5 changed files with 6 additions and 76 deletions
@ -1,14 +0,0 @@ |
|||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||
index 0c30c55..26336a1 100644
|
|
||||
--- a/CMakeLists.txt
|
|
||||
+++ b/CMakeLists.txt
|
|
||||
@@ -202,7 +202,8 @@ if (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
|
|
||||
endif() |
|
||||
|
|
||||
# On BSD and Linux, always build with PIC. |
|
||||
-if(${CMAKE_SYSTEM_NAME} MATCHES ".*BSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
|
||||
+if(${CMAKE_SYSTEM_NAME} MATCHES ".*BSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR
|
|
||||
+ CMAKE_SYSTEM_NAME STREQUAL Android)
|
|
||||
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC") |
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC") |
|
||||
endif () |
|
@ -1,7 +1,7 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://github.com/apple/swift-llbuild |
TERMUX_PKG_HOMEPAGE=https://github.com/apple/swift-llbuild |
||||
TERMUX_PKG_DESCRIPTION="A low-level build system, used by the Swift Package Manager" |
TERMUX_PKG_DESCRIPTION="A low-level build system, used by the Swift Package Manager" |
||||
TERMUX_PKG_LICENSE="Apache-2.0, NCSA" |
TERMUX_PKG_LICENSE="Apache-2.0, NCSA" |
||||
TERMUX_PKG_VERSION=5.1 |
TERMUX_PKG_VERSION=5.2 |
||||
TERMUX_PKG_SRCURL=https://github.com/apple/swift-llbuild/archive/swift-${TERMUX_PKG_VERSION}-RELEASE.tar.gz |
TERMUX_PKG_SRCURL=https://github.com/apple/swift-llbuild/archive/swift-${TERMUX_PKG_VERSION}-RELEASE.tar.gz |
||||
TERMUX_PKG_SHA256=cbd228619d1172f7f6d38983f0419226baa1cfbecc6afac891856fcb46ba4920 |
TERMUX_PKG_SHA256=6c781a4f7887a10e0443eaebde4d5f52333417392ed2422f012917c879014224 |
||||
TERMUX_PKG_DEPENDS="libc++, libandroid-spawn, libsqlite" |
TERMUX_PKG_DEPENDS="libc++, libandroid-spawn, libsqlite" |
||||
|
@ -1,19 +0,0 @@ |
|||||
commit 111d9828e6422447321196b1826c0a666a0632d2 |
|
||||
Author: Igor Makarov <igormaka@gmail.com> |
|
||||
Date: Wed Aug 21 15:06:30 2019 +0300 |
|
||||
|
|
||||
change ProcessHandle int width so it complies with platform int width |
|
||||
|
|
||||
diff --git a/include/llbuild/BuildSystem/BuildSystemFrontend.h b/include/llbuild/BuildSystem/BuildSystemFrontend.h
|
|
||||
index b14e9c8..53bf570 100644
|
|
||||
--- a/include/llbuild/BuildSystem/BuildSystemFrontend.h
|
|
||||
+++ b/include/llbuild/BuildSystem/BuildSystemFrontend.h
|
|
||||
@@ -116,7 +116,7 @@ public:
|
|
||||
/// Handle used to communicate information about a launched process. |
|
||||
struct ProcessHandle { |
|
||||
/// Opaque ID. |
|
||||
- uintptr_t id;
|
|
||||
+ uint64_t id;
|
|
||||
}; |
|
||||
|
|
||||
private: |
|
@ -1,36 +0,0 @@ |
|||||
diff --git a/include/llvm/Config/config.h b/include/llvm/Config/config.h
|
|
||||
index 9cf1c89..9af2945 100644
|
|
||||
--- a/include/llvm/Config/config.h
|
|
||||
+++ b/include/llvm/Config/config.h
|
|
||||
@@ -14,7 +14,9 @@
|
|
||||
#define ENABLE_CRASH_OVERRIDES 1 |
|
||||
|
|
||||
/* Define to 1 if you have the `backtrace' function. */ |
|
||||
+#if !defined(__ANDROID__)
|
|
||||
#define HAVE_BACKTRACE TRUE |
|
||||
+#endif
|
|
||||
|
|
||||
#define BACKTRACE_HEADER <execinfo.h> |
|
||||
|
|
||||
@@ -74,7 +76,11 @@
|
|
||||
/* #undef HAVE_FFI_H */ |
|
||||
|
|
||||
/* Define to 1 if you have the `futimens' function. */ |
|
||||
+#if defined(__ANDROID__)
|
|
||||
+#define HAVE_FUTIMENS 1
|
|
||||
+#else
|
|
||||
/* #undef HAVE_FUTIMENS */ |
|
||||
+#endif
|
|
||||
|
|
||||
/* Define to 1 if you have the `futimes' function. */ |
|
||||
#define HAVE_FUTIMES 1 |
|
||||
@@ -104,7 +110,9 @@
|
|
||||
#define HAVE_LIBPTHREAD 1 |
|
||||
|
|
||||
/* Define to 1 if you have the `pthread_getname_np' function. */ |
|
||||
+#if !defined(__ANDROID__)
|
|
||||
#define HAVE_PTHREAD_GETNAME_NP 1 |
|
||||
+#endif
|
|
||||
|
|
||||
/* Define to 1 if you have the `pthread_setname_np' function. */ |
|
||||
#define HAVE_PTHREAD_SETNAME_NP 1 |
|
Loading…
Reference in new issue