Browse Source

graphviz: update to 2.44.0

master
Henrik Grimler 5 years ago
parent
commit
f571d35d8a
  1. 4
      packages/graphviz/build.sh
  2. 35
      packages/graphviz/lib-cgraph.patch
  3. 28
      packages/graphviz/lib-gvpr-Makefile.am.patch
  4. 44
      packages/graphviz/lib-sfdpgen-PriorityQueue.c.patch
  5. 13
      packages/graphviz/lib-vpsc-blocks.cpp.patch

4
packages/graphviz/build.sh

@ -1,9 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://www.graphviz.org/ TERMUX_PKG_HOMEPAGE=https://www.graphviz.org/
TERMUX_PKG_DESCRIPTION="Rich set of graph drawing tools" TERMUX_PKG_DESCRIPTION="Rich set of graph drawing tools"
TERMUX_PKG_LICENSE="EPL-2.0" TERMUX_PKG_LICENSE="EPL-2.0"
TERMUX_PKG_VERSION=2.42.3 TERMUX_PKG_VERSION=2.44.0
TERMUX_PKG_SRCURL=https://www2.graphviz.org/Packages/stable/portable_source/graphviz-$TERMUX_PKG_VERSION.tar.gz TERMUX_PKG_SRCURL=https://www2.graphviz.org/Packages/stable/portable_source/graphviz-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=8faf3fc25317b1d15166205bf64c1b4aed55a8a6959dcabaa64dbad197e47add TERMUX_PKG_SHA256=9aabd13a8018b708ab3c822de2326c19d0a52ed59f50a6b0f9318c07e2a6d93b
TERMUX_PKG_DEPENDS="libandroid-glob, libc++, libcairo, pango, libexpat, libltdl, librsvg, libgd, zlib" TERMUX_PKG_DEPENDS="libandroid-glob, libc++, libcairo, pango, libexpat, libltdl, librsvg, libgd, zlib"
TERMUX_PKG_BREAKS="graphviz-dev" TERMUX_PKG_BREAKS="graphviz-dev"
TERMUX_PKG_REPLACES="graphviz-dev" TERMUX_PKG_REPLACES="graphviz-dev"

35
packages/graphviz/lib-cgraph.patch

@ -1,35 +0,0 @@
cgraph contains an empty malloc.h, that seems to be needed by files
that are generated by yacc. This empty malloc.h is however also picked
in other places (first error is from
plugin/visio/VisioGraphic.cpp). By moving the empty malloc.h to
include/ and only letting cgraph having `-Iinclude` we can make sure
it is only picked up where it should be picked up.
Compiling on device works without this patch, but it gives warnings
like
```
../../../lib/common/memory.c:47:10: warning: implicitly declaring library function 'malloc' with type 'void *(unsigned long)' [-Wimplicit-function-declaration]
```
diff --git a/lib/cgraph/Makefile.am b/lib/cgraph/Makefile.am
index bb6147b91..419940a7c 100644
--- a/lib/cgraph/Makefile.am
+++ b/lib/cgraph/Makefile.am
@@ -8,10 +8,11 @@ pkgconfigdir = $(libdir)/pkgconfig
AM_CPPFLAGS = \
-I$(top_srcdir) \
- -I$(top_srcdir)/lib/cdt
+ -I$(top_srcdir)/lib/cdt \
+ -Iinclude
pkginclude_HEADERS = cgraph.h
-noinst_HEADERS = agxbuf.h cghdr.h malloc.h
+noinst_HEADERS = agxbuf.h cghdr.h include/malloc.h
noinst_LTLIBRARIES = libcgraph_C.la
lib_LTLIBRARIES = libcgraph.la
pkgconfig_DATA = libcgraph.pc
diff --git a/lib/cgraph/malloc.h b/lib/cgraph/include/malloc.h
similarity index 100%
rename from lib/cgraph/malloc.h
rename to lib/cgraph/include/malloc.h

28
packages/graphviz/lib-gvpr-Makefile.am.patch

@ -1,28 +0,0 @@
--- ../lib-gvpr-Makefile.am.orig 2020-03-28 14:56:03.035919302 +0100
+++ ./lib/gvpr/Makefile.am 2020-03-28 15:32:59.954957670 +0100
@@ -3,6 +3,7 @@
pdfdir = $(pkgdatadir)/doc/pdf
pkgconfigdir = $(libdir)/pkgconfig
+HOSTCC ?= $(CC)
GVPR_VERSION="2:0:0"
@@ -21,7 +22,6 @@
-DDFLT_GVPRPATH="\".$(PATH_SEPARATOR)$(pkgdatadir)/gvpr\""
pkginclude_HEADERS = gvpr.h
-noinst_PROGRAMS = mkdefs
noinst_HEADERS = actions.h compile.h gprstate.h parse.h queue.h trieFA.h trie.c
noinst_LTLIBRARIES = libgvpr_C.la
lib_LTLIBRARIES = libgvpr.la
@@ -54,7 +54,8 @@
libgvpr_la_LDFLAGS += -export-symbols-regex gvpr
endif
-mkdefs_SOURCES = mkdefs.c
+mkdefs$(EXEEXT):
+ $(HOSTCC) $(srcdir)/mkdefs.c -o mkdefs$(EXEEXT)
gdefs.h: $(top_srcdir)/lib/gvpr/gprdata mkdefs$(EXEEXT)
./mkdefs$(EXEEXT) gdefs.h < $(top_srcdir)/lib/gvpr/gprdata

44
packages/graphviz/lib-sfdpgen-PriorityQueue.c.patch

@ -1,44 +0,0 @@
--- ../PriorityQueue.c.orig 2020-03-28 14:42:15.234189565 +0100
+++ ./lib/sfdpgen/PriorityQueue.c 2020-03-28 16:16:07.186610646 +0100
@@ -11,6 +11,8 @@
* Contributors: See CVS logs. Details at http://www.graphviz.org/
*************************************************************************/
+#include <malloc.h>
+
#include "LinkedList.h"
#include "PriorityQueue.h"
#include "memory.h"
@@ -18,12 +20,6 @@
#include "assert.h"
#include "arith.h"
-#define MALLOC gmalloc
-#define REALLOC grealloc
-#define FREE free
-#define MEMCPY memcpy
-
-
PriorityQueue PriorityQueue_new(int n, int ngain){
PriorityQueue q;
int i;
@@ -50,15 +46,15 @@
if (q){
if (q->buckets){
for (i = 0; i < q->ngain+1; i++) DoubleLinkedList_delete((q->buckets)[i], free);
- FREE(q->buckets);
+ free(q->buckets);
}
if (q->where){
- FREE(q->where);
+ free(q->where);
}
- FREE(q->gain);
- FREE(q);
+ free(q->gain);
+ free(q);
}
}

13
packages/graphviz/lib-vpsc-blocks.cpp.patch

@ -1,13 +0,0 @@
--- ../blocks.cpp.orig 2020-03-24 12:30:32.334785560 +0100
+++ ./lib/vpsc/blocks.cpp 2020-03-24 12:34:15.597529253 +0100
@@ -155,8 +155,8 @@
//erase(doomed);
}
void Blocks::cleanup() {
- vector<Block*> bcopy(begin(),end());
- for(vector<Block*>::iterator i=bcopy.begin();i!=bcopy.end();i++) {
+ vector<Block*> b_copy(begin(),end());
+ for(vector<Block*>::iterator i=b_copy.begin();i!=b_copy.end();i++) {
Block *b=*i;
if(b->deleted) {
erase(b);
Loading…
Cancel
Save