diff -u -r ../imgflo-0.4.2/Makefile ./Makefile
--- ../imgflo-0.4.2/Makefile	2016-08-21 08:46:27.000000000 +0000
+++ ./Makefile	2018-05-17 17:48:06.151296541 +0000
@@ -1,7 +1,5 @@
 
 VERSION=$(shell echo `git describe --tags`)
-#PREFIX=/opt/imgflo
-PREFIX=$(shell echo `pwd`/install)
 FLAGS=-Wall -Werror -std=c99 -g
 DEBUGPROG=
 PORT=3569
@@ -21,10 +19,10 @@
 PKGCONFIG_ARGS:=
 endif
 
-LIBS=gegl-0.3 libsoup-2.4
+LIBS=gegl-0.4 libsoup-2.4
 SYSTEM_LIBS=gio-unix-2.0 json-glib-1.0 libpng
-DEPS=$(shell $(PREFIX)/env.sh pkg-config $(PKGCONFIG_ARGS) --libs --cflags $(LIBS))
-DEPS+=$(shell $(PREFIX)/env.sh pkg-config --libs --cflags $(SYSTEM_LIBS))
+DEPS=$(shell  pkg-config $(PKGCONFIG_ARGS) --libs --cflags $(LIBS))
+DEPS+=$(shell  pkg-config --libs --cflags $(SYSTEM_LIBS))
 TRAVIS_DEPENDENCIES=$(shell echo `cat .vendor_urls | sed -e "s/heroku/travis-${TRAVIS_OS_NAME}/" | tr -d '\n'`)
 
 RUN_ARGUMENTS:=--port $(PORT) --external-port=$(EXTPORT)
@@ -53,31 +51,31 @@
 all: install
 
 run-noinstall:
-	$(PREFIX)/env.sh $(DEBUGPROG) ./bin/imgflo-runtime $(RUN_ARGUMENTS)
+	 $(DEBUGPROG) ./bin/imgflo-runtime $(RUN_ARGUMENTS)
 
 run: install run-noinstall
 
 process: install
-	$(PREFIX)/env.sh $(DEBUGPROG) ./bin/imgflo $(PROCESS_ARGUMENTS)
+	 $(DEBUGPROG) ./bin/imgflo $(PROCESS_ARGUMENTS)
 
-install: env imgflo imgflo-runtime imgflo-graphinfo
+install:  imgflo imgflo-runtime imgflo-graphinfo
 	cp ./bin/imgflo $(PREFIX)/bin/
 	cp ./bin/imgflo-runtime $(PREFIX)/bin/
 	cp ./bin/imgflo-graphinfo $(PREFIX)/bin/
 
 imgflo:
-	$(PREFIX)/env.sh $(CC) -o ./bin/imgflo bin/imgflo.c -I. $(FLAGS) $(DEPS)
+	 $(CC) -o ./bin/imgflo bin/imgflo.c -I. $(FLAGS) $(DEPS)
 
 imgflo-graphinfo:
-	$(PREFIX)/env.sh $(CC) -o ./bin/imgflo-graphinfo bin/imgflo-graphinfo.c -I. $(FLAGS) $(DEPS)
+	 $(CC) -o ./bin/imgflo-graphinfo bin/imgflo-graphinfo.c -I. $(FLAGS) $(DEPS)
 
 imgflo-runtime:
-	$(PREFIX)/env.sh $(CC) -o ./bin/imgflo-runtime bin/imgflo-runtime.c -I. $(FLAGS) $(DEPS)
+	 $(CC) -o ./bin/imgflo-runtime bin/imgflo-runtime.c -I. $(FLAGS) $(DEPS)
 
 env:
-	mkdir -p $(PREFIX) || true
-	sed -e 's|@PREFIX@|$(PREFIX)|' env.sh.in > $(PREFIX)/env.sh
-	chmod +x $(PREFIX)/env.sh
+#	mkdir -p $(PREFIX) || true
+#	sed -e 's|@PREFIX@|$(PREFIX)|' env.sh.in > $(PREFIX)/env.sh
+#	chmod +x $(PREFIX)/env.sh
 
 travis-deps:
 	wget -O imgflo-dependencies.tgz $(TRAVIS_DEPENDENCIES)
@@ -93,14 +91,14 @@
 COMPONENT_FLAGS += -DIMGFLO_OP_NAME\(orig\)=\"$(COMPONENT_NAME_PREFIX)\"orig\"$(COMPONENT_NAME_SUFFIX)\"
 endif
 
-component-install-dir: env
+component-install-dir: 
 	rm -rf $(COMPONENTINSTALLDIR)
 	mkdir -p $(COMPONENTINSTALLDIR) || true
 components: component-install-dir $(COMPONENT_PLUGINS)
 component: component-install-dir $(COMPONENT_OUT)
 
 $(COMPONENTINSTALLDIR)/%.$(SHAREDLIB_SUFFIX): $(COMPONENTDIR)/%.c
-	$(PREFIX)/env.sh $(CC) -o $@ $< -DGEGL_OP_C_FILE=\"`basename $<`\" $(COMPONENT_FLAGS) $(DEPS)
+	 $(CC) -o $@ $< -DGEGL_OP_C_FILE=\"`basename $<`\" $(COMPONENT_FLAGS) $(DEPS)
 
 dependencies:
 	cd dependencies && make PREFIX=$(PREFIX) dependencies
@@ -115,7 +113,7 @@
 	cd dependencies && make PREFIX=$(PREFIX) glib
 
 check: install
-	$(PREFIX)/env.sh ./node_modules/.bin/mocha --reporter spec --compilers .coffee:coffee-script/register ./spec/*.coffee $(TEST_ARGUMENTS)
+	 ./node_modules/.bin/mocha --reporter spec --compilers .coffee:coffee-script/register ./spec/*.coffee $(TEST_ARGUMENTS)
 
 clean:
 	git clean -dfx --exclude node_modules --exclude install