--- ../cache/gettext-0.19.8/gettext-tools/gnulib-lib/Makefile.am	2016-01-20 02:38:26.000000000 +0000
+++ ./gettext-tools/gnulib-lib/Makefile.am	2017-02-24 21:24:59.916938343 +0000
@@ -58,7 +58,6 @@
 # Rules generated and collected by gnulib-tool.
 include Makefile.gnulib
 
-# Which classes to export from the shared library.
 MOOPPFLAGS += --dllexport=styled_ostream
 
 # OS/2 does not support a DLL name longer than 8 characters.
@@ -67,10 +66,11 @@
 endif
 
 # Linking with C++ libraries is needed _only_ on mingw and Cygwin.
+# .. termux edit because i can't be bothered fixing it properly.
 if !WOE32DLL
 libgettextlib_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
 	$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link \
-	$(CCLD) $(AM_CFLAGS) $(CFLAGS) $(libgettextlib_la_LDFLAGS) $(LDFLAGS) \
+	$(CCLD) $(AM_CFLAGS) $(CFLAGS) -lcroco-0.6 -lglib-2.0 -landroid-support -lpcre -lxml2 -lz -llzma -lm -lncurses -lunistring -liconv $(LDFLAGS) \
 	-o $@
 else
 libgettextlib_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CXX \