You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

20 lines
439 B

diff --git a/samples/Makefile b/samples/Makefile
index 4724f17..8303ba5 100644
--- a/samples/Makefile
+++ b/samples/Makefile
@@ -14,12 +14,12 @@ V ?= 0
CFLAGS += -Wall -Werror -I../include
-LDFLAGS += -L$(LIBDIR) -lunicorn -lpthread -lm
+LDFLAGS += -L$(LIBDIR) -lunicorn -lm
ifeq ($(UNAME_S), Linux)
-LDFLAGS += -lrt
+LDFLAGS +=
endif
-LDLIBS += -lpthread -lunicorn -lm
+LDLIBS += -lunicorn -lm
ifneq ($(CROSS),)
CC = $(CROSS)gcc