You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

13 lines
491 B

diff --git a/shlr/Makefile b/shlr/Makefile
index 384ed78..d3bdab1 100644
--- a/shlr/Makefile
+++ b/shlr/Makefile
@@ -103,7 +103,7 @@ ${SDB_TARGETS}:
@echo
$(MAKE) -C sdb clean
$(MAKE) -C sdb src/sdb_version.h
- $(MAKE) -C sdb/src CC=${HOST_CC} CFLAGS='${HOST_CFLAGS} -fPIC' bin
+ $(MAKE) -C sdb/src CC=${HOST_CC} LDFLAGS='${HOST_LDFLAGS}' CPPFLAGS='' CFLAGS='${HOST_CFLAGS} -fPIC' bin
cp -f sdb/src/sdb${BUILD_EXT_EXE} sdb/src/.sdb${BUILD_EXT_EXE}
@echo
@echo ">>>>>>>>>>>>>>>>"