You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

23 lines
723 B

diff -uNr lmdb-LMDB_0.9.24/libraries/liblmdb/Makefile lmdb-LMDB_0.9.24.mod/libraries/liblmdb/Makefile
--- lmdb-LMDB_0.9.24/libraries/liblmdb/Makefile 2019-07-19 19:41:12.000000000 +0300
+++ lmdb-LMDB_0.9.24.mod/libraries/liblmdb/Makefile 2020-01-24 20:00:21.378688952 +0200
@@ -18,8 +18,8 @@
# There may be other macros in mdb.c of interest. You should
# read mdb.c before changing any of them.
#
-CC = gcc
-AR = ar
+CC ?= gcc
+AR ?= ar
W = -W -Wall -Wno-unused-parameter -Wbad-function-cast -Wuninitialized
THREADS = -pthread
OPT = -O2 -g
@@ -27,7 +27,7 @@
LDLIBS =
SOLIBS =
SOEXT = .so
-prefix = /usr/local
+prefix ?= /usr/local
exec_prefix = $(prefix)
bindir = $(exec_prefix)/bin
libdir = $(exec_prefix)/lib