You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

28 lines
1.0 KiB

diff -u -r ../neofetch-3.0/Makefile ./Makefile
--- ../neofetch-3.0/Makefile 2017-01-23 04:40:31.000000000 +0100
+++ ./Makefile 2017-01-23 13:04:18.588389799 +0100
@@ -1,4 +1,4 @@
-PREFIX = /usr
+PREFIX ?= /usr
all:
@echo Run \'make install\' to install Neofetch
@@ -6,15 +6,15 @@
install:
mkdir -p $(DESTDIR)$(PREFIX)/bin
mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
- mkdir -p $(DESTDIR)/etc/neofetch
+ mkdir -p $(DESTDIR)$(PREFIX)/etc/neofetch
mkdir -p $(DESTDIR)$(PREFIX)/share/neofetch/ascii/distro
cp -p neofetch $(DESTDIR)$(PREFIX)/bin/neofetch
cp -p neofetch.1 $(DESTDIR)$(PREFIX)/share/man/man1/neofetch.1
- cp -p config/config $(DESTDIR)/etc/neofetch/config
+ cp -p config/config $(DESTDIR)$(PREFIX)/etc/neofetch/config
cp -p ascii/distro/* $(DESTDIR)$(PREFIX)/share/neofetch/ascii/distro
uninstall:
rm -f $(DESTDIR)$(PREFIX)/bin/neofetch
rm -f $(DESTDIR)$(PREFIX)/share/man/man1/neofetch.1
rm -f -r $(DESTDIR)$(PREFIX)/share/neofetch
- rm -f -r $(DESTDIR)/etc/neofetch
+ rm -f -r $(DESTDIR)$(PREFIX)/etc/neofetch