its-pointless
5 years ago
committed by
Leonid Plyushch
4 changed files with 55 additions and 8 deletions
@ -0,0 +1,16 @@ |
|||
--- cmake/modules/LLDBStandalone.cmake.orig 2019-10-28 03:16:27.880770642 +0000
|
|||
+++ ./cmake/modules/LLDBStandalone.cmake 2019-10-28 03:16:53.936718250 +0000
|
|||
@@ -32,12 +32,7 @@
|
|||
set(LLVM_DEFAULT_EXTERNAL_LIT ${lit_full_path} CACHE PATH "Path to llvm-lit") |
|||
|
|||
if(CMAKE_CROSSCOMPILING) |
|||
- set(LLVM_NATIVE_BUILD "${LLVM_BINARY_DIR}/NATIVE")
|
|||
- if (NOT EXISTS "${LLVM_NATIVE_BUILD}")
|
|||
- message(FATAL_ERROR
|
|||
- "Attempting to cross-compile LLDB standalone but no native LLVM build
|
|||
- found. Please cross-compile LLVM as well.")
|
|||
- endif()
|
|||
+ set(LLVM_NATIVE_BUILD "${LLVM_BINARY_DIR}/")
|
|||
|
|||
if (CMAKE_HOST_SYSTEM_NAME MATCHES "Windows") |
|||
set(HOST_EXECUTABLE_SUFFIX ".exe") |
@ -0,0 +1,21 @@ |
|||
--- ./CMakeLists.txt.orig 2019-10-28 02:55:47.051030643 +0000
|
|||
+++ ./CMakeLists.txt 2019-10-28 02:55:59.659010243 +0000
|
|||
@@ -39,18 +39,6 @@
|
|||
add_subdirectory(scripts) |
|||
endif () |
|||
|
|||
-if(CMAKE_CROSSCOMPILING AND LLDB_BUILT_STANDALONE)
|
|||
- set(LLVM_USE_HOST_TOOLS ON)
|
|||
- include(CrossCompile)
|
|||
- if (NOT NATIVE_LLVM_DIR OR NOT NATIVE_Clang_DIR)
|
|||
- message(FATAL_ERROR
|
|||
- "Crosscompiling standalone requires the variables NATIVE_{CLANG,LLVM}_DIR
|
|||
- for building the native lldb-tblgen used during the build process.")
|
|||
- endif()
|
|||
- llvm_create_cross_target(lldb NATIVE "" Release
|
|||
- -DLLVM_DIR=${NATIVE_LLVM_DIR}
|
|||
- -DClang_DIR=${NATIVE_Clang_DIR})
|
|||
-endif()
|
|||
|
|||
add_subdirectory(utils/TableGen) |
|||
add_subdirectory(source) |
Loading…
Reference in new issue