Browse Source
This is an ISO creation and burning tool. Burning most likely won't work on Android without root even if device is connected to a burner but it's useful to be able to create ISOs.android-5
Vladimir Serbinenko
8 years ago
committed by
Fredrik Fornwall
2 changed files with 35 additions and 0 deletions
@ -0,0 +1,12 @@ |
|||||
|
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/xorriso |
||||
|
TERMUX_PKG_DESCRIPTION="Tool for creating ISO files." |
||||
|
TERMUX_PKG_VERSION=1.4.7 |
||||
|
TERMUX_PKG_SRCURL=https://www.gnu.org/software/xorriso/xorriso-${TERMUX_PKG_VERSION}.tar.gz |
||||
|
TERMUX_PKG_SHA256=b54997b71b979768b19ddc38ff15d773ce44cf449e63fb453e20be9d687d396a |
||||
|
TERMUX_PKG_DEPENDS="iconv, libandroid-support" |
||||
|
TERMUX_PKG_BUILD_IN_SRC=yes |
||||
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-jtethreads" |
||||
|
|
||||
|
termux_step_pre_configure() { |
||||
|
LDFLAGS+=" -landroid-support" |
||||
|
} |
@ -0,0 +1,23 @@ |
|||||
|
diff -ur src-o/configure src/configure
|
||||
|
--- src-o/configure 2017-07-31 04:44:24.215397674 +0200
|
||||
|
+++ src/configure 2017-07-31 04:45:19.667222873 +0200
|
||||
|
@@ -12719,7 +12719,7 @@
|
||||
|
fi |
||||
|
|
||||
|
|
||||
|
-THREAD_LIBS=-lpthread
|
||||
|
+THREAD_LIBS=
|
||||
|
|
||||
|
|
||||
|
|
||||
|
diff -ur src-o/configure.ac src/configure.ac
|
||||
|
--- src-o/configure.ac 2017-07-31 04:44:24.215397674 +0200
|
||||
|
+++ src/configure.ac 2017-07-31 04:44:40.903346135 +0200
|
||||
|
@@ -113,7 +113,7 @@
|
||||
|
, |
||||
|
[#include <unistd.h>]) |
||||
|
|
||||
|
-THREAD_LIBS=-lpthread
|
||||
|
+THREAD_LIBS=
|
||||
|
AC_SUBST(THREAD_LIBS) |
||||
|
|
Loading…
Reference in new issue