Fredrik Fornwall
6 years ago
2 changed files with 31 additions and 0 deletions
@ -0,0 +1,20 @@ |
|||
diff -u -r ../bat-0.7.1/Cargo.toml ./Cargo.toml
|
|||
--- ../bat-0.7.1/Cargo.toml 2018-09-23 08:30:19.000000000 +0000
|
|||
+++ ./Cargo.toml 2018-10-08 01:23:55.289414819 +0000
|
|||
@@ -20,6 +20,7 @@
|
|||
console = "0.6" |
|||
directories = "1.0" |
|||
lazy_static = "1.0" |
|||
+termios = "0.3"
|
|||
|
|||
[dependencies.git2] |
|||
version = "0.7" |
|||
@@ -41,5 +42,8 @@
|
|||
default-features = false |
|||
features = [] |
|||
|
|||
+[patch.crates-io]
|
|||
+termios = { git = "https://github.com/fornwall/termios-rs", branch = "support-android" }
|
|||
+
|
|||
[dev-dependencies] |
|||
tempdir = "0.3" |
@ -0,0 +1,11 @@ |
|||
TERMUX_PKG_HOMEPAGE=https://github.com/sharkdp/bat |
|||
TERMUX_PKG_DESCRIPTION="A cat(1) clone with wings" |
|||
TERMUX_PKG_VERSION=0.7.1 |
|||
TERMUX_PKG_SHA256=5863895e6ac95f5349da95ff74e196c4b365af3fc3f4a1376cab797df493b7a4 |
|||
TERMUX_PKG_SRCURL=https://github.com/sharkdp/bat/archive/v$TERMUX_PKG_VERSION.tar.gz |
|||
TERMUX_PKG_BUILD_IN_SRC=yes |
|||
|
|||
termux_step_post_make_install() { |
|||
mkdir -p $TERMUX_PREFIX/share/man/man1 |
|||
cp $TERMUX_PKG_SRCDIR/doc/bat.1 $TERMUX_PREFIX/share/man/man1/ |
|||
} |
Loading…
Reference in new issue