Fredrik Fornwall
8 years ago
2 changed files with 17 additions and 6 deletions
@ -1,17 +1,16 @@ |
|||||
TERMUX_PKG_HOMEPAGE=https://www.postgresql.org |
TERMUX_PKG_HOMEPAGE=https://www.postgresql.org |
||||
TERMUX_PKG_DESCRIPTION="Object-relational SQL database" |
TERMUX_PKG_DESCRIPTION="Object-relational SQL database" |
||||
TERMUX_PKG_MAINTAINER='Vishal Biswas @vishalbiswas' |
TERMUX_PKG_MAINTAINER='Vishal Biswas @vishalbiswas' |
||||
TERMUX_PKG_VERSION=9.6.1 |
TERMUX_PKG_VERSION=9.6.2 |
||||
TERMUX_PKG_SRCURL=https://ftp.postgresql.org/pub/source/v$TERMUX_PKG_VERSION/postgresql-$TERMUX_PKG_VERSION.tar.bz2 |
TERMUX_PKG_SRCURL=https://ftp.postgresql.org/pub/source/v$TERMUX_PKG_VERSION/postgresql-$TERMUX_PKG_VERSION.tar.bz2 |
||||
TERMUX_PKG_SHA256=e5101e0a49141fc12a7018c6dad594694d3a3325f5ab71e93e0e51bd94e51fcd |
TERMUX_PKG_SHA256=0187b5184be1c09034e74e44761505e52357248451b0c854dddec6c231fe50c9 |
||||
TERMUX_PKG_DEPENDS="openssl, libcrypt, readline" |
TERMUX_PKG_DEPENDS="openssl, libcrypt, readline, libandroid-shmem" |
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" --without-gssapi --with-readline --with-openssl --with-system-tzdata=/system/usr/share/zoneinfo" |
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" --without-gssapi --with-readline --with-openssl --with-system-tzdata=/system/usr/share/zoneinfo" |
||||
TERMUX_PKG_EXTRA_MAKE_ARGS=" -s" |
TERMUX_PKG_EXTRA_MAKE_ARGS=" -s" |
||||
|
|
||||
termux_step_pre_configure () { |
termux_step_pre_configure () { |
||||
# to use shmem and sem stubs |
# to use shmem and sem stubs |
||||
#CPPFLAGS="$CPPFLAGS -DTERMUX_SHMEM_STUBS -DTERMUX_SEMOPS_STUBS -DEXEC_BACKEND" |
CFLAGS+=" -DTERMUX_SEMOPS_STUBS=1" |
||||
CFLAGS="$CFLAGS -DTERMUX_SHMEM_STUBS=1 -DTERMUX_SEMOPS_STUBS=1" |
LDFLAGS+=" -llog" |
||||
LDFLAGS="$LDFLAGS -llog" |
|
||||
} |
} |
||||
|
|
||||
|
@ -0,0 +1,12 @@ |
|||||
|
diff -u -r ../postgresql-9.6.1/src/backend/Makefile ./src/backend/Makefile
|
||||
|
--- ../postgresql-9.6.1/src/backend/Makefile 2016-10-24 20:08:51.000000000 +0000
|
||||
|
+++ ./src/backend/Makefile 2017-03-04 23:18:25.301563453 +0000
|
||||
|
@@ -49,6 +49,8 @@
|
||||
|
LIBS += -lsystemd |
||||
|
endif |
||||
|
|
||||
|
+LIBS += -landroid-shmem
|
||||
|
+
|
||||
|
########################################################################## |
||||
|
|
||||
|
all: submake-libpgport submake-schemapg postgres $(POSTGRES_IMP) |
Loading…
Reference in new issue