Browse Source
* add bvi package * add new package: cgdb * add gdb in cgdb's TERMUX_PKG_DEPENDS * add new package: redir * bvi package revision 1: fix column number issue with clang (gcc does not seem to have this issue) bvi (compiled with clang) incorrectly displayed only 12 bytes for each line on a 80-column terminal (instead of 16 bytes normally). command :set cm=## also had similar problems. I found the issue was caused by the following statements: sprintf(addr_form, "%%0%dllX ", AnzAdd); AnzAdd = sprintf(tmp, addr_form, block_begin); ('block_begin''s data type is off_t) gcc automatically typecasts 'block_begin' from off_t to loff_t, on the otherhand, clang takes address of 'block_begin' and uses it as loff_t thus writes some garbage value in 'tmp' string.android-5
ElTopo
8 years ago
committed by
Fredrik Fornwall
6 changed files with 76 additions and 17 deletions
@ -0,0 +1,30 @@ |
|||||
|
--- bvi-1.4.0/bvi.c 2014-10-07 13:09:45.000000000 -0700
|
||||
|
+++ src/bvi.c 2017-02-19 00:35:24.587363303 -0800
|
||||
|
@@ -276,7 +276,7 @@
|
||||
|
if (AnzAdd > sizeof(block_begin) * 2) |
||||
|
AnzAdd = sizeof(block_begin) * 2; |
||||
|
sprintf(addr_form, "%%0%dllX ", AnzAdd); |
||||
|
- AnzAdd = sprintf(tmp, addr_form, block_begin);
|
||||
|
+ AnzAdd = sprintf(tmp, addr_form, (long long unsigned)block_begin);
|
||||
|
} |
||||
|
|
||||
|
Anzahl = ((COLS - AnzAdd - 1) / 16) * 4; |
||||
|
@@ -729,7 +729,6 @@
|
||||
|
char *arg; |
||||
|
{ |
||||
|
off_t val; |
||||
|
- extern int errno;
|
||||
|
char *poi; |
||||
|
|
||||
|
errno = 0; |
||||
|
--- bvi-1.4.0/set.c 2014-09-30 05:00:53.000000000 -0700
|
||||
|
+++ src/set.c 2017-02-19 00:36:08.927600541 -0800
|
||||
|
@@ -135,7 +135,7 @@
|
||||
|
if (((COLS - AnzAdd - 1) / 4) >= P(P_CM)) { |
||||
|
Anzahl = P(P_CM); |
||||
|
} else { |
||||
|
- Anzahl = P(P_CM) = ((COLS - AnzAdd - 1) / 4);
|
||||
|
+ Anzahl = P(P_CM) = ((COLS - AnzAdd - 1) / 16) * 4;
|
||||
|
} |
||||
|
maxx = Anzahl * 4 + AnzAdd + 1; |
||||
|
Anzahl3 = Anzahl * 3; |
@ -0,0 +1,31 @@ |
|||||
|
--- redir-2.2.1/Makefile 1999-12-26 12:51:55.000000000 -0800
|
||||
|
+++ src/Makefile 2017-02-15 13:07:10.577481896 -0800
|
||||
|
@@ -15,7 +15,8 @@
|
||||
|
# if your system needs any additional libraries (solaris, for example, |
||||
|
# needs the ones commented out below), edit this line. |
||||
|
|
||||
|
-EXTRA_LIBS = #-lnsl -lsocket
|
||||
|
+#EXTRA_LIBS = #-lnsl -lsocket
|
||||
|
+EXTRA_LIBS = -llog
|
||||
|
|
||||
|
# add additional compiler flags here. Some useful ones are: |
||||
|
# |
||||
|
@@ -27,7 +28,7 @@
|
||||
|
### end of user configuration section |
||||
|
|
||||
|
# redir requires gcc. if you're lucky, another compiler might work. |
||||
|
-CC = gcc
|
||||
|
+#CC = gcc
|
||||
|
|
||||
|
# if your system lacks getopt_long, remove the comment from this line |
||||
|
OBJS = redir.o $(GETOPT_OBJS) |
||||
|
@@ -51,6 +52,9 @@
|
||||
|
redir: ${OBJS} |
||||
|
${CC} ${LDFLAGS} -o redir ${OBJS} ${LIBS} |
||||
|
|
||||
|
+install: all
|
||||
|
+ install redir $(PREFIX)/bin
|
||||
|
+ install redir.man $(PREFIX)/share/man/man1/redir.1
|
||||
|
|
||||
|
|
||||
|
|
@ -0,0 +1,8 @@ |
|||||
|
TERMUX_PKG_HOMEPAGE=http://sammy.net/~sammy/hacks/ |
||||
|
TERMUX_PKG_DESCRIPTION="Redirect TCP connections" |
||||
|
TERMUX_PKG_VERSION=2.2.1 |
||||
|
TERMUX_PKG_SRCURL=http://sammy.net/~sammy/hacks/redir-2.2.1.tar.gz |
||||
|
TERMUX_PKG_SHA256=7ea504f835338e448f674ca8637512f511bf74538418ad43ab39039017090e6c |
||||
|
TERMUX_PKG_FOLDERNAME=redir-${TERMUX_PKG_VERSION} |
||||
|
TERMUX_PKG_BUILD_IN_SRC="yes" |
||||
|
TERMUX_PKG_RM_AFTER_INSTALL="share/applications share/pixmaps" |
Loading…
Reference in new issue