Leonid Plyushch
5 years ago
14 changed files with 351 additions and 0 deletions
@ -0,0 +1,12 @@ |
|||||
|
diff -uNr distcc/Makefile.in distcc.mod/Makefile.in
|
||||
|
--- distcc/Makefile.in 2018-07-27 08:08:55.000000000 +0300
|
||||
|
+++ distcc.mod/Makefile.in 2019-02-05 15:54:16.980606827 +0200
|
||||
|
@@ -85,7 +85,7 @@
|
||||
|
# directory names of possible locations for the installation to be |
||||
|
# checked. Change the value of this variable to @bindir@ to check the |
||||
|
# installation at the location determined by 'configure'. |
||||
|
-DISTCC_INSTALLATION = $(RESTRICTED_PATH)
|
||||
|
+DISTCC_INSTALLATION = @bindir@
|
||||
|
|
||||
|
dist_files = \ |
||||
|
src/config.h.in \ |
@ -0,0 +1,20 @@ |
|||||
|
TERMUX_PKG_HOMEPAGE=http://distcc.org/ |
||||
|
TERMUX_PKG_DESCRIPTION="Distributed C/C++ compiler." |
||||
|
TERMUX_PKG_LICENSE="GPL-2.0" |
||||
|
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>" |
||||
|
TERMUX_PKG_VERSION=3.3.3 |
||||
|
TERMUX_PKG_SRCURL=https://github.com/distcc/distcc/releases/download/v$TERMUX_PKG_VERSION/distcc-$TERMUX_PKG_VERSION.tar.gz |
||||
|
TERMUX_PKG_SHA256=bead25471d5a53ecfdf8f065a6fe48901c14d5008956c318c700e56bc87bf0bc |
||||
|
TERMUX_PKG_DEPENDS="libpopt" |
||||
|
TERMUX_PKG_BUILD_IN_SRC=true |
||||
|
|
||||
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" |
||||
|
--disable-pump-mode |
||||
|
--without-avahi |
||||
|
--without-gtk |
||||
|
--without-libiberty" |
||||
|
|
||||
|
termux_step_pre_configure() { |
||||
|
./autogen.sh |
||||
|
export LIBS="-llog" |
||||
|
} |
@ -0,0 +1,13 @@ |
|||||
|
diff -uNr distcc/src/util.c distcc.mod/src/util.c
|
||||
|
--- distcc/src/util.c 2018-07-27 08:08:55.000000000 +0300
|
||||
|
+++ distcc.mod/src/util.c 2019-02-05 16:49:03.805286863 +0200
|
||||
|
@@ -39,6 +39,9 @@
|
||||
|
#include <sys/un.h> |
||||
|
#include <sys/socket.h> |
||||
|
|
||||
|
+#include <linux/in.h>
|
||||
|
+#include <linux/in6.h>
|
||||
|
+
|
||||
|
#ifdef HAVE_SYS_RESOURCE_H |
||||
|
#include <sys/resource.h> |
||||
|
#endif |
@ -0,0 +1,24 @@ |
|||||
|
TERMUX_PKG_HOMEPAGE=https://github.com/mvdan/fdroidcl |
||||
|
TERMUX_PKG_DESCRIPTION="F-Droid client" |
||||
|
TERMUX_PKG_LICENSE="BSD" |
||||
|
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>" |
||||
|
TERMUX_PKG_VERSION=0.5.0 |
||||
|
TERMUX_PKG_REVISION=1 |
||||
|
TERMUX_PKG_SRCURL=https://github.com/mvdan/fdroidcl/archive/v$TERMUX_PKG_VERSION.tar.gz |
||||
|
TERMUX_PKG_SHA256=532a8c4c93216cbf13378ff409c06a08d48e8baee6119a50ed43dc0ce9ec7879 |
||||
|
|
||||
|
termux_step_make() { |
||||
|
termux_setup_golang |
||||
|
export GOPATH=$TERMUX_PKG_BUILDDIR |
||||
|
|
||||
|
mkdir -p "$GOPATH"/src/mvdan.cc |
||||
|
cp -a "$TERMUX_PKG_SRCDIR" "$GOPATH"/src/mvdan.cc/fdroidcl |
||||
|
cd "$GOPATH"/src/mvdan.cc/fdroidcl |
||||
|
|
||||
|
go build . |
||||
|
} |
||||
|
|
||||
|
termux_step_make_install() { |
||||
|
install -Dm700 "$TERMUX_PKG_BUILDDIR"/src/mvdan.cc/fdroidcl/fdroidcl \ |
||||
|
"$TERMUX_PREFIX"/bin/fdroidcl |
||||
|
} |
@ -0,0 +1,17 @@ |
|||||
|
## |
||||
|
## NOTE: script 'fetchmailconf' uses TkInter which is not available |
||||
|
## in Termux variant of python2. |
||||
|
## |
||||
|
TERMUX_PKG_HOMEPAGE=http://www.fetchmail.info/ |
||||
|
TERMUX_PKG_DESCRIPTION="A remote-mail retrieval utility" |
||||
|
TERMUX_PKG_LICENSE="GPL-2.0" |
||||
|
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>" |
||||
|
TERMUX_PKG_VERSION=6.4.1 |
||||
|
TERMUX_PKG_SRCURL=https://sourceforge.net/projects/fetchmail/files/branch_${TERMUX_PKG_VERSION:0:3}/fetchmail-$TERMUX_PKG_VERSION.tar.xz |
||||
|
TERMUX_PKG_SHA256=3f33f11dd08c3e8cc3e9d18eec686b1626d4818f4d5a72791507bbc4dce6a9a0 |
||||
|
TERMUX_PKG_DEPENDS="libcrypt, openssl" |
||||
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-ssl=$TERMUX_PREFIX" |
||||
|
|
||||
|
termux_step_pre_configure() { |
||||
|
export LIBS="-llog" |
||||
|
} |
@ -0,0 +1,45 @@ |
|||||
|
diff -uNr fetchmail-6.4.1/fetchmail.h fetchmail-6.4.1.mod/fetchmail.h
|
||||
|
--- fetchmail-6.4.1/fetchmail.h 2019-09-28 11:52:03.000000000 +0300
|
||||
|
+++ fetchmail-6.4.1.mod/fetchmail.h 2019-10-31 15:03:00.008488320 +0200
|
||||
|
@@ -114,7 +114,7 @@
|
||||
|
#define MSGBUFSIZE 8192 |
||||
|
|
||||
|
#define NAMELEN 64 /* max username length */ |
||||
|
-#define PASSWORDLEN 256 /* max password length */
|
||||
|
+#define FETCHMAIL_PASSWORDLEN 256 /* max password length */
|
||||
|
#define DIGESTLEN 33 /* length of MD5 digest */ |
||||
|
|
||||
|
/* exit code values */ |
||||
|
@@ -463,7 +463,7 @@
|
||||
|
extern flag configdump; /* dump control blocks as Python dictionary */ |
||||
|
extern const char *fetchmailhost; /* either "localhost" or an FQDN */ |
||||
|
extern int suppress_tags; /* suppress tags in tagged protocols? */ |
||||
|
-extern char shroud[PASSWORDLEN*2+3]; /* string to shroud in debug output */
|
||||
|
+extern char shroud[FETCHMAIL_PASSWORDLEN*2+3]; /* string to shroud in debug output */
|
||||
|
#ifdef SDPS_ENABLE |
||||
|
extern char *sdps_envfrom; |
||||
|
extern char *sdps_envto; |
||||
|
diff -uNr fetchmail-6.4.1/getpass.c fetchmail-6.4.1.mod/getpass.c
|
||||
|
--- fetchmail-6.4.1/getpass.c 2019-08-24 11:49:43.000000000 +0300
|
||||
|
+++ fetchmail-6.4.1.mod/getpass.c 2019-10-31 15:03:10.211855090 +0200
|
||||
|
@@ -24,7 +24,7 @@
|
||||
|
#include "fetchmail.h" |
||||
|
#include "i18n.h" |
||||
|
|
||||
|
-#define INPUT_BUF_SIZE PASSWORDLEN
|
||||
|
+#define INPUT_BUF_SIZE FETCHMAIL_PASSWORDLEN
|
||||
|
|
||||
|
#if defined(HAVE_TERMIOS_H) && defined(HAVE_TCSETATTR) |
||||
|
# include <termios.h> |
||||
|
diff -uNr fetchmail-6.4.1/transact.c fetchmail-6.4.1.mod/transact.c
|
||||
|
--- fetchmail-6.4.1/transact.c 2019-08-28 01:30:05.000000000 +0300
|
||||
|
+++ fetchmail-6.4.1.mod/transact.c 2019-10-31 15:03:15.288538378 +0200
|
||||
|
@@ -56,7 +56,7 @@
|
||||
|
/** Macro to generate the tag and store it in #tag. */ |
||||
|
#define GENSYM (sprintf(tag, "A%04u", ++tagnum % TAGMOD), tag) |
||||
|
static const struct method *protocol; /**< description of the protocol used for the current poll */ |
||||
|
-char shroud[PASSWORDLEN*2+3]; /**< string to shroud in debug output */
|
||||
|
+char shroud[FETCHMAIL_PASSWORDLEN*2+3]; /**< string to shroud in debug output */
|
||||
|
|
||||
|
/* session variables initialized in do_session() */ |
||||
|
int mytimeout; /**< value of nonreponse timeout */ |
@ -0,0 +1,33 @@ |
|||||
|
diff -uNr fetchmail-6.3.26/Makefile.am fetchmail-6.3.26.mod/Makefile.am
|
||||
|
--- fetchmail-6.3.26/Makefile.am 2013-04-23 23:00:45.000000000 +0300
|
||||
|
+++ fetchmail-6.3.26.mod/Makefile.am 2019-07-01 23:34:02.456251878 +0300
|
||||
|
@@ -190,7 +190,7 @@
|
||||
|
Doxyfile |
||||
|
|
||||
|
fetchmailconf: |
||||
|
- ( echo '#! /bin/sh' && echo 'exec @PYTHON@ @pythondir@/fetchmailconf.py "$$@"' ) >$@ && chmod +x $@ || { rm -f $@ ; exit 1; }
|
||||
|
+ ( echo '#! /bin/sh' && echo 'exec python2 @pythondir@/fetchmailconf.py "$$@"' ) >$@ && chmod +x $@ || { rm -f $@ ; exit 1; }
|
||||
|
|
||||
|
FAQ: fetchmail-FAQ.html $(srcdir)/dist-tools/html2txt |
||||
|
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/fetchmail-FAQ.html >$@ || { rm -f $@ ; exit 1 ; } |
||||
|
diff -uNr fetchmail-6.3.26/Makefile.in fetchmail-6.3.26.mod/Makefile.in
|
||||
|
--- fetchmail-6.3.26/Makefile.in 2013-04-24 00:36:56.000000000 +0300
|
||||
|
+++ fetchmail-6.3.26.mod/Makefile.in 2019-07-01 23:33:45.826122087 +0300
|
||||
|
@@ -1754,7 +1754,7 @@
|
||||
|
$(srcdir)/specgen.sh $(VERSION) >fetchmail.spec |
||||
|
|
||||
|
fetchmailconf: |
||||
|
- ( echo '#! /bin/sh' && echo 'exec @PYTHON@ @pythondir@/fetchmailconf.py "$$@"' ) >$@ && chmod +x $@ || { rm -f $@ ; exit 1; }
|
||||
|
+ ( echo '#! /bin/sh' && echo 'exec python2 @pythondir@/fetchmailconf.py "$$@"' ) >$@ && chmod +x $@ || { rm -f $@ ; exit 1; }
|
||||
|
|
||||
|
FAQ: fetchmail-FAQ.html $(srcdir)/dist-tools/html2txt |
||||
|
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/fetchmail-FAQ.html >$@ || { rm -f $@ ; exit 1 ; } |
||||
|
diff -uNr fetchmail-6.3.26/fetchmailconf.py fetchmail-6.3.26.mod/fetchmailconf.py
|
||||
|
--- fetchmail-6.3.26/fetchmailconf.py 2013-04-23 23:00:45.000000000 +0300
|
||||
|
+++ fetchmail-6.3.26.mod/fetchmailconf.py 2019-07-01 23:21:00.873525116 +0300
|
||||
|
@@ -1,4 +1,4 @@
|
||||
|
-#!/usr/bin/env python
|
||||
|
+#!/usr/bin/env python2
|
||||
|
# |
||||
|
# A GUI configurator for generating fetchmail configuration files. |
||||
|
# by Eric S. Raymond, <esr@snark.thyrsus.com>, |
@ -0,0 +1,62 @@ |
|||||
|
TERMUX_PKG_HOMEPAGE=http://www.nongnu.org/nmh/ |
||||
|
TERMUX_PKG_DESCRIPTION="Powerful electronic mail handling system" |
||||
|
TERMUX_PKG_LICENSE="BSD" |
||||
|
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>" |
||||
|
TERMUX_PKG_VERSION=1.7.1 |
||||
|
TERMUX_PKG_REVISION=1 |
||||
|
TERMUX_PKG_SRCURL=http://download.savannah.nongnu.org/releases/nmh/nmh-$TERMUX_PKG_VERSION.tar.gz |
||||
|
TERMUX_PKG_SHA256=f1fb94bbf7d95fcd43277c7cfda55633a047187f57afc6c1bb9321852bd07c11 |
||||
|
TERMUX_PKG_DEPENDS="gdbm, libdb, libiconv, libsasl, openssl" |
||||
|
TERMUX_PKG_BUILD_DEPENDS="ncurses" |
||||
|
|
||||
|
# We don't have complete sendmail utility. |
||||
|
# Using here a one from busybox, even if it may not work. |
||||
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" |
||||
|
ac_cv_path_sendmailpath=$TERMUX_PREFIX/bin/applets/sendmail |
||||
|
--with-cyrus-sasl |
||||
|
--with-tls" |
||||
|
|
||||
|
TERMUX_PKG_CONFFILES=" |
||||
|
etc/nmh/MailAliases |
||||
|
etc/nmh/components |
||||
|
etc/nmh/digestcomps |
||||
|
etc/nmh/distcomps |
||||
|
etc/nmh/forwcomps |
||||
|
etc/nmh/mhl.body |
||||
|
etc/nmh/mhl.digest |
||||
|
etc/nmh/mhl.format |
||||
|
etc/nmh/mhl.forward |
||||
|
etc/nmh/mhl.headers |
||||
|
etc/nmh/mhl.reply |
||||
|
etc/nmh/mhn.defaults |
||||
|
etc/nmh/mts.conf |
||||
|
etc/nmh/rcvdistcomps |
||||
|
etc/nmh/rcvdistcomps.outbox |
||||
|
etc/nmh/replcomps |
||||
|
etc/nmh/replgroupcomps |
||||
|
etc/nmh/scan.MMDDYY |
||||
|
etc/nmh/scan.YYYYMMDD |
||||
|
etc/nmh/scan.default |
||||
|
etc/nmh/scan.mailx |
||||
|
etc/nmh/scan.nomime |
||||
|
etc/nmh/scan.size |
||||
|
etc/nmh/scan.time |
||||
|
etc/nmh/scan.timely |
||||
|
etc/nmh/scan.unseen" |
||||
|
|
||||
|
termux_step_pre_configure() { |
||||
|
TERMUX_MAKE_PROCESSES=1 |
||||
|
autoreconf -fi |
||||
|
} |
||||
|
|
||||
|
termux_step_post_make_install() { |
||||
|
# We disabled hardlinks with a patch. Replace them with |
||||
|
# symlinks here. |
||||
|
ln -sfr "$TERMUX_PREFIX"/bin/flist "$TERMUX_PREFIX"/bin/flists |
||||
|
ln -sfr "$TERMUX_PREFIX"/bin/folder "$TERMUX_PREFIX"/bin/folders |
||||
|
ln -sfr "$TERMUX_PREFIX"/bin/new "$TERMUX_PREFIX"/bin/fnext |
||||
|
ln -sfr "$TERMUX_PREFIX"/bin/new "$TERMUX_PREFIX"/bin/fprev |
||||
|
ln -sfr "$TERMUX_PREFIX"/bin/new "$TERMUX_PREFIX"/bin/unseen |
||||
|
ln -sfr "$TERMUX_PREFIX"/bin/show "$TERMUX_PREFIX"/bin/prev |
||||
|
ln -sfr "$TERMUX_PREFIX"/bin/show "$TERMUX_PREFIX"/bin/next |
||||
|
} |
@ -0,0 +1,24 @@ |
|||||
|
diff -uNr nmh-1.7.1/Makefile.am nmh-1.7.1.mod/Makefile.am
|
||||
|
--- nmh-1.7.1/Makefile.am 2018-03-06 21:05:55.000000000 +0200
|
||||
|
+++ nmh-1.7.1.mod/Makefile.am 2019-07-01 14:28:31.650669954 +0300
|
||||
|
@@ -901,13 +901,13 @@
|
||||
|
@rm -f $(DESTDIR)$(bindir)/unseen$(EXEEXT) |
||||
|
@rm -f $(DESTDIR)$(bindir)/prev$(EXEEXT) |
||||
|
@rm -f $(DESTDIR)$(bindir)/next$(EXEEXT) |
||||
|
- $(LN) $(DESTDIR)$(bindir)/flist$(EXEEXT) $(DESTDIR)$(bindir)/flists$(EXEEXT)
|
||||
|
- $(LN) $(DESTDIR)$(bindir)/folder$(EXEEXT) $(DESTDIR)$(bindir)/folders$(EXEEXT)
|
||||
|
- $(LN) $(DESTDIR)$(bindir)/new$(EXEEXT) $(DESTDIR)$(bindir)/fnext$(EXEEXT)
|
||||
|
- $(LN) $(DESTDIR)$(bindir)/new$(EXEEXT) $(DESTDIR)$(bindir)/fprev$(EXEEXT)
|
||||
|
- $(LN) $(DESTDIR)$(bindir)/new$(EXEEXT) $(DESTDIR)$(bindir)/unseen$(EXEEXT)
|
||||
|
- $(LN) $(DESTDIR)$(bindir)/show$(EXEEXT) $(DESTDIR)$(bindir)/prev$(EXEEXT)
|
||||
|
- $(LN) $(DESTDIR)$(bindir)/show$(EXEEXT) $(DESTDIR)$(bindir)/next$(EXEEXT)
|
||||
|
+# $(LN) $(DESTDIR)$(bindir)/flist$(EXEEXT) $(DESTDIR)$(bindir)/flists$(EXEEXT)
|
||||
|
+# $(LN) $(DESTDIR)$(bindir)/folder$(EXEEXT) $(DESTDIR)$(bindir)/folders$(EXEEXT)
|
||||
|
+# $(LN) $(DESTDIR)$(bindir)/new$(EXEEXT) $(DESTDIR)$(bindir)/fnext$(EXEEXT)
|
||||
|
+# $(LN) $(DESTDIR)$(bindir)/new$(EXEEXT) $(DESTDIR)$(bindir)/fprev$(EXEEXT)
|
||||
|
+# $(LN) $(DESTDIR)$(bindir)/new$(EXEEXT) $(DESTDIR)$(bindir)/unseen$(EXEEXT)
|
||||
|
+# $(LN) $(DESTDIR)$(bindir)/show$(EXEEXT) $(DESTDIR)$(bindir)/prev$(EXEEXT)
|
||||
|
+# $(LN) $(DESTDIR)$(bindir)/show$(EXEEXT) $(DESTDIR)$(bindir)/next$(EXEEXT)
|
||||
|
if test x$(SETGID_MAIL) != x; then \ |
||||
|
chgrp $(MAIL_SPOOL_GRP) $(DESTDIR)$(bindir)/inc$(EXEEXT) && \ |
||||
|
chmod 2755 $(DESTDIR)$(bindir)/inc$(EXEEXT); \ |
@ -0,0 +1,29 @@ |
|||||
|
TERMUX_PKG_HOMEPAGE=https://racket-lang.org |
||||
|
TERMUX_PKG_DESCRIPTION="Full-spectrum programming language going beyond Lisp and Scheme" |
||||
|
TERMUX_PKG_LICENSE="GPL-3.0, LGPL-3.0" |
||||
|
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>" |
||||
|
TERMUX_PKG_VERSION=7.4 |
||||
|
TERMUX_PKG_SRCURL=https://www.cs.utah.edu/plt/installers/${TERMUX_PKG_VERSION}/racket-minimal-${TERMUX_PKG_VERSION}-src-builtpkgs.tgz |
||||
|
TERMUX_PKG_SHA256=c819608cee733c98241e329274f3567956baaaa7283e061e45342f533bd9a51b |
||||
|
TERMUX_PKG_DEPENDS="libffi, libiconv" |
||||
|
TERMUX_PKG_NO_DEVELSPLIT=true |
||||
|
TERMUX_PKG_HOSTBUILD=true |
||||
|
|
||||
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" |
||||
|
--enable-racket=$TERMUX_PKG_HOSTBUILD_DIR/racket/racketcgc |
||||
|
--enable-libs |
||||
|
--disable-shared |
||||
|
--disable-gracket |
||||
|
--enable-libffi" |
||||
|
|
||||
|
termux_step_host_build() { |
||||
|
"$TERMUX_PKG_SRCDIR"/src/configure \ |
||||
|
$TERMUX_PKG_EXTRA_HOSTBUILD_CONFIGURE_ARGS |
||||
|
make -j "$TERMUX_MAKE_PROCESSES" |
||||
|
} |
||||
|
|
||||
|
termux_step_pre_configure() { |
||||
|
CPPFLAGS+=" -I$TERMUX_PKG_SRCDIR/src/racket/include -I$TERMUX_PKG_BUILDDIR/racket" |
||||
|
LDFLAGS+=" -liconv -llog" |
||||
|
export TERMUX_PKG_SRCDIR="$TERMUX_PKG_SRCDIR/src" |
||||
|
} |
@ -0,0 +1,12 @@ |
|||||
|
diff -u -r ../racket-6.6/collects/racket/system.rkt ./collects/racket/system.rkt
|
||||
|
--- ../racket-6.6/collects/racket/system.rkt 2016-04-15 16:33:56.000000000 -0400
|
||||
|
+++ ./collects/racket/system.rkt 2016-11-22 16:45:09.576844179 -0500
|
||||
|
@@ -17,7 +17,7 @@
|
||||
|
|
||||
|
(define (shell-path/args who argstr) |
||||
|
(case (system-type) |
||||
|
- [(unix macosx) (append '("/bin/sh" "-c") (list argstr))]
|
||||
|
+ [(unix macosx) (append '("@TERMUX_PREFIX@/bin/sh" "-c") (list argstr))]
|
||||
|
[(windows) (let ([cmd |
||||
|
(let ([d (find-system-path 'sys-dir)]) |
||||
|
(let ([cmd (build-path d "cmd.exe")]) |
@ -0,0 +1,10 @@ |
|||||
|
--- ../cache/racket-6.11/src/racket/gc2/newgc.c 2017-07-07 19:13:22.000000000 +0000
|
||||
|
+++ ./src/racket/gc2/newgc.c 2018-01-05 05:55:28.900376813 +0000
|
||||
|
@@ -10,6 +10,7 @@
|
||||
|
#include <stdio.h> |
||||
|
#include <string.h> |
||||
|
#include <errno.h> |
||||
|
+#include <strings.h>
|
||||
|
#include "platforms.h" |
||||
|
#include "../src/schpriv.h" |
||||
|
#include "gc2.h" |
@ -0,0 +1,18 @@ |
|||||
|
--- ../cache/racket-6.12/src/rktio/rktio_dll.c 2017-10-12 18:23:27.000000000 +0000
|
||||
|
+++ ./src/rktio/rktio_dll.c 2018-03-18 01:22:17.345952252 +0000
|
||||
|
@@ -1,5 +1,6 @@
|
||||
|
#include "rktio.h" |
||||
|
#include "rktio_private.h" |
||||
|
+#include "scheme.h"
|
||||
|
#include <stdlib.h> |
||||
|
#include <string.h> |
||||
|
|
||||
|
@@ -63,7 +64,7 @@
|
||||
|
return dll; |
||||
|
|
||||
|
#ifdef RKTIO_SYSTEM_UNIX |
||||
|
-# if defined(__ANDROID__)
|
||||
|
+# if defined(__ANDROID__) && !defined(__x86_64__) && !defined(__aarch64__)
|
||||
|
if (!name) handle = RTLD_DEFAULT; else |
||||
|
# elif defined(__CYGWIN32__) |
||||
|
if (!name) { handle = RTLD_DEFAULT; null_ok = 1; } else |
@ -0,0 +1,32 @@ |
|||||
|
--- ../cache/racket-6.12/src/racket/sconfig.h 2017-10-12 18:23:27.000000000 +0000
|
||||
|
+++ ./src/racket/sconfig.h 2018-02-07 01:18:13.911569478 +0000
|
||||
|
@@ -124,10 +124,12 @@
|
||||
|
# endif |
||||
|
# if defined(__x86_64__) |
||||
|
# define SCHEME_PLATFORM_LIBRARY_SUBPATH "x86_64-"SPLS_LINUX |
||||
|
# define REGISTER_POOR_MACHINE |
||||
|
# define ASM_DBLPREC_CONTROL_87 |
||||
|
+#ifndef __ANDROID__
|
||||
|
# define MZ_TRY_EXTFLONUMS |
||||
|
# endif |
||||
|
+# endif
|
||||
|
# ifndef SCHEME_PLATFORM_LIBRARY_SUBPATH |
||||
|
# define SCHEME_PLATFORM_LIBRARY_SUBPATH "unknown-"SPLS_LINUX |
||||
|
# endif |
||||
|
@@ -147,12 +149,16 @@
|
||||
|
#if defined(__i386__) |
||||
|
# define MZ_USE_JIT_I386 |
||||
|
# define MZ_JIT_USE_MPROTECT |
||||
|
+#ifndef __ANDROID__
|
||||
|
# define MZ_USE_DWARF_LIBUNWIND |
||||
|
#endif |
||||
|
+#endif
|
||||
|
#if defined(__x86_64__) |
||||
|
# define MZ_USE_JIT_X86_64 |
||||
|
# define MZ_JIT_USE_MPROTECT |
||||
|
+#ifndef __ANDROID__
|
||||
|
# define MZ_USE_DWARF_LIBUNWIND |
||||
|
+#endif
|
||||
|
#endif |
||||
|
#if defined(__powerpc__) && !defined(__powerpc64__) |
||||
|
# define MZ_USE_JIT_PPC |
Loading…
Reference in new issue