Browse Source

liblz4: fix build & installation steps

* Run only `make install` to avoid compiling libs & tools 2 times.

* Always use `ln -sf` when creating symlinks.
emacs-27
Leonid Plyushch 5 years ago
parent
commit
54eb668e8b
No known key found for this signature in database GPG Key ID: 45F2964132545795
  1. 12
      packages/liblz4/Makefile.inc.patch
  2. 6
      packages/liblz4/build.sh

12
packages/liblz4/Makefile.inc.patch

@ -0,0 +1,12 @@
diff -uNr lz4-1.9.2/Makefile.inc lz4-1.9.2.mod/Makefile.inc
--- lz4-1.9.2/Makefile.inc 2019-08-15 14:59:59.000000000 +0300
+++ lz4-1.9.2.mod/Makefile.inc 2019-09-09 03:40:49.761918035 +0300
@@ -70,7 +70,7 @@
LN_S = cp -p
LN_SF = cp -p
else
-LN_S = ln -s
+LN_S = ln -sf
LN_SF = ln -sf
endif
endif

6
packages/liblz4/build.sh

@ -11,3 +11,9 @@ TERMUX_PKG_BUILD_IN_SRC=true
termux_step_pre_configure() {
TERMUX_PKG_SRCDIR+=lib
}
# Do not execute this step since on `make install` it will
# recompile libraries & tools again.
termux_step_make() {
:
}

Loading…
Cancel
Save