Browse Source
Previously aliases such as arm-linux-androideabi-gcc was removed from the gcc package. This causes trouble and confusion for things that pick up the C compiler they where compiled with (e.g. ruby, go).android-5
Fredrik Fornwall
9 years ago
3 changed files with 60 additions and 49 deletions
@ -0,0 +1,58 @@ |
|||
The first block is to install aliases such as arm-linux-androideabi-gcc->gcc |
|||
as symlinks instead of hard links. |
|||
|
|||
diff -u -r ../gcc-4.9.3/gcc/Makefile.in ./gcc/Makefile.in
|
|||
--- ../gcc-4.9.3/gcc/Makefile.in 2014-10-16 09:50:42.000000000 -0400
|
|||
+++ ./gcc/Makefile.in 2015-08-16 18:12:44.446098799 -0400
|
|||
@@ -260,7 +260,7 @@
|
|||
INSTALL = @INSTALL@ |
|||
# Some systems may be missing symbolic links, regular links, or both. |
|||
# Allow configure to check this and use "ln -s", "ln", or "cp" as appropriate. |
|||
-LN=@LN@
|
|||
+LN=@LN_S@
|
|||
LN_S=@LN_S@ |
|||
# These permit overriding just for certain files. |
|||
INSTALL_PROGRAM = @INSTALL_PROGRAM@ |
|||
@@ -2430,27 +2430,29 @@
|
|||
|
|||
gengtype-lex.o build/gengtype-lex.o : gengtype-lex.c gengtype.h $(SYSTEM_H) |
|||
gengtype-lex.o: $(CONFIG_H) $(BCONFIG_H) |
|||
-CFLAGS-gengtype-lex.o += -DGENERATOR_FILE
|
|||
+CFLAGS-build/gengtype-lex.o += -DGENERATOR_FILE
|
|||
build/gengtype-lex.o: $(BCONFIG_H) |
|||
|
|||
gengtype-parse.o build/gengtype-parse.o : gengtype-parse.c gengtype.h \ |
|||
$(SYSTEM_H) |
|||
gengtype-parse.o: $(CONFIG_H) |
|||
-CFLAGS-gengtype-parse.o += -DGENERATOR_FILE
|
|||
+CFLAGS-build/gengtype-parse.o += -DGENERATOR_FILE
|
|||
build/gengtype-parse.o: $(BCONFIG_H) |
|||
|
|||
gengtype-state.o build/gengtype-state.o: gengtype-state.c $(SYSTEM_H) \ |
|||
gengtype.h errors.h double-int.h version.h $(HASHTAB_H) $(OBSTACK_H) \ |
|||
$(XREGEX_H) |
|||
gengtype-state.o: $(CONFIG_H) |
|||
-CFLAGS-gengtype-state.o += -DGENERATOR_FILE
|
|||
+CFLAGS-gengtype-state.o += -DGENERATOR_FILE2
|
|||
+CFLAGS-build/gengtype-state.o += -DGENERATOR_FILE
|
|||
build/gengtype-state.o: $(BCONFIG_H) |
|||
|
|||
gengtype.o build/gengtype.o : gengtype.c $(SYSTEM_H) gengtype.h \ |
|||
rtl.def insn-notes.def errors.h double-int.h version.h $(HASHTAB_H) \ |
|||
$(OBSTACK_H) $(XREGEX_H) |
|||
gengtype.o: $(CONFIG_H) |
|||
-CFLAGS-gengtype.o += -DGENERATOR_FILE
|
|||
+CFLAGS-gengtype.o += -DGENERATOR_FILE2
|
|||
+CFLAGS-build/gengtype.o += -DGENERATOR_FILE
|
|||
build/gengtype.o: $(BCONFIG_H) |
|||
|
|||
build/genmddeps.o: genmddeps.c $(BCONFIG_H) $(SYSTEM_H) coretypes.h \ |
|||
@@ -2515,7 +2517,7 @@
|
|||
# any system header is included. |
|||
gengtype-lex.c : gengtype-lex.l |
|||
-$(FLEX) $(FLEXFLAGS) -o$@ $< && { \ |
|||
- echo '#include "bconfig.h"' > $@.tmp; \
|
|||
+ echo '' > $@.tmp; \
|
|||
cat $@ >> $@.tmp; \ |
|||
mv $@.tmp $@; \ |
|||
} |
Loading…
Reference in new issue